aboutsummaryrefslogtreecommitdiff
diff options
context:
space:
mode:
Diffstat (limited to 'sci-biology/deeptools/deeptools-3.5.0.ebuild')
-rw-r--r--sci-biology/deeptools/deeptools-3.5.0.ebuild15
1 files changed, 8 insertions, 7 deletions
diff --git a/sci-biology/deeptools/deeptools-3.5.0.ebuild b/sci-biology/deeptools/deeptools-3.5.0.ebuild
index f53a19bcb..7c2eaa739 100644
--- a/sci-biology/deeptools/deeptools-3.5.0.ebuild
+++ b/sci-biology/deeptools/deeptools-3.5.0.ebuild
@@ -1,9 +1,10 @@
-# Copyright 1999-2021 Gentoo Authors
+# Copyright 1999-2023 Gentoo Authors
# Distributed under the terms of the GNU General Public License v2
-EAPI=7
+EAPI=8
-PYTHON_COMPAT=( python3_{7,8,9} )
+DISTUTILS_USE_PEP517=setuptools
+PYTHON_COMPAT=( python3_{10..11} )
inherit distutils-r1
@@ -13,7 +14,7 @@ SRC_URI="https://github.com/deeptools/deepTools/archive/${PV}.tar.gz -> ${P}.tar
LICENSE="BSD"
SLOT="0"
-KEYWORDS="~amd64 ~x86"
+KEYWORDS="~amd64"
# TODO: fix this
RESTRICT="test"
@@ -23,7 +24,7 @@ RDEPEND="
>=dev-python/numpy-1.9.0[${PYTHON_USEDEP}]
>=dev-python/numpydoc-0.5[${PYTHON_USEDEP}]
>=dev-python/scipy-0.17.0[${PYTHON_USEDEP}]
- >=dev-python/plotly-2.0.0[${PYTHON_USEDEP}]
+ dev-python/plotly[${PYTHON_USEDEP}]
>=dev-python/py2bit-0.2.0[${PYTHON_USEDEP}]
>=dev-python/pyBigWig-0.2.1[${PYTHON_USEDEP}]
>=sci-biology/pysam-0.14.0[${PYTHON_USEDEP}]
@@ -32,5 +33,5 @@ RDEPEND="
S="${WORKDIR}/deepTools-${PV}"
-distutils_enable_sphinx docs dev-python/sphinx_rtd_theme dev-python/sphinx-argparse
-distutils_enable_tests nose
+distutils_enable_sphinx docs dev-python/sphinx-rtd-theme dev-python/sphinx-argparse
+#distutils_enable_tests nose