aboutsummaryrefslogtreecommitdiff
diff options
context:
space:
mode:
Diffstat (limited to 'sci-biology/deeptools')
-rw-r--r--sci-biology/deeptools/Manifest1
-rw-r--r--sci-biology/deeptools/deeptools-3.5.0.ebuild15
-rw-r--r--sci-biology/deeptools/deeptools-3.5.1.ebuild37
3 files changed, 46 insertions, 7 deletions
diff --git a/sci-biology/deeptools/Manifest b/sci-biology/deeptools/Manifest
index 31a5bdb90..649a31cdf 100644
--- a/sci-biology/deeptools/Manifest
+++ b/sci-biology/deeptools/Manifest
@@ -1 +1,2 @@
DIST deeptools-3.5.0.tar.gz 62553343 BLAKE2B a8cd1520b96c50ad36667405677cf422a74376d88f0716f83cc0c6f58d01aefcf47ac1b862aa98b8801e61445d59831dbc9246660e2f41a5b3e0ed3d6573ad50 SHA512 699734c8a863ec76dfead728e3227bbe3ec04d62e91f447269a6aa8406d627ff618837b85ab2e31cc635c671e1d62230c4db0992106bbe921281b81164387b38
+DIST deeptools-3.5.1.tar.gz 62552044 BLAKE2B 3c785ba478b88fbbe7ba2617e2d05984b8a897f787e85d6f8f144f596af07b9e16ba920c8adee35efc4b1b067f255e81f66cf746aaea43e5ee61c23c4d15c9c3 SHA512 f7618f1a51b975d42712a38e13e9ab2ddfeafffe24d81fdab41f1ef7c2e44fd09da0351210670b0036bf72e7af11b679417275adce300ae9fabe4b5339ee9810
diff --git a/sci-biology/deeptools/deeptools-3.5.0.ebuild b/sci-biology/deeptools/deeptools-3.5.0.ebuild
index f53a19bcb..7c2eaa739 100644
--- a/sci-biology/deeptools/deeptools-3.5.0.ebuild
+++ b/sci-biology/deeptools/deeptools-3.5.0.ebuild
@@ -1,9 +1,10 @@
-# Copyright 1999-2021 Gentoo Authors
+# Copyright 1999-2023 Gentoo Authors
# Distributed under the terms of the GNU General Public License v2
-EAPI=7
+EAPI=8
-PYTHON_COMPAT=( python3_{7,8,9} )
+DISTUTILS_USE_PEP517=setuptools
+PYTHON_COMPAT=( python3_{10..11} )
inherit distutils-r1
@@ -13,7 +14,7 @@ SRC_URI="https://github.com/deeptools/deepTools/archive/${PV}.tar.gz -> ${P}.tar
LICENSE="BSD"
SLOT="0"
-KEYWORDS="~amd64 ~x86"
+KEYWORDS="~amd64"
# TODO: fix this
RESTRICT="test"
@@ -23,7 +24,7 @@ RDEPEND="
>=dev-python/numpy-1.9.0[${PYTHON_USEDEP}]
>=dev-python/numpydoc-0.5[${PYTHON_USEDEP}]
>=dev-python/scipy-0.17.0[${PYTHON_USEDEP}]
- >=dev-python/plotly-2.0.0[${PYTHON_USEDEP}]
+ dev-python/plotly[${PYTHON_USEDEP}]
>=dev-python/py2bit-0.2.0[${PYTHON_USEDEP}]
>=dev-python/pyBigWig-0.2.1[${PYTHON_USEDEP}]
>=sci-biology/pysam-0.14.0[${PYTHON_USEDEP}]
@@ -32,5 +33,5 @@ RDEPEND="
S="${WORKDIR}/deepTools-${PV}"
-distutils_enable_sphinx docs dev-python/sphinx_rtd_theme dev-python/sphinx-argparse
-distutils_enable_tests nose
+distutils_enable_sphinx docs dev-python/sphinx-rtd-theme dev-python/sphinx-argparse
+#distutils_enable_tests nose
diff --git a/sci-biology/deeptools/deeptools-3.5.1.ebuild b/sci-biology/deeptools/deeptools-3.5.1.ebuild
new file mode 100644
index 000000000..7c2eaa739
--- /dev/null
+++ b/sci-biology/deeptools/deeptools-3.5.1.ebuild
@@ -0,0 +1,37 @@
+# Copyright 1999-2023 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+DISTUTILS_USE_PEP517=setuptools
+PYTHON_COMPAT=( python3_{10..11} )
+
+inherit distutils-r1
+
+DESCRIPTION="Extract reads from BAM files, normalize, draw figures, convert BAM to bigWig"
+HOMEPAGE="https://github.com/deeptools/deepTools"
+SRC_URI="https://github.com/deeptools/deepTools/archive/${PV}.tar.gz -> ${P}.tar.gz"
+
+LICENSE="BSD"
+SLOT="0"
+KEYWORDS="~amd64"
+
+# TODO: fix this
+RESTRICT="test"
+
+RDEPEND="
+ >=sci-biology/deeptools-intervals-0.1.8[${PYTHON_USEDEP}]
+ >=dev-python/numpy-1.9.0[${PYTHON_USEDEP}]
+ >=dev-python/numpydoc-0.5[${PYTHON_USEDEP}]
+ >=dev-python/scipy-0.17.0[${PYTHON_USEDEP}]
+ dev-python/plotly[${PYTHON_USEDEP}]
+ >=dev-python/py2bit-0.2.0[${PYTHON_USEDEP}]
+ >=dev-python/pyBigWig-0.2.1[${PYTHON_USEDEP}]
+ >=sci-biology/pysam-0.14.0[${PYTHON_USEDEP}]
+ >=dev-python/matplotlib-3.1.0[${PYTHON_USEDEP}]
+"
+
+S="${WORKDIR}/deepTools-${PV}"
+
+distutils_enable_sphinx docs dev-python/sphinx-rtd-theme dev-python/sphinx-argparse
+#distutils_enable_tests nose