aboutsummaryrefslogtreecommitdiff
diff options
context:
space:
mode:
Diffstat (limited to 'sci-biology/discrover/discrover-1.3.1.ebuild')
-rw-r--r--sci-biology/discrover/discrover-1.3.1.ebuild75
1 files changed, 75 insertions, 0 deletions
diff --git a/sci-biology/discrover/discrover-1.3.1.ebuild b/sci-biology/discrover/discrover-1.3.1.ebuild
new file mode 100644
index 000000000..c892c73cf
--- /dev/null
+++ b/sci-biology/discrover/discrover-1.3.1.ebuild
@@ -0,0 +1,75 @@
+# Copyright 1999-2014 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: $
+
+EAPI=5
+inherit cmake-utils
+
+DESCRIPTION="A sequence motif discovery tool that uses discriminative learning"
+HOMEPAGE="https://github.com/maaskola/discrover"
+SRC_URI="https://github.com/maaskola/discrover/archive/${PV}.tar.gz -> ${P}.tar.gz"
+
+LICENSE="GPL-3+"
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+IUSE="dreme doc +logo misc_scripts +rmathlib tcmalloc"
+
+RDEPEND="
+ dev-libs/boost
+ dreme? ( sci-biology/meme )
+ logo? (
+ dev-lang/ruby
+ dev-texlive/texlive-latex
+ dev-texlive/texlive-latexextra
+ dev-tex/pgf
+ dev-tex/xcolor
+ media-gfx/imagemagick
+ )
+ misc_scripts? ( dev-lang/ruby )
+ rmathlib? ( dev-lang/R )
+ tcmalloc? ( dev-util/google-perftools )
+"
+DEPEND="${RDEPEND}
+ doc? (
+ dev-texlive/texlive-latex
+ dev-texlive/texlive-latexextra
+ dev-texlive/texlive-latexrecommended
+ media-gfx/imagemagick
+ )
+"
+src_configure() {
+ local mycmakeargs=(
+ $(cmake-utils_use_with dreme DREME)
+ $(cmake-utils_use_with doc DOC)
+ $(cmake-utils_use_with logo LOGO)
+ $(cmake-utils_use_with misc_scripts MISC_SCRIPTS)
+ $(cmake-utils_use_with rmathlib RMATHLIB)
+ $(cmake-utils_use_with tcmalloc TCMALLOC)
+ )
+
+ unset R_HOME
+
+ if use rmathlib ; then
+ elog
+ elog "Using statistical routines from standalone Rmathlib."
+ elog
+ fi
+ if use dreme ; then
+ elog
+ elog "Linking to DREME from the MEME suite."
+ elog
+ else
+ elog
+ elog "Not linking to DREME from the MEME suite (sci-biology/meme)."
+ elog "You will not be able to use DREME to find seeds."
+ elog
+ fi
+
+ if use doc ; then
+ elog
+ elog "User manual available at /usr/share/doc/discrover/discrover-manual.pdf"
+ elog
+ fi
+
+ cmake-utils_src_configure
+}