aboutsummaryrefslogtreecommitdiff
diff options
context:
space:
mode:
Diffstat (limited to 'sci-biology/ePCR/ePCR-2.3.12.ebuild')
-rw-r--r--sci-biology/ePCR/ePCR-2.3.12.ebuild34
1 files changed, 34 insertions, 0 deletions
diff --git a/sci-biology/ePCR/ePCR-2.3.12.ebuild b/sci-biology/ePCR/ePCR-2.3.12.ebuild
new file mode 100644
index 000000000..8e71c90be
--- /dev/null
+++ b/sci-biology/ePCR/ePCR-2.3.12.ebuild
@@ -0,0 +1,34 @@
+# Copyright 1999-2012 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: $
+
+EAPI=3
+
+inherit eutils
+
+DESCRIPTION="Search for sub-sequences matching PCR primers with correct order, orientation, and spacing"
+HOMEPAGE="http://www.ncbi.nlm.nih.gov/projects/e-pcr/"
+SRC_URI="ftp://ftp.ncbi.nlm.nih.gov/pub/schuler/e-PCR/e-PCR-"${PV}"-src.tar.gz"
+
+LICENSE=""
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+IUSE=""
+
+DEPEND=""
+RDEPEND="${DEPEND}"
+
+S=${WORKDIR}"/e-PCR-"${PV}
+
+src_prepare(){
+ epatch ${FILESDIR}"/config.mk.patch"
+}
+
+src_compile(){
+ make -j1 srcdir=${S} objdir=${S} || die "make -j1 failed"
+}
+
+src_install(){
+ dobin e-PCR famap fahash re-PCR
+ dodoc README.TXT
+}