aboutsummaryrefslogtreecommitdiff
diff options
context:
space:
mode:
Diffstat (limited to 'sci-biology/exonerate-gff3/exonerate-gff3-9999.ebuild')
-rw-r--r--sci-biology/exonerate-gff3/exonerate-gff3-9999.ebuild55
1 files changed, 55 insertions, 0 deletions
diff --git a/sci-biology/exonerate-gff3/exonerate-gff3-9999.ebuild b/sci-biology/exonerate-gff3/exonerate-gff3-9999.ebuild
new file mode 100644
index 000000000..2c6d11c6d
--- /dev/null
+++ b/sci-biology/exonerate-gff3/exonerate-gff3-9999.ebuild
@@ -0,0 +1,55 @@
+# Copyright 1999-2015 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/sci-biology/exonerate/exonerate-2.2.0-r1.ebuild,v 1.5 2013/01/25 16:24:50 jlec Exp $
+
+EAPI=5
+
+AUTOTOOLS_AUTORECONF=true
+
+inherit autotools-utils toolchain-funcs git-r3
+
+DESCRIPTION="exonerate-2.2.0 with patches to add GFF3 formatted output"
+HOMEPAGE="https://github.com/hotdogee/exonerate-gff3"
+SRC_URI=""
+EGIT_REPO_URI="https://github.com/hotdogee/exonerate-gff3.git"
+
+LICENSE="GPL-3"
+SLOT="0"
+KEYWORDS=""
+IUSE="utils test threads"
+
+REQUIRED_USE="test? ( utils )"
+
+# block with sci-biology/exonerate , maybe the best would be to change SRC_URI in sci-biology/exonerate
+DEPEND="
+ !sci-biology/exonerate
+ dev-libs/glib:2"
+RDEPEND="${DEPEND}"
+
+AUTOTOOLS_IN_SOURCE_BUILD=1
+
+PATCHES=( "${FILESDIR}"/${P}-asneeded.patch )
+
+src_prepare() {
+ tc-export CC
+ sed \
+ -e 's: -O3 -finline-functions::g' \
+ -i configure.in || die
+ mc configure.in configure.ac
+ autotools-utils_src_prepare
+}
+
+src_configure() {
+ local myeconfargs=(
+ $(use_enable utils utilities)
+ $(use_enable threads pthreads)
+ --enable-largefile
+ --enable-glib2
+ )
+ autotools-utils_src_configure
+}
+
+src_install() {
+ autotools-utils_src_install
+ doman doc/man/man1/*.1
+}