aboutsummaryrefslogtreecommitdiff
diff options
context:
space:
mode:
Diffstat (limited to 'sci-biology/fsl/files/fsl-6.0.4-remove_fslpy_collisions-p2.patch')
-rw-r--r--sci-biology/fsl/files/fsl-6.0.4-remove_fslpy_collisions-p2.patch348
1 files changed, 348 insertions, 0 deletions
diff --git a/sci-biology/fsl/files/fsl-6.0.4-remove_fslpy_collisions-p2.patch b/sci-biology/fsl/files/fsl-6.0.4-remove_fslpy_collisions-p2.patch
new file mode 100644
index 000000000..ddb7cfb67
--- /dev/null
+++ b/sci-biology/fsl/files/fsl-6.0.4-remove_fslpy_collisions-p2.patch
@@ -0,0 +1,348 @@
+diff -Naur fsl.orig/src/fslio/Makefile fsl/src/fslio/Makefile
+--- fsl.orig/src/fslio/Makefile 2021-02-01 15:29:34.842752994 -0500
++++ fsl/src/fslio/Makefile 2021-02-01 15:32:19.723761859 -0500
+@@ -6,7 +6,7 @@
+
+ OBJS=fslio.o
+
+-SCRIPTS = remove_ext fsloutputtype imtest imglob imcp imln imrm immv
++SCRIPTS = fsloutputtype imglob imcp immv
+
+ all:
+
+diff -Naur fsl.orig/src/fslio/remove_ext fsl/src/fslio/remove_ext
+--- fsl.orig/src/fslio/remove_ext 2021-02-01 15:29:34.842752994 -0500
++++ fsl/src/fslio/remove_ext 1969-12-31 19:00:00.000000000 -0500
+@@ -1,87 +0,0 @@
+-#!/bin/sh
+-
+-# remove_ext - remove extension from image filename
+-#
+-# Stephen Smith and Mark Jenkinson, FMRIB Image Analysis Group
+-#
+-# Copyright (C) 1999-2004 University of Oxford
+-#
+-# Part of FSL - FMRIB's Software Library
+-# http://www.fmrib.ox.ac.uk/fsl
+-# fsl@fmrib.ox.ac.uk
+-#
+-# Developed at FMRIB (Oxford Centre for Functional Magnetic Resonance
+-# Imaging of the Brain), Department of Clinical Neurology, Oxford
+-# University, Oxford, UK
+-#
+-#
+-# LICENCE
+-#
+-# FMRIB Software Library, Release 6.0 (c) 2018, The University of
+-# Oxford (the "Software")
+-#
+-# The Software remains the property of the Oxford University Innovation
+-# ("the University").
+-#
+-# The Software is distributed "AS IS" under this Licence solely for
+-# non-commercial use in the hope that it will be useful, but in order
+-# that the University as a charitable foundation protects its assets for
+-# the benefit of its educational and research purposes, the University
+-# makes clear that no condition is made or to be implied, nor is any
+-# warranty given or to be implied, as to the accuracy of the Software,
+-# or that it will be suitable for any particular purpose or for use
+-# under any specific conditions. Furthermore, the University disclaims
+-# all responsibility for the use which is made of the Software. It
+-# further disclaims any liability for the outcomes arising from using
+-# the Software.
+-#
+-# The Licensee agrees to indemnify the University and hold the
+-# University harmless from and against any and all claims, damages and
+-# liabilities asserted by third parties (including claims for
+-# negligence) which arise directly or indirectly from the use of the
+-# Software or the sale of any products based on the Software.
+-#
+-# No part of the Software may be reproduced, modified, transmitted or
+-# transferred in any form or by any means, electronic or mechanical,
+-# without the express permission of the University. The permission of
+-# the University is not required if the said reproduction, modification,
+-# transmission or transference is done without financial return, the
+-# conditions of this Licence are imposed upon the receiver of the
+-# product, and all original and amended source code is included in any
+-# transmitted product. You may be held legally responsible for any
+-# copyright infringement that is caused or encouraged by your failure to
+-# abide by these terms and conditions.
+-#
+-# You are not permitted under this Licence to use this Software
+-# commercially. Use for which any financial return is received shall be
+-# defined as commercial use, and includes (1) integration of all or part
+-# of the source code or the Software into a product for sale or license
+-# by or on behalf of Licensee to third parties or (2) use of the
+-# Software or any derivative of it for research with the final aim of
+-# developing software products for sale or license to a third party or
+-# (3) use of the Software or any derivative of it for research with the
+-# final aim of developing non-software products for sale or license to a
+-# third party, or (4) use of the Software to provide any service to an
+-# external organisation for which payment is received. If you are
+-# interested in using the Software commercially, please contact Oxford
+-# University Innovation ("OUI"), the technology transfer company of the
+-# University, to negotiate a licence. Contact details are:
+-# fsl@innovation.ox.ac.uk quoting Reference Project 9564, FSL.
+-export LC_ALL=C
+-
+-
+-if [ $# -lt 1 ] ; then
+- exit 1
+-fi
+-
+-lst="";
+-for fn in $@ ; do
+- # for the ones at the end of the line
+- f=`echo "$fn" | sed 's/\.hdr\.gz$//' | sed 's/\.img\.gz$//' | sed 's/\.hdr$//' | sed 's/\.img$//' | sed 's/\.nii.gz$//' | sed 's/\.nii$//' | sed 's/\.mnc.gz$//' | sed 's/\.mnc$//' | sed 's/\.$//'`;
+- # for the ones in the middle of the line
+- f=`echo "$f" | sed 's/\.hdr\.gz[ ]/ /g' | sed 's/\.img\.gz[ ]/ /g' | sed 's/\.hdr[ ]/ /g' | sed 's/\.img[ ]/ /g' | sed 's/\.nii\.gz[ ]/ /g' | sed 's/\.nii[ ]/ /g' | sed 's/\.mnc\.gz[ ]/ /g' | sed 's/\.mnc[ ]/ /g' |sed 's/\.[ ]/ /g'`;
+- lst="$lst $f";
+-done
+-echo $lst;
+-
+-
+diff -Naur fsl.orig/src/misc_scripts/fsl_abspath fsl/src/misc_scripts/fsl_abspath
+--- fsl.orig/src/misc_scripts/fsl_abspath 2021-02-01 15:29:34.828752994 -0500
++++ fsl/src/misc_scripts/fsl_abspath 1969-12-31 19:00:00.000000000 -0500
+@@ -1,71 +0,0 @@
+-#!/usr/bin/env fslpython
+-# fsl_abspath - return true file path
+-# Matthew Webster FMRIB Image Analysis Group
+-# Copyright (C) 2009 University of Oxford
+-# Part of FSL - FMRIB's Software Library
+-# http://www.fmrib.ox.ac.uk/fsl
+-# fsl@fmrib.ox.ac.uk
+-#
+-# Developed at FMRIB (Oxford Centre for Functional Magnetic Resonance
+-# Imaging of the Brain), Department of Clinical Neurology, Oxford
+-# University, Oxford, UK
+-#
+-#
+-# LICENCE
+-#
+-# FMRIB Software Library, Release 6.0 (c) 2018, The University of
+-# Oxford (the "Software")
+-#
+-# The Software remains the property of the Oxford University Innovation
+-# ("the University").
+-#
+-# The Software is distributed "AS IS" under this Licence solely for
+-# non-commercial use in the hope that it will be useful, but in order
+-# that the University as a charitable foundation protects its assets for
+-# the benefit of its educational and research purposes, the University
+-# makes clear that no condition is made or to be implied, nor is any
+-# warranty given or to be implied, as to the accuracy of the Software,
+-# or that it will be suitable for any particular purpose or for use
+-# under any specific conditions. Furthermore, the University disclaims
+-# all responsibility for the use which is made of the Software. It
+-# further disclaims any liability for the outcomes arising from using
+-# the Software.
+-#
+-# The Licensee agrees to indemnify the University and hold the
+-# University harmless from and against any and all claims, damages and
+-# liabilities asserted by third parties (including claims for
+-# negligence) which arise directly or indirectly from the use of the
+-# Software or the sale of any products based on the Software.
+-#
+-# No part of the Software may be reproduced, modified, transmitted or
+-# transferred in any form or by any means, electronic or mechanical,
+-# without the express permission of the University. The permission of
+-# the University is not required if the said reproduction, modification,
+-# transmission or transference is done without financial return, the
+-# conditions of this Licence are imposed upon the receiver of the
+-# product, and all original and amended source code is included in any
+-# transmitted product. You may be held legally responsible for any
+-# copyright infringement that is caused or encouraged by your failure to
+-# abide by these terms and conditions.
+-#
+-# You are not permitted under this Licence to use this Software
+-# commercially. Use for which any financial return is received shall be
+-# defined as commercial use, and includes (1) integration of all or part
+-# of the source code or the Software into a product for sale or license
+-# by or on behalf of Licensee to third parties or (2) use of the
+-# Software or any derivative of it for research with the final aim of
+-# developing software products for sale or license to a third party or
+-# (3) use of the Software or any derivative of it for research with the
+-# final aim of developing non-software products for sale or license to a
+-# third party, or (4) use of the Software to provide any service to an
+-# external organisation for which payment is received. If you are
+-# interested in using the Software commercially, please contact Oxford
+-# University Innovation ("OUI"), the technology transfer company of the
+-# University, to negotiate a licence. Contact details are:
+-# fsl@innovation.ox.ac.uk quoting Reference Project 9564, FSL.
+-from __future__ import print_function
+-import sys
+-import os
+-
+-print (os.path.realpath(sys.argv[1]))
+-sys.exit(0)
+diff -Naur fsl.orig/src/misc_scripts/Makefile fsl/src/misc_scripts/Makefile
+--- fsl.orig/src/misc_scripts/Makefile 2021-02-01 15:29:34.828752994 -0500
++++ fsl/src/misc_scripts/Makefile 2021-02-01 15:32:56.027763811 -0500
+@@ -2,6 +2,6 @@
+
+ PROJNAME = misc_scripts
+
+-SCRIPTS = fslecho regscript remove_vols replace_and_average_fmrib linkbedpost ocmr_preproc correct_and_average eddy_correct Text2Vest Vest2Text AnatomicalAverage fsl_abspath fsl_anat fslFixText
++SCRIPTS = fslecho regscript remove_vols replace_and_average_fmrib linkbedpost ocmr_preproc correct_and_average eddy_correct AnatomicalAverage fsl_anat fslFixText
+
+ all:
+diff -Naur fsl.orig/src/misc_scripts/Text2Vest fsl/src/misc_scripts/Text2Vest
+--- fsl.orig/src/misc_scripts/Text2Vest 2021-02-01 15:29:34.828752994 -0500
++++ fsl/src/misc_scripts/Text2Vest 1969-12-31 19:00:00.000000000 -0500
+@@ -1,80 +0,0 @@
+-#!/bin/sh
+-# Copyright (C) 2012 University of Oxford
+-#
+-# Part of FSL - FMRIB's Software Library
+-# http://www.fmrib.ox.ac.uk/fsl
+-# fsl@fmrib.ox.ac.uk
+-#
+-# Developed at FMRIB (Oxford Centre for Functional Magnetic Resonance
+-# Imaging of the Brain), Department of Clinical Neurology, Oxford
+-# University, Oxford, UK
+-#
+-#
+-# LICENCE
+-#
+-# FMRIB Software Library, Release 6.0 (c) 2018, The University of
+-# Oxford (the "Software")
+-#
+-# The Software remains the property of the Oxford University Innovation
+-# ("the University").
+-#
+-# The Software is distributed "AS IS" under this Licence solely for
+-# non-commercial use in the hope that it will be useful, but in order
+-# that the University as a charitable foundation protects its assets for
+-# the benefit of its educational and research purposes, the University
+-# makes clear that no condition is made or to be implied, nor is any
+-# warranty given or to be implied, as to the accuracy of the Software,
+-# or that it will be suitable for any particular purpose or for use
+-# under any specific conditions. Furthermore, the University disclaims
+-# all responsibility for the use which is made of the Software. It
+-# further disclaims any liability for the outcomes arising from using
+-# the Software.
+-#
+-# The Licensee agrees to indemnify the University and hold the
+-# University harmless from and against any and all claims, damages and
+-# liabilities asserted by third parties (including claims for
+-# negligence) which arise directly or indirectly from the use of the
+-# Software or the sale of any products based on the Software.
+-#
+-# No part of the Software may be reproduced, modified, transmitted or
+-# transferred in any form or by any means, electronic or mechanical,
+-# without the express permission of the University. The permission of
+-# the University is not required if the said reproduction, modification,
+-# transmission or transference is done without financial return, the
+-# conditions of this Licence are imposed upon the receiver of the
+-# product, and all original and amended source code is included in any
+-# transmitted product. You may be held legally responsible for any
+-# copyright infringement that is caused or encouraged by your failure to
+-# abide by these terms and conditions.
+-#
+-# You are not permitted under this Licence to use this Software
+-# commercially. Use for which any financial return is received shall be
+-# defined as commercial use, and includes (1) integration of all or part
+-# of the source code or the Software into a product for sale or license
+-# by or on behalf of Licensee to third parties or (2) use of the
+-# Software or any derivative of it for research with the final aim of
+-# developing software products for sale or license to a third party or
+-# (3) use of the Software or any derivative of it for research with the
+-# final aim of developing non-software products for sale or license to a
+-# third party, or (4) use of the Software to provide any service to an
+-# external organisation for which payment is received. If you are
+-# interested in using the Software commercially, please contact Oxford
+-# University Innovation ("OUI"), the technology transfer company of the
+-# University, to negotiate a licence. Contact details are:
+-# fsl@innovation.ox.ac.uk quoting Reference Project 9564, FSL.
+-export LC_ALL=C
+-if [ $# -lt 2 ] ; then
+- echo "`basename $0` <text file> <vest file>"
+- exit 0
+-fi
+-
+-NumPoints=`grep -cve '^\s*$' $1`
+-NumWaves=`wc $1 | awk '{ print $2 }'`
+-NumWaves=`expr $NumWaves / $NumPoints`
+-
+-echo /NumWaves $NumWaves > $2
+-echo /NumPoints $NumPoints >> $2
+-echo /Matrix >> $2
+-
+-cat $1 >> $2
+-
+diff -Naur fsl.orig/src/misc_scripts/Vest2Text fsl/src/misc_scripts/Vest2Text
+--- fsl.orig/src/misc_scripts/Vest2Text 2021-02-01 15:29:34.828752994 -0500
++++ fsl/src/misc_scripts/Vest2Text 1969-12-31 19:00:00.000000000 -0500
+@@ -1,71 +0,0 @@
+-#!/bin/sh
+-# Copyright (C) 2012 University of Oxford
+-#
+-# Part of FSL - FMRIB's Software Library
+-# http://www.fmrib.ox.ac.uk/fsl
+-# fsl@fmrib.ox.ac.uk
+-#
+-# Developed at FMRIB (Oxford Centre for Functional Magnetic Resonance
+-# Imaging of the Brain), Department of Clinical Neurology, Oxford
+-# University, Oxford, UK
+-#
+-#
+-# LICENCE
+-#
+-# FMRIB Software Library, Release 6.0 (c) 2018, The University of
+-# Oxford (the "Software")
+-#
+-# The Software remains the property of the Oxford University Innovation
+-# ("the University").
+-#
+-# The Software is distributed "AS IS" under this Licence solely for
+-# non-commercial use in the hope that it will be useful, but in order
+-# that the University as a charitable foundation protects its assets for
+-# the benefit of its educational and research purposes, the University
+-# makes clear that no condition is made or to be implied, nor is any
+-# warranty given or to be implied, as to the accuracy of the Software,
+-# or that it will be suitable for any particular purpose or for use
+-# under any specific conditions. Furthermore, the University disclaims
+-# all responsibility for the use which is made of the Software. It
+-# further disclaims any liability for the outcomes arising from using
+-# the Software.
+-#
+-# The Licensee agrees to indemnify the University and hold the
+-# University harmless from and against any and all claims, damages and
+-# liabilities asserted by third parties (including claims for
+-# negligence) which arise directly or indirectly from the use of the
+-# Software or the sale of any products based on the Software.
+-#
+-# No part of the Software may be reproduced, modified, transmitted or
+-# transferred in any form or by any means, electronic or mechanical,
+-# without the express permission of the University. The permission of
+-# the University is not required if the said reproduction, modification,
+-# transmission or transference is done without financial return, the
+-# conditions of this Licence are imposed upon the receiver of the
+-# product, and all original and amended source code is included in any
+-# transmitted product. You may be held legally responsible for any
+-# copyright infringement that is caused or encouraged by your failure to
+-# abide by these terms and conditions.
+-#
+-# You are not permitted under this Licence to use this Software
+-# commercially. Use for which any financial return is received shall be
+-# defined as commercial use, and includes (1) integration of all or part
+-# of the source code or the Software into a product for sale or license
+-# by or on behalf of Licensee to third parties or (2) use of the
+-# Software or any derivative of it for research with the final aim of
+-# developing software products for sale or license to a third party or
+-# (3) use of the Software or any derivative of it for research with the
+-# final aim of developing non-software products for sale or license to a
+-# third party, or (4) use of the Software to provide any service to an
+-# external organisation for which payment is received. If you are
+-# interested in using the Software commercially, please contact Oxford
+-# University Innovation ("OUI"), the technology transfer company of the
+-# University, to negotiate a licence. Contact details are:
+-# fsl@innovation.ox.ac.uk quoting Reference Project 9564, FSL.
+-export LC_ALL=C
+-if [ $# -lt 2 ] ; then
+- echo "`basename $0` <vest file> <text file>"
+- exit 0
+-fi
+-sed -e "/\//d" $1 | sed '/^$/d' > $2
+-