aboutsummaryrefslogtreecommitdiff
diff options
context:
space:
mode:
Diffstat (limited to 'sci-biology/mRNAmarkup/mRNAmarkup-5.21.2019.ebuild')
-rw-r--r--sci-biology/mRNAmarkup/mRNAmarkup-5.21.2019.ebuild55
1 files changed, 55 insertions, 0 deletions
diff --git a/sci-biology/mRNAmarkup/mRNAmarkup-5.21.2019.ebuild b/sci-biology/mRNAmarkup/mRNAmarkup-5.21.2019.ebuild
new file mode 100644
index 000000000..fb37b69f9
--- /dev/null
+++ b/sci-biology/mRNAmarkup/mRNAmarkup-5.21.2019.ebuild
@@ -0,0 +1,55 @@
+# Copyright 1999-2021 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=7
+
+DESCRIPTION="Transcript annotation workflow"
+HOMEPAGE="http://brendelgroup.org/bioinformatics2go/mRNAmarkup.php"
+SRC_URI="http://www.brendelgroup.org/bioinformatics2go/Download/mRNAmarkup-${PV//./-}.tar.gz" # 184MB
+
+LICENSE="mRNAmarkup"
+SLOT="0"
+KEYWORDS="~amd64"
+
+DEPEND="
+ sci-biology/ncbi-tools++
+ sci-biology/estscan"
+# sci-biology/MuSeqBox has fetch-restrict and probably only works with old BLAST plaintex output
+# but, mRNAmarkup/INSTALL says:
+# 'For convenience, a copy of the MuSeqBox code distribution is included in directory src/contributed
+#
+# has a slightly modified estscan copy in src/contributed
+RDEPEND="${DEPEND}"
+
+S="${WORKDIR}/${PN}"
+
+src_prepare(){
+ default
+ sed -e \
+ "s#configfile=$installdir/mRNAmarkup.conf#configfile=/usr/share/mRNAmarkup/etc/mRNAmarkup.conf#" \
+ -i bin/mRNAmarkup.orig || die
+ sed -e \
+ "s#$installdir/bin/ESTScan.conf#/usr/share/mRNAmarkup/etc/ESTScan.conf#" \
+ -i bin/mRNAmarkup.orig
+}
+
+src_compile(){
+ cd src
+ emake
+}
+
+src_install(){
+ mv bin/mRNAmarkup.orig bin/mRNAmarkup
+ sed -e 's#INSTALLDIR#/usr/share/mRNAmarkup/etc/#' -i bin/mRNAmarkup
+ dobin bin/mRNAmarkup bin/*.pl bin/dnatopro bin/genestat
+ # TODO: there are some more files in bin/ , sigh!
+ insinto /usr/share/mRNAmarkup/etc
+ mv mRNAmarkup.conf.orig mRNAmarkup.conf
+ doins mRNAmarkup.conf
+ doins bin/ESTScan.conf
+ dodoc 0README INSTALL
+}
+
+pkg_postinst(){
+ einfo "Please obtain a local copy of NCBI CDD dastabase"
+}