aboutsummaryrefslogtreecommitdiff
diff options
context:
space:
mode:
Diffstat (limited to 'sci-biology/minced/minced-0.4.2.ebuild')
-rw-r--r--sci-biology/minced/minced-0.4.2.ebuild23
1 files changed, 23 insertions, 0 deletions
diff --git a/sci-biology/minced/minced-0.4.2.ebuild b/sci-biology/minced/minced-0.4.2.ebuild
new file mode 100644
index 000000000..b9845e859
--- /dev/null
+++ b/sci-biology/minced/minced-0.4.2.ebuild
@@ -0,0 +1,23 @@
+# Copyright 1999-2021 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=7
+
+inherit java-pkg-2 java-pkg-simple
+
+DESCRIPTION="Short Palindromic Repeat finder tool (for CRISPRs)"
+HOMEPAGE="https://github.com/ctSkennerton/minced"
+SRC_URI="https://github.com/ctSkennerton/minced/archive/${PV}.tar.gz -> ${P}.tar.gz"
+
+LICENSE="GPL-3"
+SLOT="0"
+KEYWORDS="~amd64"
+
+DEPEND=">=virtual/jdk-1.7"
+RDEPEND=">=virtual/jre-1.7"
+
+src_install(){
+ java-pkg_dojar minced.jar
+ java-pkg_dolauncher
+ einstalldocs
+}