aboutsummaryrefslogtreecommitdiff
diff options
context:
space:
mode:
Diffstat (limited to 'sci-biology/mouse-brain-atlases/mouse-brain-atlases-0.2.20180719.ebuild')
-rw-r--r--sci-biology/mouse-brain-atlases/mouse-brain-atlases-0.2.20180719.ebuild44
1 files changed, 44 insertions, 0 deletions
diff --git a/sci-biology/mouse-brain-atlases/mouse-brain-atlases-0.2.20180719.ebuild b/sci-biology/mouse-brain-atlases/mouse-brain-atlases-0.2.20180719.ebuild
new file mode 100644
index 000000000..b4caed1b2
--- /dev/null
+++ b/sci-biology/mouse-brain-atlases/mouse-brain-atlases-0.2.20180719.ebuild
@@ -0,0 +1,44 @@
+# Copyright 1999-2018 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=6
+
+inherit check-reqs
+
+DESCRIPTION="A collection of mouse brain atlases in NIfTI format"
+HOMEPAGE="https://github.com/IBT-FMI/mouse-brain-atlases"
+SRC_URI="
+ http://chymera.eu/distfiles/${P}.tar.xz
+ hires? ( http://chymera.eu/distfiles/${PN}HD-${PV}.tar.xz )
+ "
+
+LICENSE="fairuse"
+SLOT="0"
+KEYWORDS="~amd64 ~x86 ~amd64-linux ~x86-linux"
+IUSE="hires"
+
+RDEPEND=""
+DEPEND=""
+
+pkg_pretend() {
+ if use hires; then
+ CHECKREQS_DISK_BUILD="4G"
+ CHECKREQS_DISK_USR="4G"
+ CHECKREQS_DISK_VAR="8G"
+ else
+ CHECKREQS_DISK_BUILD="500M"
+ fi
+ check-reqs_pkg_pretend
+}
+
+# We disable this phase to not check requirements twice.
+pkg_setup() { :; }
+
+src_install() {
+ insinto "/usr/share/${PN}"
+ doins *
+ if use hires; then
+ cd "../${PN}HD-${PV}"
+ doins *
+ fi
+}