aboutsummaryrefslogtreecommitdiff
diff options
context:
space:
mode:
Diffstat (limited to 'sci-biology/ncbi-tools++/ncbi-tools++-9.0.0-r1.ebuild')
-rw-r--r--sci-biology/ncbi-tools++/ncbi-tools++-9.0.0-r1.ebuild33
1 files changed, 30 insertions, 3 deletions
diff --git a/sci-biology/ncbi-tools++/ncbi-tools++-9.0.0-r1.ebuild b/sci-biology/ncbi-tools++/ncbi-tools++-9.0.0-r1.ebuild
index 8c190e48b..4e1ee2e3e 100644
--- a/sci-biology/ncbi-tools++/ncbi-tools++-9.0.0-r1.ebuild
+++ b/sci-biology/ncbi-tools++/ncbi-tools++-9.0.0-r1.ebuild
@@ -24,7 +24,7 @@ IUSE="
debug static-libs static threads pch
test wxwidgets odbc
berkdb boost bzip2 cppunit curl expat fastcgi fltk freetype ftds gif
- glut gnutls hdf5 icu jpeg lzo mesa mysql muparser opengl pcre png python
+ glut gnutls hdf5 icu lzo jpeg mesa mysql muparser opengl pcre png python
sablotron sqlite sqlite3 ssl tiff xerces xalan xml xpm xslt X"
#KEYWORDS="~amd64 ~x86 ~amd64-linux ~x86-linux"
KEYWORDS=""
@@ -42,7 +42,9 @@ DEPEND="
ssl? ( dev-libs/openssl )
fltk? ( x11-libs/fltk )
opengl? ( virtual/opengl )
- mesa? ( media-libs/mesa )
+ mesa? ( media-libs/mesa
+ media-libs/glew
+ )
glut? ( media-libs/freeglut )
freetype? ( media-libs/freetype )
fastcgi? ( www-apache/mod_fastcgi )
@@ -67,6 +69,9 @@ DEPEND="
dev-libs/libpcre"
# USE flags which should be added somehow: wxWindows wxWidgets SP ORBacus ODBC OEChem sge
+
+# seems muParser is required, also glew is required. configure exitss otherwise
+
RDEPEND="${DEPEND}"
S="${WORKDIR}/${MY_P}"
@@ -100,6 +105,10 @@ src_prepare() {
local PATCHES=(
"${FILESDIR}"/${P}-conf-opts.patch
"${FILESDIR}"/${P}-as-needed.patch
+ "${FILESDIR}"/${P}-fix-creaders-linking.patch
+ "${FILESDIR}"/${P}-fix-svn-URL-upstream.patch
+ "${FILESDIR}"/${P}-fix-undef-reference-to-GenBankReaders_Register_Id1.patch
+ "${FILESDIR}"/${P}-remove-LZO-definition-upstream.patch
)
epatch ${PATCHES[@]}
@@ -190,7 +199,17 @@ src_configure() {
--with-muparser="${EPREFIX}/usr"
--without-sybase
--with-autodep
+
+# due to \*-fix-undef-reference-to-GenBankReaders_Register_Id1.patch
+# ./configure ... --with-flat-makefile
+# cd .../build
+# make -f Makefile.flat
+#
+ --with-flat-makefile
# --with-3psw=std:netopt favor standard (system) builds of the above pkgs
+
+
+# TODO: should improve the ssl/openssl/gmutls logic like is in net-misc/vpnc
$(use_with debug)
$(use_with debug max-debug)
$(use_with debug symbols)
@@ -254,6 +273,7 @@ src_configure() {
--srcdir="${S}" \
--prefix="${EPREFIX}/usr" \
--libdir=/usr/lib64 \
+ ${myconf} LDFLAGS="-Wl,-rpath-link,${S}_build/lib -Wl,--no-as-needed" \
${myconf[@]} || die
#--without-debug \
# --with-bin-release \
@@ -274,7 +294,14 @@ src_compile() {
# emake all_r -C GCC*-Release*/build || die
# all_p with compile only selected/required components
# cd "${S}"_build &&\
- emake all_p -C "${S}"_build/build
+
+ # disabling this because we need to take the flat Makefile route
+ # emake all_p -C "${S}"_build/build
+
+ # take the flat Makefile route
+ emake -f Makefile.flat -C "${S}"_build/build
+
+
# emake all_p -C GCC*-Release*/build || die "gcc-4.5.3 crashes at src/objects/valerr/ValidError.cpp:226:1: internal compiler error: Segmentation fault, right?"
}