aboutsummaryrefslogtreecommitdiff
diff options
context:
space:
mode:
Diffstat (limited to 'sci-biology/nilearn/nilearn-0.4.2.ebuild')
-rw-r--r--sci-biology/nilearn/nilearn-0.4.2.ebuild53
1 files changed, 0 insertions, 53 deletions
diff --git a/sci-biology/nilearn/nilearn-0.4.2.ebuild b/sci-biology/nilearn/nilearn-0.4.2.ebuild
deleted file mode 100644
index c850c3ffb..000000000
--- a/sci-biology/nilearn/nilearn-0.4.2.ebuild
+++ /dev/null
@@ -1,53 +0,0 @@
-# Copyright 1999-2018 Gentoo Foundation
-# Distributed under the terms of the GNU General Public License v2
-
-EAPI=7
-
-PYTHON_COMPAT=( python{2_7,3_4,3_5,3_6} )
-
-inherit distutils-r1
-
-DESCRIPTION="Fast and easy statistical learning on NeuroImaging data"
-HOMEPAGE="http://nilearn.github.io/"
-SRC_URI="https://github.com/nilearn/nilearn/archive/${PV}.tar.gz -> ${P}.tar.gz"
-
-LICENSE="BSD"
-SLOT="0"
-KEYWORDS="~amd64 ~x86"
-IUSE="+plot test"
-
-DEPEND="
- test? (
- ${RDEPEND}
- dev-python/nose[${PYTHON_USEDEP}]
- )
- dev-python/setuptools[${PYTHON_USEDEP}]
- "
-RDEPEND="
- dev-python/joblib[${PYTHON_USEDEP}]
- dev-python/numpy[${PYTHON_USEDEP}]
- sci-libs/scikits_learn[${PYTHON_USEDEP}]
- dev-python/scipy[${PYTHON_USEDEP}]
- sci-libs/nibabel[${PYTHON_USEDEP}]
- plot? ( dev-python/matplotlib[${PYTHON_USEDEP}] )"
-
-PATCHES=( "${FILESDIR}/0.4.1-bundled_joblib_test.patch" )
-
-python_prepare_all() {
- # upstream is reluctant to *not* depend on bundled scikits_learn:
- # https://github.com/nilearn/nilearn/pull/1398
- local f
- for f in nilearn/{*/*/,*/,}*.py; do
- sed -r \
- -e '/^from/s/(sklearn|\.|)\.externals\.joblib/joblib/' \
- -e 's/from (sklearn|\.|)\.externals import/import/' \
- -i $f || die
- done
-
- distutils-r1_python_prepare_all
-}
-
-python_test() {
- echo "backend: Agg" > matplotlibrc
- MPLCONFIGDIR=. nosetests -v || die
-}