aboutsummaryrefslogtreecommitdiff
diff options
context:
space:
mode:
Diffstat (limited to 'sci-biology/nilearn/nilearn-0.8.0.ebuild')
-rw-r--r--sci-biology/nilearn/nilearn-0.8.0.ebuild42
1 files changed, 0 insertions, 42 deletions
diff --git a/sci-biology/nilearn/nilearn-0.8.0.ebuild b/sci-biology/nilearn/nilearn-0.8.0.ebuild
deleted file mode 100644
index a70e8d0fc..000000000
--- a/sci-biology/nilearn/nilearn-0.8.0.ebuild
+++ /dev/null
@@ -1,42 +0,0 @@
-# Copyright 1999-2021 Gentoo Authors
-# Distributed under the terms of the GNU General Public License v2
-
-EAPI=8
-
-PYTHON_COMPAT=( python3_{8..9} )
-
-inherit distutils-r1
-
-DESCRIPTION="Fast and easy statistical learning on NeuroImaging data"
-HOMEPAGE="http://nilearn.github.io/"
-SRC_URI="https://github.com/nilearn/nilearn/archive/${PV}.tar.gz -> ${P}.tar.gz"
-
-LICENSE="BSD"
-SLOT="0"
-KEYWORDS="~amd64 ~x86"
-
-# Tests attempt to download external data.
-RESTRICT="test"
-
-BDEPEND="
- test? (
- dev-python/matplotlib[${PYTHON_USEDEP}]
- )
-"
-
-RDEPEND="
- >=dev-python/joblib-0.12[${PYTHON_USEDEP}]
- >=dev-python/numpy-1.16[${PYTHON_USEDEP}]
- >=sci-libs/scikit-learn-0.21[${PYTHON_USEDEP}]
- >=dev-python/scipy-1.2[${PYTHON_USEDEP}]
- >=sci-libs/nibabel-2.5[${PYTHON_USEDEP}]
- >=dev-python/pandas-0.24.0[${PYTHON_USEDEP}]
- >=dev-python/requests-2[${PYTHON_USEDEP}]
-"
-
-distutils_enable_tests pytest
-
-python_test() {
- echo "backend: Agg" > matplotlibrc
- MPLCONFIGDIR=. pytest -vv || die
-}