aboutsummaryrefslogtreecommitdiff
diff options
context:
space:
mode:
Diffstat (limited to 'sci-biology/nitime/nitime-0.10.2.ebuild')
-rw-r--r--sci-biology/nitime/nitime-0.10.2.ebuild33
1 files changed, 33 insertions, 0 deletions
diff --git a/sci-biology/nitime/nitime-0.10.2.ebuild b/sci-biology/nitime/nitime-0.10.2.ebuild
new file mode 100644
index 000000000..7e47d7288
--- /dev/null
+++ b/sci-biology/nitime/nitime-0.10.2.ebuild
@@ -0,0 +1,33 @@
+# Copyright 1999-2023 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+DISTUTILS_USE_PEP517=setuptools
+PYTHON_COMPAT=( python3_{10..11} )
+
+inherit distutils-r1 pypi
+
+DESCRIPTION="Time-series analysis of neuroscience data"
+HOMEPAGE="http://nipy.org/nitime/index.html"
+
+LICENSE="BSD"
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+
+COMMON_DEPEND="
+ dev-python/numpy[${PYTHON_USEDEP}]
+ dev-python/matplotlib[${PYTHON_USEDEP}]
+ dev-python/scipy[${PYTHON_USEDEP}]
+ "
+BDEPEND="${COMMON_DEPEND}
+ dev-python/cython[${PYTHON_USEDEP}]
+ "
+RDEPEND="
+ ${COMMON_DEPEND}
+ dev-python/networkx[${PYTHON_USEDEP}]
+ sci-libs/nibabel[${PYTHON_USEDEP}]
+ "
+
+distutils_enable_tests pytest
+distutils_enable_sphinx doc