aboutsummaryrefslogtreecommitdiff
diff options
context:
space:
mode:
Diffstat (limited to 'sci-biology/nitime/nitime-9999.ebuild')
-rw-r--r--sci-biology/nitime/nitime-9999.ebuild14
1 files changed, 4 insertions, 10 deletions
diff --git a/sci-biology/nitime/nitime-9999.ebuild b/sci-biology/nitime/nitime-9999.ebuild
index d90744bd5..ee81c01dc 100644
--- a/sci-biology/nitime/nitime-9999.ebuild
+++ b/sci-biology/nitime/nitime-9999.ebuild
@@ -1,9 +1,10 @@
-# Copyright 1999-2021 Gentoo Authors
+# Copyright 1999-2023 Gentoo Authors
# Distributed under the terms of the GNU General Public License v2
-EAPI=7
+EAPI=8
-PYTHON_COMPAT=( python3_{7,8,9} )
+DISTUTILS_USE_PEP517=setuptools
+PYTHON_COMPAT=( python3_{10..11} )
inherit distutils-r1 git-r3
@@ -16,9 +17,6 @@ LICENSE="BSD"
SLOT="0"
KEYWORDS=""
-# import file mismatch:
-RESTRICT="test"
-
COMMON_DEPEND="
dev-python/numpy[${PYTHON_USEDEP}]
dev-python/matplotlib[${PYTHON_USEDEP}]
@@ -35,7 +33,3 @@ RDEPEND="
distutils_enable_tests pytest
distutils_enable_sphinx doc
-
-python_test() {
- virtx pytest -v || die
-}