aboutsummaryrefslogtreecommitdiff
diff options
context:
space:
mode:
Diffstat (limited to 'sci-biology/nitime')
-rw-r--r--sci-biology/nitime/Manifest1
-rw-r--r--sci-biology/nitime/metadata.xml7
-rw-r--r--sci-biology/nitime/nitime-0.10.2.ebuild33
-rw-r--r--sci-biology/nitime/nitime-0.9.ebuild9
-rw-r--r--sci-biology/nitime/nitime-9999.ebuild14
5 files changed, 46 insertions, 18 deletions
diff --git a/sci-biology/nitime/Manifest b/sci-biology/nitime/Manifest
index 2ba87b1bb..4a9a85cc0 100644
--- a/sci-biology/nitime/Manifest
+++ b/sci-biology/nitime/Manifest
@@ -1 +1,2 @@
+DIST nitime-0.10.2.tar.gz 6231004 BLAKE2B 2214eb4fcb29567ebb4e819451bf7401ae6b467c0a2d196904c08bc44343e5c1ea840770f72d37df5e6642df455d895bfc9453b9389d8ef96cc88f3abc0d586e SHA512 c8c687f6c5e189e48bbe5cba4bbe3f19f34e6d087b43e3b0aa42d587f46081d3727867dbe07fa6d945381119086e12c98cdf12798055529a484152a4c04eae21
DIST nitime-0.9.tar.gz 6222979 BLAKE2B 45dbf34fd89b805f97ae5d4f88264f47ff88fa1f89b7ef05527477270bfa588a79fd1b356b2e7206919ed675936207accc02ad5b9a4be27e916a1dcf0561147e SHA512 cd8af7c3463143ac1765c472c1274915adfaf85508c334008c703ef72961e0a5e9ccbbd9321aaf62f7a58d9534934386baf1c7269a1d8f2d41b678707cd69406
diff --git a/sci-biology/nitime/metadata.xml b/sci-biology/nitime/metadata.xml
index d504ea22c..606822ddb 100644
--- a/sci-biology/nitime/metadata.xml
+++ b/sci-biology/nitime/metadata.xml
@@ -10,10 +10,11 @@
<name>Gentoo Science Project</name>
</maintainer>
<longdescription lang="en">
-Nitime is a library for time-series analysis of data from neuroscience experiments
-in both the time and spectral domains.
-</longdescription>
+ Nitime is a library for time-series analysis of data from neuroscience experiments
+ in both the time and spectral domains.
+ </longdescription>
<upstream>
<remote-id type="github">nipy/nitime</remote-id>
+ <remote-id type="pypi">nitime</remote-id>
</upstream>
</pkgmetadata>
diff --git a/sci-biology/nitime/nitime-0.10.2.ebuild b/sci-biology/nitime/nitime-0.10.2.ebuild
new file mode 100644
index 000000000..7e47d7288
--- /dev/null
+++ b/sci-biology/nitime/nitime-0.10.2.ebuild
@@ -0,0 +1,33 @@
+# Copyright 1999-2023 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+DISTUTILS_USE_PEP517=setuptools
+PYTHON_COMPAT=( python3_{10..11} )
+
+inherit distutils-r1 pypi
+
+DESCRIPTION="Time-series analysis of neuroscience data"
+HOMEPAGE="http://nipy.org/nitime/index.html"
+
+LICENSE="BSD"
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+
+COMMON_DEPEND="
+ dev-python/numpy[${PYTHON_USEDEP}]
+ dev-python/matplotlib[${PYTHON_USEDEP}]
+ dev-python/scipy[${PYTHON_USEDEP}]
+ "
+BDEPEND="${COMMON_DEPEND}
+ dev-python/cython[${PYTHON_USEDEP}]
+ "
+RDEPEND="
+ ${COMMON_DEPEND}
+ dev-python/networkx[${PYTHON_USEDEP}]
+ sci-libs/nibabel[${PYTHON_USEDEP}]
+ "
+
+distutils_enable_tests pytest
+distutils_enable_sphinx doc
diff --git a/sci-biology/nitime/nitime-0.9.ebuild b/sci-biology/nitime/nitime-0.9.ebuild
index 90cb4ff6a..cae7fdfea 100644
--- a/sci-biology/nitime/nitime-0.9.ebuild
+++ b/sci-biology/nitime/nitime-0.9.ebuild
@@ -1,15 +1,14 @@
-# Copyright 1999-2021 Gentoo Authors
+# Copyright 1999-2023 Gentoo Authors
# Distributed under the terms of the GNU General Public License v2
-EAPI=7
+EAPI=8
-PYTHON_COMPAT=( python3_{7,8,9} )
+PYTHON_COMPAT=( python3_{10..11} )
-inherit distutils-r1 virtualx
+inherit distutils-r1 pypi virtualx
DESCRIPTION="Time-series analysis of neuroscience data"
HOMEPAGE="http://nipy.org/nitime/index.html"
-SRC_URI="mirror://pypi/${PN:0:1}/${PN}/${P}.tar.gz"
LICENSE="BSD"
SLOT="0"
diff --git a/sci-biology/nitime/nitime-9999.ebuild b/sci-biology/nitime/nitime-9999.ebuild
index d90744bd5..ee81c01dc 100644
--- a/sci-biology/nitime/nitime-9999.ebuild
+++ b/sci-biology/nitime/nitime-9999.ebuild
@@ -1,9 +1,10 @@
-# Copyright 1999-2021 Gentoo Authors
+# Copyright 1999-2023 Gentoo Authors
# Distributed under the terms of the GNU General Public License v2
-EAPI=7
+EAPI=8
-PYTHON_COMPAT=( python3_{7,8,9} )
+DISTUTILS_USE_PEP517=setuptools
+PYTHON_COMPAT=( python3_{10..11} )
inherit distutils-r1 git-r3
@@ -16,9 +17,6 @@ LICENSE="BSD"
SLOT="0"
KEYWORDS=""
-# import file mismatch:
-RESTRICT="test"
-
COMMON_DEPEND="
dev-python/numpy[${PYTHON_USEDEP}]
dev-python/matplotlib[${PYTHON_USEDEP}]
@@ -35,7 +33,3 @@ RDEPEND="
distutils_enable_tests pytest
distutils_enable_sphinx doc
-
-python_test() {
- virtx pytest -v || die
-}