aboutsummaryrefslogtreecommitdiff
diff options
context:
space:
mode:
Diffstat (limited to 'sci-biology/open-ephys-gui')
-rw-r--r--sci-biology/open-ephys-gui/Manifest3
-rw-r--r--sci-biology/open-ephys-gui/files/open-ephys-gui-0.5.2.2.patch12
-rw-r--r--sci-biology/open-ephys-gui/files/open-ephys-gui-0.6.1.patch15
-rw-r--r--sci-biology/open-ephys-gui/files/open-ephys-gui-0.6.4.patch15
-rw-r--r--sci-biology/open-ephys-gui/files/open-ephys-gui-9999.patch12
-rw-r--r--sci-biology/open-ephys-gui/files/open-ephys-gui-99999999.patch12
-rw-r--r--sci-biology/open-ephys-gui/metadata.xml4
-rw-r--r--sci-biology/open-ephys-gui/open-ephys-gui-0.6.1.ebuild (renamed from sci-biology/open-ephys-gui/open-ephys-gui-0.5.2.2.ebuild)47
-rw-r--r--sci-biology/open-ephys-gui/open-ephys-gui-0.6.4.ebuild83
-rw-r--r--sci-biology/open-ephys-gui/open-ephys-gui-9999.ebuild13
-rw-r--r--sci-biology/open-ephys-gui/open-ephys-gui-99999999.ebuild13
11 files changed, 159 insertions, 70 deletions
diff --git a/sci-biology/open-ephys-gui/Manifest b/sci-biology/open-ephys-gui/Manifest
index 9f8d8eeac..5863b7945 100644
--- a/sci-biology/open-ephys-gui/Manifest
+++ b/sci-biology/open-ephys-gui/Manifest
@@ -1,2 +1,3 @@
-DIST open-ephys-gui-0.5.2.2.tar.gz 64533170 BLAKE2B dc70c3eca6a8fbc7c4f6e84580fa6d5b31b837fedbdff20f532e3c01c764cbc3c51637e4fd678d048c78b6f79b4b4a5cd4d437125beeaf712f6f322e82579c85 SHA512 b6369bb0abd8ca18ff225cffab04a24915865647ee1ab5b6d83d5d6fbda3bc64d1b7db04c23deb8d29b8ff378e703b88cfa9d409f4cde62a3af34a7984427219
DIST open-ephys-gui-0.5.5.tar.gz 63347783 BLAKE2B 8f3ab3c20e23dd4f613e2ed47dca1827ddbcc5e95be5ca12dfeefdc84611653d531d629b78049397fd4951d558f63531ea2265d13e629c8da793fc20090d1075 SHA512 b835a7f8bb3eeb08ec77f6d14f988d6278b2f5b1966fbf8bec55d429c9cee36050cf574dd78a2ebad4adc5c681bcec5b64dcfb1ec87e548c55e2bf1bff2eb2dc
+DIST open-ephys-gui-0.6.1.tar.gz 44674639 BLAKE2B 10113418c41ccc62064bd8b993aab5402691259702c53c580e39371bd5034bc3b65babfa0adcaa7e2aadb8a86758e52cc4a86fee83db05614c849ed4c2b76ff4 SHA512 00ef7e5fd1242c84948e8eaf0479337365de21a28cb77252bf2baf806b186b9c8b7a424d756a4b6a883ecac48aefd6d2a532a8cadaa910e295b474d38056547e
+DIST open-ephys-gui-0.6.4.tar.gz 44686737 BLAKE2B 839e33679cc14ffa9e2da99622e7a18f6c4f17d6a45a6c07b1136372126e2c05ad4804bc3bdf5412c7e74d00242d61d0a084574d619ea7acad4485a4aa150795 SHA512 5ac81076731d0b325ea9267d52c702c4fbb972a9c73ab156ccf9752b14cc842d7fdbca2ba292277c9127f124ca2fa73c555a51219bd3e1c95c63f40837f7eff2
diff --git a/sci-biology/open-ephys-gui/files/open-ephys-gui-0.5.2.2.patch b/sci-biology/open-ephys-gui/files/open-ephys-gui-0.5.2.2.patch
deleted file mode 100644
index 77e401639..000000000
--- a/sci-biology/open-ephys-gui/files/open-ephys-gui-0.5.2.2.patch
+++ /dev/null
@@ -1,12 +0,0 @@
-# Add 'Gentoo' build type
-
---- ../CMakeLists.txt 2019-12-02 22:29:24.021065669 -0300
-+++ ../CMakeLists.txt 2019-12-02 22:29:11.251065418 -0300
-@@ -123,6 +123,7 @@
- if(${CMAKE_BUILD_TYPE} STREQUAL "Debug")
-
- elseif (${CMAKE_BUILD_TYPE} STREQUAL "Release")
-+ elseif (${CMAKE_BUILD_TYPE} STREQUAL "Gentoo")
- else()
- message(FATAL_ERROR "Invalid build type")
- endif()
diff --git a/sci-biology/open-ephys-gui/files/open-ephys-gui-0.6.1.patch b/sci-biology/open-ephys-gui/files/open-ephys-gui-0.6.1.patch
new file mode 100644
index 000000000..0992f2241
--- /dev/null
+++ b/sci-biology/open-ephys-gui/files/open-ephys-gui-0.6.1.patch
@@ -0,0 +1,15 @@
+# Add 'Gentoo' build type
+
+--- ../CMakeLists.txt 2022-08-24 15:27:32.871426442 -0300
++++ ../CMakeLists.txt 2022-08-24 15:31:03.438087613 -0300
+@@ -171,8 +171,8 @@
+ target_compile_options(open-ephys PRIVATE -O0) #enable optimization for linux debug
+ elseif (${CMAKE_BUILD_TYPE} STREQUAL "Release")
+ target_compile_options(open-ephys PRIVATE -O3) #enable optimization for linux release
+- else()
+- message(FATAL_ERROR "Invalid build type")
++ # else()
++ # message(FATAL_ERROR "Invalid build type")
+ endif()
+ find_package(CURL REQUIRED)
+ find_package(PkgConfig REQUIRED)
diff --git a/sci-biology/open-ephys-gui/files/open-ephys-gui-0.6.4.patch b/sci-biology/open-ephys-gui/files/open-ephys-gui-0.6.4.patch
new file mode 100644
index 000000000..5c0c6526e
--- /dev/null
+++ b/sci-biology/open-ephys-gui/files/open-ephys-gui-0.6.4.patch
@@ -0,0 +1,15 @@
+# Add 'Gentoo' build type
+
+--- ../CMakeLists.txt 2022-08-24 15:27:32.871426442 -0300
++++ ../CMakeLists.txt 2022-08-24 15:31:03.438087613 -0300
+@@ -173,8 +173,8 @@
+ target_compile_options(open-ephys PRIVATE -O0) #enable optimization for linux debug
+ elseif (${CMAKE_BUILD_TYPE} STREQUAL "Release")
+ target_compile_options(open-ephys PRIVATE -O3) #enable optimization for linux release
+- else()
+- message(FATAL_ERROR "Invalid build type")
++ # else()
++ # message(FATAL_ERROR "Invalid build type")
+ endif()
+ find_package(CURL REQUIRED)
+ find_package(PkgConfig REQUIRED)
diff --git a/sci-biology/open-ephys-gui/files/open-ephys-gui-9999.patch b/sci-biology/open-ephys-gui/files/open-ephys-gui-9999.patch
deleted file mode 100644
index 77e401639..000000000
--- a/sci-biology/open-ephys-gui/files/open-ephys-gui-9999.patch
+++ /dev/null
@@ -1,12 +0,0 @@
-# Add 'Gentoo' build type
-
---- ../CMakeLists.txt 2019-12-02 22:29:24.021065669 -0300
-+++ ../CMakeLists.txt 2019-12-02 22:29:11.251065418 -0300
-@@ -123,6 +123,7 @@
- if(${CMAKE_BUILD_TYPE} STREQUAL "Debug")
-
- elseif (${CMAKE_BUILD_TYPE} STREQUAL "Release")
-+ elseif (${CMAKE_BUILD_TYPE} STREQUAL "Gentoo")
- else()
- message(FATAL_ERROR "Invalid build type")
- endif()
diff --git a/sci-biology/open-ephys-gui/files/open-ephys-gui-99999999.patch b/sci-biology/open-ephys-gui/files/open-ephys-gui-99999999.patch
deleted file mode 100644
index 77e401639..000000000
--- a/sci-biology/open-ephys-gui/files/open-ephys-gui-99999999.patch
+++ /dev/null
@@ -1,12 +0,0 @@
-# Add 'Gentoo' build type
-
---- ../CMakeLists.txt 2019-12-02 22:29:24.021065669 -0300
-+++ ../CMakeLists.txt 2019-12-02 22:29:11.251065418 -0300
-@@ -123,6 +123,7 @@
- if(${CMAKE_BUILD_TYPE} STREQUAL "Debug")
-
- elseif (${CMAKE_BUILD_TYPE} STREQUAL "Release")
-+ elseif (${CMAKE_BUILD_TYPE} STREQUAL "Gentoo")
- else()
- message(FATAL_ERROR "Invalid build type")
- endif()
diff --git a/sci-biology/open-ephys-gui/metadata.xml b/sci-biology/open-ephys-gui/metadata.xml
index ed9bf87e3..2c9af77a9 100644
--- a/sci-biology/open-ephys-gui/metadata.xml
+++ b/sci-biology/open-ephys-gui/metadata.xml
@@ -5,6 +5,10 @@
<email>malfatti@disroot.org</email>
<name>T Malfatti</name>
</maintainer>
+ <maintainer type="project">
+ <email>sci@gentoo.org</email>
+ <name>Gentoo Science Project</name>
+ </maintainer>
<upstream>
<remote-id type="github">open-ephys/plugin-GUI</remote-id>
</upstream>
diff --git a/sci-biology/open-ephys-gui/open-ephys-gui-0.5.2.2.ebuild b/sci-biology/open-ephys-gui/open-ephys-gui-0.6.1.ebuild
index b4cbc6d8f..fe6791a2d 100644
--- a/sci-biology/open-ephys-gui/open-ephys-gui-0.5.2.2.ebuild
+++ b/sci-biology/open-ephys-gui/open-ephys-gui-0.6.1.ebuild
@@ -1,8 +1,8 @@
-# Copyright 2019-2021 Gentoo Authors
+# Copyright 2019-2022 Gentoo Authors
# Distributed under the terms of the GNU General Public License v2
-EAPI=7
-inherit cmake
+EAPI=8
+inherit cmake udev
DESCRIPTION="Processing, recording, and visualizing multichannel ephys data"
HOMEPAGE="https://open-ephys.org/gui/"
@@ -11,47 +11,47 @@ LICENSE="GPL-3"
if [[ ${PV} == "9999" ]] ; then
inherit git-r3
EGIT_REPO_URI="https://github.com/open-ephys/plugin-GUI"
- EGIT_BRANCH="master"
- Suffix=$EGIT_BRANCH
+ EGIT_BRANCH="main"
+ Suffix=${EGIT_BRANCH}
SubDir=${P}
elif [[ ${PV} == "99999999" ]] ; then
inherit git-r3
EGIT_REPO_URI="https://github.com/open-ephys/plugin-GUI"
EGIT_BRANCH="development"
- Suffix=$EGIT_BRANCH
+ Suffix=${EGIT_BRANCH}
SubDir=${P}
else
SRC_URI="https://github.com/open-ephys/plugin-GUI/archive/v${PV}.tar.gz -> ${P}.tar.gz"
Suffix=${PV}
SubDir="plugin-GUI-${PV}"
- S="${WORKDIR}/$SubDir"
+ S="${WORKDIR}/${SubDir}"
KEYWORDS="~amd64 ~x86"
fi
SLOT="${PV}"
IUSE="jack"
-BDEPEND="
- <sys-devel/gcc-9
-"
DEPEND="
+ dev-libs/openssl
media-libs/alsa-lib
media-libs/freeglut
media-libs/freetype
+ net-libs/webkit-gtk
+ net-misc/curl
x11-libs/libXrandr
x11-libs/libXcursor
x11-libs/libXinerama
- jack? ( media-sound/jack-audio-connection-kit )
+ jack? ( || ( media-sound/jack-audio-connection-kit media-sound/jack2 ) )
"
RDEPEND="${DEPEND}"
-BUILD_DIR="$S/Build"
+BUILD_DIR="${S}/Build"
PATCHES=( "${FILESDIR}"/${P}.patch )
-QA_PREBUILT="opt/open-ephys-0.5.2.2/shared/*.so"
+QA_PREBUILT="opt/open-ephys-*/shared/*.so"
QA_PRESTRIPPED="
- opt/open-ephys-0.5.2.2/plugins/*.so
- opt/open-ephys-0.5.2.2/open-ephys
+ opt/open-ephys-*/plugins/*.so
+ opt/open-ephys-*/open-ephys
"
src_prepare() {
@@ -68,15 +68,16 @@ src_configure() {
}
src_install() {
- dodir opt/open-ephys-"$Suffix"/ lib/udev/rules.d/
- cp -R "${BUILD_DIR}"/Gentoo/* "${ED}"/opt/open-ephys-"$Suffix"/
- cp -R "${WORKDIR}"/"${SubDir}"/Resources/Scripts/40-open-ephys.rules "${ED}"/lib/udev/rules.d/
- dosym ../../opt/open-ephys-"$Suffix"/open-ephys usr/bin/open-ephys-"$Suffix"
+ dodir opt/open-ephys-"${Suffix}"/ lib/udev/rules.d/
+ cp -R "${BUILD_DIR}"/RelWithDebInfo/* "${ED}"/opt/open-ephys-"${Suffix}"/ || die
+ udev_newrules "${WORKDIR}"/"${SubDir}"/Resources/Scripts/40-open-ephys.rules 40-open-ephys-"${Suffix}".rules
+ dosym ../../opt/open-ephys-"${Suffix}"/open-ephys usr/bin/open-ephys-"${Suffix}"
}
pkg_postinst() {
- ewarn " "
- ewarn "You must restart the udev service in order to allow your computer to"
- ewarn "communicate with the Open Ephys acquisition board."
- ewarn " "
+ udev_reload
+}
+
+pkg_postrm() {
+ udev_reload
}
diff --git a/sci-biology/open-ephys-gui/open-ephys-gui-0.6.4.ebuild b/sci-biology/open-ephys-gui/open-ephys-gui-0.6.4.ebuild
new file mode 100644
index 000000000..cae41e773
--- /dev/null
+++ b/sci-biology/open-ephys-gui/open-ephys-gui-0.6.4.ebuild
@@ -0,0 +1,83 @@
+# Copyright 2019-2023 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+inherit cmake udev
+
+DESCRIPTION="Processing, recording, and visualizing multichannel ephys data"
+HOMEPAGE="https://open-ephys.org/gui/"
+LICENSE="GPL-3"
+
+if [[ ${PV} == "9999" ]] ; then
+ inherit git-r3
+ EGIT_REPO_URI="https://github.com/open-ephys/plugin-GUI"
+ EGIT_BRANCH="main"
+ Suffix=${EGIT_BRANCH}
+ SubDir=${P}
+elif [[ ${PV} == "99999999" ]] ; then
+ inherit git-r3
+ EGIT_REPO_URI="https://github.com/open-ephys/plugin-GUI"
+ EGIT_BRANCH="development"
+ Suffix=${EGIT_BRANCH}
+ SubDir=${P}
+else
+ SRC_URI="https://github.com/open-ephys/plugin-GUI/archive/v${PV}.tar.gz -> ${P}.tar.gz"
+ Suffix=${PV}
+ SubDir="plugin-GUI-${PV}"
+ S="${WORKDIR}/${SubDir}"
+ KEYWORDS="~amd64 ~x86"
+fi
+
+SLOT="${PV}"
+IUSE="jack"
+
+DEPEND="
+ dev-libs/openssl
+ media-libs/alsa-lib
+ media-libs/freeglut
+ media-libs/freetype
+ net-libs/webkit-gtk:4
+ net-misc/curl
+ x11-libs/libXrandr
+ x11-libs/libXcursor
+ x11-libs/libXinerama
+ jack? ( || ( media-sound/jack-audio-connection-kit media-sound/jack2 ) )
+"
+RDEPEND="${DEPEND}"
+
+BUILD_DIR="${S}/Build"
+PATCHES=( "${FILESDIR}"/${P}.patch )
+
+QA_PREBUILT="opt/open-ephys-*/shared/*.so"
+QA_PRESTRIPPED="
+ opt/open-ephys-*/plugins/*.so
+ opt/open-ephys-*/open-ephys
+"
+
+src_prepare() {
+ cmake_src_prepare
+
+ if use jack; then
+ sed -i 's/JUCE_APP_VERSION=/JUCE_JACK=1\n JUCE_APP_VERSION=/' "${WORKDIR}/${SubDir}/CMakeLists.txt" || die "Sed failed!"
+ fi
+}
+
+src_configure() {
+ local mycmakeargs=( -DCMAKE_SKIP_RPATH=ON )
+ cmake_src_configure
+}
+
+src_install() {
+ dodir opt/open-ephys-"${Suffix}"/ lib/udev/rules.d/
+ cp -R "${BUILD_DIR}"/RelWithDebInfo/* "${ED}"/opt/open-ephys-"${Suffix}"/ || die
+ udev_newrules "${WORKDIR}"/"${SubDir}"/Resources/Scripts/40-open-ephys.rules 40-open-ephys-"${Suffix}".rules
+ dosym ../../opt/open-ephys-"${Suffix}"/open-ephys usr/bin/open-ephys-"${Suffix}"
+}
+
+pkg_postinst() {
+ udev_reload
+}
+
+pkg_postrm() {
+ udev_reload
+}
diff --git a/sci-biology/open-ephys-gui/open-ephys-gui-9999.ebuild b/sci-biology/open-ephys-gui/open-ephys-gui-9999.ebuild
index 1c2b20e24..2ab957f40 100644
--- a/sci-biology/open-ephys-gui/open-ephys-gui-9999.ebuild
+++ b/sci-biology/open-ephys-gui/open-ephys-gui-9999.ebuild
@@ -1,7 +1,7 @@
-# Copyright 2019-2021 Gentoo Authors
+# Copyright 2019-2023 Gentoo Authors
# Distributed under the terms of the GNU General Public License v2
-EAPI=7
+EAPI=8
inherit cmake udev
DESCRIPTION="Processing, recording, and visualizing multichannel ephys data"
@@ -11,7 +11,7 @@ LICENSE="GPL-3"
if [[ ${PV} == "9999" ]] ; then
inherit git-r3
EGIT_REPO_URI="https://github.com/open-ephys/plugin-GUI"
- EGIT_BRANCH="master"
+ EGIT_BRANCH="main"
Suffix=${EGIT_BRANCH}
SubDir=${P}
elif [[ ${PV} == "99999999" ]] ; then
@@ -32,9 +32,12 @@ SLOT="${PV}"
IUSE="jack"
DEPEND="
+ dev-libs/openssl
media-libs/alsa-lib
media-libs/freeglut
media-libs/freetype
+ net-libs/webkit-gtk:4
+ net-misc/curl
x11-libs/libXrandr
x11-libs/libXcursor
x11-libs/libXinerama
@@ -43,7 +46,7 @@ DEPEND="
RDEPEND="${DEPEND}"
BUILD_DIR="${S}/Build"
-PATCHES=( "${FILESDIR}"/${P}.patch )
+PATCHES=( "${FILESDIR}"/"${PN}"-0.6.4.patch )
QA_PREBUILT="opt/open-ephys-*/shared/*.so"
QA_PRESTRIPPED="
@@ -66,7 +69,7 @@ src_configure() {
src_install() {
dodir opt/open-ephys-"${Suffix}"/ lib/udev/rules.d/
- cp -R "${BUILD_DIR}"/Gentoo/* "${ED}"/opt/open-ephys-"${Suffix}"/
+ cp -R "${BUILD_DIR}"/RelWithDebInfo/* "${ED}"/opt/open-ephys-"${Suffix}"/ || die
udev_newrules "${WORKDIR}"/"${SubDir}"/Resources/Scripts/40-open-ephys.rules 40-open-ephys-"${Suffix}".rules
dosym ../../opt/open-ephys-"${Suffix}"/open-ephys usr/bin/open-ephys-"${Suffix}"
}
diff --git a/sci-biology/open-ephys-gui/open-ephys-gui-99999999.ebuild b/sci-biology/open-ephys-gui/open-ephys-gui-99999999.ebuild
index 1c2b20e24..2ab957f40 100644
--- a/sci-biology/open-ephys-gui/open-ephys-gui-99999999.ebuild
+++ b/sci-biology/open-ephys-gui/open-ephys-gui-99999999.ebuild
@@ -1,7 +1,7 @@
-# Copyright 2019-2021 Gentoo Authors
+# Copyright 2019-2023 Gentoo Authors
# Distributed under the terms of the GNU General Public License v2
-EAPI=7
+EAPI=8
inherit cmake udev
DESCRIPTION="Processing, recording, and visualizing multichannel ephys data"
@@ -11,7 +11,7 @@ LICENSE="GPL-3"
if [[ ${PV} == "9999" ]] ; then
inherit git-r3
EGIT_REPO_URI="https://github.com/open-ephys/plugin-GUI"
- EGIT_BRANCH="master"
+ EGIT_BRANCH="main"
Suffix=${EGIT_BRANCH}
SubDir=${P}
elif [[ ${PV} == "99999999" ]] ; then
@@ -32,9 +32,12 @@ SLOT="${PV}"
IUSE="jack"
DEPEND="
+ dev-libs/openssl
media-libs/alsa-lib
media-libs/freeglut
media-libs/freetype
+ net-libs/webkit-gtk:4
+ net-misc/curl
x11-libs/libXrandr
x11-libs/libXcursor
x11-libs/libXinerama
@@ -43,7 +46,7 @@ DEPEND="
RDEPEND="${DEPEND}"
BUILD_DIR="${S}/Build"
-PATCHES=( "${FILESDIR}"/${P}.patch )
+PATCHES=( "${FILESDIR}"/"${PN}"-0.6.4.patch )
QA_PREBUILT="opt/open-ephys-*/shared/*.so"
QA_PRESTRIPPED="
@@ -66,7 +69,7 @@ src_configure() {
src_install() {
dodir opt/open-ephys-"${Suffix}"/ lib/udev/rules.d/
- cp -R "${BUILD_DIR}"/Gentoo/* "${ED}"/opt/open-ephys-"${Suffix}"/
+ cp -R "${BUILD_DIR}"/RelWithDebInfo/* "${ED}"/opt/open-ephys-"${Suffix}"/ || die
udev_newrules "${WORKDIR}"/"${SubDir}"/Resources/Scripts/40-open-ephys.rules 40-open-ephys-"${Suffix}".rules
dosym ../../opt/open-ephys-"${Suffix}"/open-ephys usr/bin/open-ephys-"${Suffix}"
}