aboutsummaryrefslogtreecommitdiff
diff options
context:
space:
mode:
Diffstat (limited to 'sci-biology/pbbam/pbbam-2.1.0.ebuild')
-rw-r--r--sci-biology/pbbam/pbbam-2.1.0.ebuild27
1 files changed, 27 insertions, 0 deletions
diff --git a/sci-biology/pbbam/pbbam-2.1.0.ebuild b/sci-biology/pbbam/pbbam-2.1.0.ebuild
new file mode 100644
index 000000000..a114da0fc
--- /dev/null
+++ b/sci-biology/pbbam/pbbam-2.1.0.ebuild
@@ -0,0 +1,27 @@
+# Copyright 1999-2022 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+inherit meson
+
+DESCRIPTION="PacBio modified BAM file format"
+HOMEPAGE="https://pbbam.readthedocs.io/en/latest/index.html"
+SRC_URI="https://github.com/PacificBiosciences/pbbam/archive/v${PV}.tar.gz -> ${P}.tar.gz"
+
+LICENSE="blasr"
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+
+BDEPEND="
+ virtual/pkgconfig
+ >=dev-cpp/gtest-1.8.1
+ >=dev-lang/swig-3.0.5
+"
+DEPEND="
+ sci-biology/pbcopper
+ sci-biology/samtools:0
+ >=sci-libs/htslib-1.3.1:=
+ >=dev-libs/boost-1.55:=
+"
+RDEPEND="${DEPEND}"