aboutsummaryrefslogtreecommitdiff
diff options
context:
space:
mode:
Diffstat (limited to 'sci-biology/pbcopper/pbcopper-1.9.5.ebuild')
-rw-r--r--sci-biology/pbcopper/pbcopper-1.9.5.ebuild26
1 files changed, 26 insertions, 0 deletions
diff --git a/sci-biology/pbcopper/pbcopper-1.9.5.ebuild b/sci-biology/pbcopper/pbcopper-1.9.5.ebuild
new file mode 100644
index 000000000..79307d839
--- /dev/null
+++ b/sci-biology/pbcopper/pbcopper-1.9.5.ebuild
@@ -0,0 +1,26 @@
+# Copyright 1999-2022 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+inherit meson
+
+DESCRIPTION="Core C++ library for data structures, algorithms, and utilities"
+HOMEPAGE="https://github.com/PacificBiosciences/pbcopper"
+SRC_URI="https://github.com/PacificBiosciences/pbcopper/archive/v${PV}.tar.gz -> ${P}.tar.gz"
+
+LICENSE="blasr"
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+
+BDEPEND="
+ virtual/pkgconfig
+ >=dev-lang/swig-3.0.5
+ >=dev-cpp/gtest-1.8.1
+"
+
+DEPEND="
+ >=sci-libs/htslib-1.3.1:=
+ >=dev-libs/boost-1.55:=
+"
+RDEPEND="${DEPEND}"