aboutsummaryrefslogtreecommitdiff
diff options
context:
space:
mode:
Diffstat (limited to 'sci-biology/perlprimer/perlprimer-1.1.14.ebuild')
-rw-r--r--sci-biology/perlprimer/perlprimer-1.1.14.ebuild37
1 files changed, 37 insertions, 0 deletions
diff --git a/sci-biology/perlprimer/perlprimer-1.1.14.ebuild b/sci-biology/perlprimer/perlprimer-1.1.14.ebuild
new file mode 100644
index 000000000..2b2c5e9a0
--- /dev/null
+++ b/sci-biology/perlprimer/perlprimer-1.1.14.ebuild
@@ -0,0 +1,37 @@
+# Copyright 1999-2008 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: $
+
+DESCRIPTION="A GUI application written in Perl to help design
+primers for standard PCR, bisulphite PCR and Real-time PCR"
+HOMEPAGE="http://perlprimer.sourceforge.net/"
+SRC_URI="mirror://sourceforge/${PN}/${P}.tar.bz2"
+
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS="~amd64"
+IUSE=""
+
+DEPEND=""
+RDEPEND="dev-perl/perl-tk
+ dev-perl/libwww-perl"
+
+src_unpack() {
+
+ unpack ${A}
+ cd "${S}"
+ sed -i -e "s|\(\"\$HOME\".\"gcg.*\"\)|\"\/usr\/share\/${P}\/\".\"gcg.*\"|" perlprimer.pl || die "Sed failed!"
+}
+
+# TODO: figure out why right-clicking on the sequence doesn't produce a stable menu.
+# see if upstream still exists, point them at the new gcg file.
+
+src_install() {
+
+ exeinto /usr/bin
+ doexe "${S}"/perlprimer.pl
+ insinto /usr/share/${P}
+ doins ${FILESDIR}/gcg.801
+ dodoc Changelog ReadMe.txt
+ dohtml -r tutorial_files tutorial.html
+}