aboutsummaryrefslogtreecommitdiff
diff options
context:
space:
mode:
Diffstat (limited to 'sci-biology/psychopy/psychopy-1.75.01.ebuild')
-rw-r--r--sci-biology/psychopy/psychopy-1.75.01.ebuild24
1 files changed, 19 insertions, 5 deletions
diff --git a/sci-biology/psychopy/psychopy-1.75.01.ebuild b/sci-biology/psychopy/psychopy-1.75.01.ebuild
index 6b341f50b..9d6b51dee 100644
--- a/sci-biology/psychopy/psychopy-1.75.01.ebuild
+++ b/sci-biology/psychopy/psychopy-1.75.01.ebuild
@@ -2,14 +2,15 @@
# Distributed under the terms of the GNU General Public License v2
# $Header: $
-EAPI="4"
+EAPI="5"
+PYTHON_COMPAT=( python2_7 )
PYTHON_DEPEND="2"
SUPPORT_PYTHON_ABIS="1"
RESTRICT_PYTHON_ABIS="3.* *-jython *-pypy-*"
DISTUTILS_SRC_TEST="py.test"
-inherit distutils
+inherit distutils-r1 gnome2-utils eutils
MY_P="PsychoPy-${PV}"
@@ -24,11 +25,11 @@ IUSE="test"
RDEPEND="dev-python/numpy[lapack]
sci-libs/scipy
dev-python/matplotlib
- dev-python/pyopengl
+ dev-python/pyopengl[${PYTHON_USEDEP}]
dev-python/imaging
dev-python/wxpython
- dev-python/setuptools
- dev-python/lxml
+ dev-python/setuptools[${PYTHON_USEDEP}]
+ dev-python/lxml[${PYTHON_USEDEP}]
app-admin/eselect
dev-python/pyglet
dev-python/pygame"
@@ -40,3 +41,16 @@ DEPEND="app-arch/unzip
RESTRICT="test" # interactive, opens lots of windows
S="${WORKDIR}/${MY_P}"
+
+python_install_all() {
+ distutils-r1_python_install_all
+ doicon psychopy/monitors/psychopy.ico
+ make_desktop_entry psychopyapp.py PsychoPy psychopy "Science;Biology"
+}
+
+pkg_postinst() {
+ gnome2_icon_cache_update
+}
+pkg_postrm() {
+ gnome2_icon_cache_update
+}