aboutsummaryrefslogtreecommitdiff
diff options
context:
space:
mode:
Diffstat (limited to 'sci-biology/pybedtools/pybedtools-0.8.2.ebuild')
-rw-r--r--sci-biology/pybedtools/pybedtools-0.8.2.ebuild17
1 files changed, 12 insertions, 5 deletions
diff --git a/sci-biology/pybedtools/pybedtools-0.8.2.ebuild b/sci-biology/pybedtools/pybedtools-0.8.2.ebuild
index 95bee9be2..bc02bda6f 100644
--- a/sci-biology/pybedtools/pybedtools-0.8.2.ebuild
+++ b/sci-biology/pybedtools/pybedtools-0.8.2.ebuild
@@ -1,9 +1,10 @@
-# Copyright 1999-2022 Gentoo Authors
+# Copyright 1999-2023 Gentoo Authors
# Distributed under the terms of the GNU General Public License v2
EAPI=8
-PYTHON_COMPAT=( python3_{8..10} )
+PYTHON_COMPAT=( python3_{10..11} )
+DISTUTILS_USE_PEP517=setuptools
inherit distutils-r1
@@ -15,9 +16,6 @@ LICENSE="MIT"
SLOT="0"
KEYWORDS="~amd64 ~x86"
-# ModuleNotFoundError: No module named 'pybedtools.cbedtools'
-RESTRICT="test"
-
RDEPEND="
sci-biology/bedtools
sci-biology/pysam[${PYTHON_USEDEP}]
@@ -34,3 +32,12 @@ BDEPEND="dev-python/cython[${PYTHON_USEDEP}]"
# even if pybedtools is installed
#distutils_enable_sphinx docs/source
distutils_enable_tests pytest
+
+python_test() {
+ # Requires network
+ local EPYTEST_DESELECT=(
+ test/test_helpers.py::test_chromsizes
+ )
+ cd "${T}" || die
+ epytest --pyargs pybedtools
+}