aboutsummaryrefslogtreecommitdiff
diff options
context:
space:
mode:
Diffstat (limited to 'sci-biology/pybedtools/pybedtools-0.8.2.ebuild')
-rw-r--r--sci-biology/pybedtools/pybedtools-0.8.2.ebuild43
1 files changed, 43 insertions, 0 deletions
diff --git a/sci-biology/pybedtools/pybedtools-0.8.2.ebuild b/sci-biology/pybedtools/pybedtools-0.8.2.ebuild
new file mode 100644
index 000000000..bc02bda6f
--- /dev/null
+++ b/sci-biology/pybedtools/pybedtools-0.8.2.ebuild
@@ -0,0 +1,43 @@
+# Copyright 1999-2023 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+PYTHON_COMPAT=( python3_{10..11} )
+DISTUTILS_USE_PEP517=setuptools
+
+inherit distutils-r1
+
+DESCRIPTION="Use BED and GFF files from python using BEDtools"
+HOMEPAGE="https://daler.github.io/pybedtools"
+SRC_URI="https://github.com/daler/pybedtools/archive/v${PV}.tar.gz -> ${P}.tar.gz"
+
+LICENSE="MIT"
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+
+RDEPEND="
+ sci-biology/bedtools
+ sci-biology/pysam[${PYTHON_USEDEP}]
+ dev-python/six[${PYTHON_USEDEP}]
+ dev-python/numpy[${PYTHON_USEDEP}]
+ dev-python/pandas[${PYTHON_USEDEP}]
+ dev-python/matplotlib[${PYTHON_USEDEP}]
+"
+
+BDEPEND="dev-python/cython[${PYTHON_USEDEP}]"
+
+# TODO: fix docs building
+# ModuleNotFoundError: No module named 'pybedtools.cbedtools'
+# even if pybedtools is installed
+#distutils_enable_sphinx docs/source
+distutils_enable_tests pytest
+
+python_test() {
+ # Requires network
+ local EPYTEST_DESELECT=(
+ test/test_helpers.py::test_chromsizes
+ )
+ cd "${T}" || die
+ epytest --pyargs pybedtools
+}