aboutsummaryrefslogtreecommitdiff
diff options
context:
space:
mode:
Diffstat (limited to 'sci-biology/pyfaidx/pyfaidx-0.7.2.1.ebuild')
-rw-r--r--sci-biology/pyfaidx/pyfaidx-0.7.2.1.ebuild24
1 files changed, 24 insertions, 0 deletions
diff --git a/sci-biology/pyfaidx/pyfaidx-0.7.2.1.ebuild b/sci-biology/pyfaidx/pyfaidx-0.7.2.1.ebuild
new file mode 100644
index 000000000..14f557869
--- /dev/null
+++ b/sci-biology/pyfaidx/pyfaidx-0.7.2.1.ebuild
@@ -0,0 +1,24 @@
+# Copyright 1999-2023 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+PYTHON_COMPAT=( python3_{10..11} )
+DISTUTILS_USE_PEP517=setuptools
+
+inherit distutils-r1 pypi
+
+DESCRIPTION="Efficient pythonic random access to fasta subsequences"
+HOMEPAGE="https://pypi.python.org/pypi/pyfaidx https://github.com/mdshw5/pyfaidx"
+
+LICENSE="MIT"
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+IUSE=""
+# Test issues reported upstream:
+# https://github.com/mdshw5/pyfaidx/issues/208
+RESTRICT="test"
+
+REPEND="dev-python/six[${PYTHON_USEDEP}]"
+
+distutils_enable_tests pytest