aboutsummaryrefslogtreecommitdiff
diff options
context:
space:
mode:
Diffstat (limited to 'sci-biology/samri/samri-9999.ebuild')
-rw-r--r--sci-biology/samri/samri-9999.ebuild40
1 files changed, 23 insertions, 17 deletions
diff --git a/sci-biology/samri/samri-9999.ebuild b/sci-biology/samri/samri-9999.ebuild
index 507d6a53c..f632f83a8 100644
--- a/sci-biology/samri/samri-9999.ebuild
+++ b/sci-biology/samri/samri-9999.ebuild
@@ -1,26 +1,31 @@
-# Copyright 1999-2021 Gentoo Authors
+# Copyright 1999-2023 Gentoo Authors
# Distributed under the terms of the GNU General Public License v2
-EAPI=7
+EAPI=8
-PYTHON_COMPAT=( python3_{7..8} )
+PYTHON_COMPAT=( python3_{10..11} )
+DISTUTILS_USE_PEP517=setuptools
-inherit distutils-r1 git-r3
+inherit distutils-r1 prefix
DESCRIPTION="Small Animal Magnetic Resonance Imaging"
HOMEPAGE="https://github.com/IBT-FMI/SAMRI"
-SRC_URI=""
-EGIT_REPO_URI="https://github.com/IBT-FMI/SAMRI"
+if [ "$PV" == "9999" ]; then
+ inherit git-r3
+ EGIT_REPO_URI="https://github.com/IBT-FMI/SAMRI.git"
+else
+ SRC_URI="https://github.com/IBT-FMI/SAMRI/archive/${PV}.tar.gz -> ${P}.tar.gz"
+ KEYWORDS="~amd64"
+ S="${WORKDIR}/SAMRI-${PV}"
+fi
LICENSE="GPL-3"
SLOT="0"
-IUSE="+atlases labbookdb test"
-KEYWORDS=""
-RESTRICT="!test? ( test )"
+IUSE="+atlases labbookdb"
+REQUIRED_USE="test? ( atlases )"
DEPEND="
test? (
- dev-python/pytest[${PYTHON_USEDEP}]
sci-biology/samri_bidsdata
sci-biology/samri_bindata
)
@@ -37,24 +42,25 @@ RDEPEND="
>=media-gfx/blender-2.83.4
>=sci-biology/fsl-5.0.9
sci-biology/bru2nii
- atlases? ( sci-biology/mouse-brain-atlases )
+ atlases? ( sci-biology/mouse-brain-templates )
labbookdb? ( sci-libs/labbookdb[${PYTHON_USEDEP}] )
sci-libs/nibabel[${PYTHON_USEDEP}]
>=sci-libs/nipy-0.4.1[${PYTHON_USEDEP}]
>=sci-libs/nipype-1.0.0[${PYTHON_USEDEP}]
- sci-libs/pybids[${PYTHON_USEDEP}]
- sci-libs/scikit-image[${PYTHON_USEDEP}]
+ <sci-libs/pybids-0.10.2[${PYTHON_USEDEP}]
+ dev-python/scikit-image[${PYTHON_USEDEP}]
sci-biology/ants
sci-biology/afni
sci-biology/nilearn[${PYTHON_USEDEP}]
"
-REQUIRED_USE="test? ( atlases )"
+distutils_enable_tests pytest
+distutils_enable_sphinx doc/source dev-python/sphinxcontrib-napoleon
src_prepare() {
distutils-r1_src_prepare
- sed -i -e "s:/usr:@GENTOO_PORTAGE_EPREFIX@/usr:g" `grep -rlI \'/usr/ samri`
- sed -i -e "s:/usr:@GENTOO_PORTAGE_EPREFIX@/usr:g" `grep -rlI /usr/ test_scripts.sh`
+ sed -i -e "s:/usr:@GENTOO_PORTAGE_EPREFIX@/usr:g" `grep -rlI \'/usr/ samri` || die
+ sed -i -e "s:/usr:@GENTOO_PORTAGE_EPREFIX@/usr:g" `grep -rlI /usr/ test_scripts.sh` || die
eprefixify $(grep -rl GENTOO_PORTAGE_EPREFIX samri/* test_scripts.sh)
}
@@ -67,5 +73,5 @@ python_test() {
sed -i -e \
"/def test_bru2bids():/i@pytest.mark.skip('Removed in full test suite, as this is already tested in `test_scripts.sh`')" \
samri/pipelines/tests/test_repos.py || die
- pytest -vv -k "not longtime" || die
+ epytest -k "not longtime"
}