aboutsummaryrefslogtreecommitdiff
diff options
context:
space:
mode:
Diffstat (limited to 'sci-biology/sga/sga-9999.ebuild')
-rw-r--r--sci-biology/sga/sga-9999.ebuild25
1 files changed, 15 insertions, 10 deletions
diff --git a/sci-biology/sga/sga-9999.ebuild b/sci-biology/sga/sga-9999.ebuild
index 52f7bb69c..7519b3e2a 100644
--- a/sci-biology/sga/sga-9999.ebuild
+++ b/sci-biology/sga/sga-9999.ebuild
@@ -1,9 +1,9 @@
-# Copyright 1999-2020 Gentoo Authors
+# Copyright 1999-2021 Gentoo Authors
# Distributed under the terms of the GNU General Public License v2
-EAPI=5
+EAPI=7
-inherit eutils git-r3
+inherit git-r3 autotools
DESCRIPTION="String Graph OLC Assembler for short reads (overlap-layout-consensus)"
HOMEPAGE="https://github.com/jts/sga"
@@ -14,20 +14,27 @@ SLOT="0"
KEYWORDS=""
IUSE="jemalloc python"
-DEPEND="dev-cpp/sparsehash
+DEPEND="
+ dev-cpp/sparsehash
sci-biology/bamtools
sys-libs/zlib
- jemalloc? ( dev-libs/jemalloc )"
+ jemalloc? ( dev-libs/jemalloc )
+"
RDEPEND="${DEPEND}
sci-biology/abyss
python? ( sci-biology/pysam
sci-biology/ruffus )"
+S="${WORKDIR}/${P}/src"
+
+src_prepare() {
+ default
+ eautoreconf
+}
+
# http://www.vcru.wisc.edu/simonlab/bioinformatics/programs/install/sga.htm
src_configure(){
- cd src || die
- ./autogen.sh || die
- econf --with-bamtools="${EPREFIX}"/usr
+ econf --with-bamtools="${EPREFIX}"/usr --with-sparsehash="${EPREFIX}"/usr
}
src_compile(){
@@ -38,12 +45,10 @@ src_compile(){
#
# other unreviewed patches:
# https://github.com/jts/sga/issues/96
- cd src || die "Try -std=g++-98, try gcc-5 or -std=c++03"
default
}
src_install(){
- cd src || die
dodoc README
emake install DESTDIR="${D}"
insinto /usr/share/sga/examples