aboutsummaryrefslogtreecommitdiff
diff options
context:
space:
mode:
Diffstat (limited to 'sci-biology/ssaha2-bin/ssaha2-bin-2.5.5.ebuild')
-rw-r--r--sci-biology/ssaha2-bin/ssaha2-bin-2.5.5.ebuild38
1 files changed, 0 insertions, 38 deletions
diff --git a/sci-biology/ssaha2-bin/ssaha2-bin-2.5.5.ebuild b/sci-biology/ssaha2-bin/ssaha2-bin-2.5.5.ebuild
deleted file mode 100644
index 3122e2188..000000000
--- a/sci-biology/ssaha2-bin/ssaha2-bin-2.5.5.ebuild
+++ /dev/null
@@ -1,38 +0,0 @@
-# Copyright 1999-2021 Gentoo Authors
-# Distributed under the terms of the GNU General Public License v2
-
-EAPI=7
-
-inherit toolchain-funcs
-
-MY_PN="${PN%-bin}"
-MY_P="${MY_PN}_v${PV}"
-
-DESCRIPTION="SSAHA2: Sequence Search and Alignment by Hashing Algorithm"
-HOMEPAGE="https://www.sanger.ac.uk/tool/ssaha2-0/"
-SRC_URI="
- x86? ( ftp://ftp.sanger.ac.uk/pub4/resources/software/${MY_PN}/${MY_P}_i686.tgz )
- amd64? ( ftp://ftp.sanger.ac.uk/pub4/resources/software/${MY_PN}/${MY_P}_x86_64.tgz )
- ftp://ftp.sanger.ac.uk/pub4/resources/software/ssaha2/samflag.c
- ftp://ftp.sanger.ac.uk/pub4/resources/software/ssaha2/ssaha2-manual.pdf"
-
-LICENSE="all-rights-reserved"
-SLOT="0"
-KEYWORDS="~amd64 ~x86"
-
-QA_PREBUILT="/opt/.*"
-
-pkg_setup() {
- use x86 && export S="${WORKDIR}"/${MY_P}_i686
- use amd64 && export S="${WORKDIR}"/${MY_P}_x86_64
-}
-src_compile() {
- $(tc-getCC) ${CFLAGS} ${LDFLAGS} -o samflag "${DISTDIR}"/samflag.c || die "Failed to compile samflags"
-}
-
-src_install() {
- dobin samflag
- exeinto /opt/bin
- doexe ssaha2 ssaha2Build ssahaSNP
- dodoc README "${DISTDIR}"/ssaha2-manual.pdf
-}