aboutsummaryrefslogtreecommitdiff
diff options
context:
space:
mode:
Diffstat (limited to 'sci-chemistry/MotionCor2')
-rw-r--r--sci-chemistry/MotionCor2/MotionCor2-1.4.0.ebuild9
1 files changed, 6 insertions, 3 deletions
diff --git a/sci-chemistry/MotionCor2/MotionCor2-1.4.0.ebuild b/sci-chemistry/MotionCor2/MotionCor2-1.4.0.ebuild
index 99b3b14cd..e1f880d28 100644
--- a/sci-chemistry/MotionCor2/MotionCor2-1.4.0.ebuild
+++ b/sci-chemistry/MotionCor2/MotionCor2-1.4.0.ebuild
@@ -11,7 +11,7 @@ S="${WORKDIR}"/${PN}_${PV}
LICENSE="UCSF-Motioncor2"
SLOT="0"
KEYWORDS="~amd64"
-IUSE="cuda92 cuda102"
+IUSE="cuda92 +cuda102"
REQUIRED_USE="^^ ( cuda92 cuda102 )"
RESTRICT="fetch"
@@ -37,9 +37,12 @@ src_install() {
# package also has 10.0 10.1 11.0 versions
# but these cuda versions are not in ::gentoo
+ local mcbin
if use cuda92; then
- dobin ${PN}_${PV}-Cuda92 ${PN}
+ mcbin="${PN}_${PV}_Cuda92"
elif use cuda102; then
- dobin ${PN}_${PV}-Cuda102 ${PN}
+ mcbin="${PN}_${PV}_Cuda102"
fi
+ dobin "${mcbin}"
+ dosym "${mcbin}" /usr/bin/MotionCor2
}