aboutsummaryrefslogtreecommitdiff
diff options
context:
space:
mode:
Diffstat (limited to 'sci-chemistry/bkchem/bkchem-0.13.0-r1.ebuild')
-rw-r--r--sci-chemistry/bkchem/bkchem-0.13.0-r1.ebuild48
1 files changed, 0 insertions, 48 deletions
diff --git a/sci-chemistry/bkchem/bkchem-0.13.0-r1.ebuild b/sci-chemistry/bkchem/bkchem-0.13.0-r1.ebuild
deleted file mode 100644
index e259eccad..000000000
--- a/sci-chemistry/bkchem/bkchem-0.13.0-r1.ebuild
+++ /dev/null
@@ -1,48 +0,0 @@
-# Copyright 1999-2009 Gentoo Foundation
-# Distributed under the terms of the GNU General Public License v2
-# $Header: $
-
-EAPI=2
-
-inherit distutils eutils
-
-DESCRIPTION="A chemical drawing program"
-HOMEPAGE="http://bkchem.zirael.org/"
-
-SRC_URI="http://bkchem.zirael.org/download/${P}.tar.gz"
-LICENSE="GPL-2"
-
-SLOT="0"
-
-KEYWORDS="~x86 ~amd64"
-IUSE="cairo"
-
-DEPEND=">=dev-lang/python-2.4
- ~sci-libs/oasa-${PV}"
-
-RDEPEND="${DEPEND}
- cairo? ( ~sci-libs/oasa-${PV}[cairo] )"
-
-pkg_setup() {
- distutils_python_tkinter
-}
-
-src_unpack() {
- unpack ${A}
- cd "${S}"
-
- epatch "${FILESDIR}/${P}-setup.patch" || die "Failed to apply ${P}-setup.patch"
- epatch "${FILESDIR}/${P}-oasa_import.patch" || die "Failed to apply ${P}-oasa_import.patch"
-}
-
-src_install() {
- # strip this path from the paths in site_config.py and bkchem script
- # we have to strip the trailing / from the $D path
- STRD=`echo "$D" | sed "s/\\\\/$//g"`
-
- distutils_src_install "--strip=${STRD}"
-
- doicon images/${PN}.png
- make_desktop_entry ${PN} BKChem ${PN}.png Education
-}
-