aboutsummaryrefslogtreecommitdiff
diff options
context:
space:
mode:
Diffstat (limited to 'sci-chemistry/burrow-owl/burrow-owl-9999.ebuild')
-rw-r--r--sci-chemistry/burrow-owl/burrow-owl-9999.ebuild9
1 files changed, 5 insertions, 4 deletions
diff --git a/sci-chemistry/burrow-owl/burrow-owl-9999.ebuild b/sci-chemistry/burrow-owl/burrow-owl-9999.ebuild
index 0b8c025e9..ed54ee51f 100644
--- a/sci-chemistry/burrow-owl/burrow-owl-9999.ebuild
+++ b/sci-chemistry/burrow-owl/burrow-owl-9999.ebuild
@@ -6,7 +6,7 @@ EAPI=5
AUTOTOOLS_AUTORECONF="true"
-inherit autotools-utils git-2
+inherit autotools-utils git-r3 virtualx
DESCRIPTION="Visualize multidimensional nuclear magnetic resonance (NMR) spectra"
HOMEPAGE="http://burrow-owl.sourceforge.net/"
@@ -38,7 +38,7 @@ PATCHES=(
)
src_unpack() {
- git-2_src_unpack
+ git-r3_src_unpack
use examples && unpack ${A}
}
@@ -50,11 +50,12 @@ src_configure() {
}
src_test () {
- autotools-utils_src_compile -C test-suite check
+ VIRTUALX_COMMAND="autotools-utils_src_compile -C test-suite check"
+ virtualmake
}
src_install() {
- use doc && HTML_DOCS=("${AUTOTOOLS_BUILD_DIR}/doc/api/html/")
+ use doc && HTML_DOCS=( "${AUTOTOOLS_BUILD_DIR}/doc/api/html/." )
autotools-utils_src_install
use examples && \