aboutsummaryrefslogtreecommitdiff
diff options
context:
space:
mode:
Diffstat (limited to 'sci-chemistry/ctffind/ctffind-4.1.14.ebuild')
-rw-r--r--sci-chemistry/ctffind/ctffind-4.1.14.ebuild31
1 files changed, 31 insertions, 0 deletions
diff --git a/sci-chemistry/ctffind/ctffind-4.1.14.ebuild b/sci-chemistry/ctffind/ctffind-4.1.14.ebuild
new file mode 100644
index 000000000..d48db4012
--- /dev/null
+++ b/sci-chemistry/ctffind/ctffind-4.1.14.ebuild
@@ -0,0 +1,31 @@
+# Copyright 2019-2020 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=7
+
+inherit wxwidgets
+
+DESCRIPTION="CTF estimation (ctffind, ctftilt)"
+HOMEPAGE="https://grigoriefflab.umassmed.edu/"
+SRC_URI="https://grigoriefflab.umassmed.edu/system/tdf?path=ctffind-${PV}.tar.gz&file=1&type=node&id=26 -> ${P}.tar.gz"
+
+LICENSE="Janelia-1.2"
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+
+DEPEND="
+ sci-libs/fftw:3.0
+ virtual/jpeg
+ media-libs/tiff
+ x11-libs/wxGTK:*
+"
+RDEPEND="${DEPEND}"
+BDEPEND="
+ ${DEPEND}
+ virtual/pkgconfig"
+
+src_prepare() {
+ default
+ sed /pdb/d -i src/core/core_headers.h || die "removing pdb.h failed"
+ sed /water/d -i src/core/core_headers.h || die "removing water.h failed"
+}