aboutsummaryrefslogtreecommitdiff
diff options
context:
space:
mode:
Diffstat (limited to 'sci-chemistry/ctffind')
-rw-r--r--sci-chemistry/ctffind/Manifest3
-rw-r--r--sci-chemistry/ctffind/ctffind-4.1.10.ebuild37
-rw-r--r--sci-chemistry/ctffind/ctffind-4.1.13.ebuild37
-rw-r--r--sci-chemistry/ctffind/ctffind-4.1.14.ebuild37
-rw-r--r--sci-chemistry/ctffind/metadata.xml12
5 files changed, 126 insertions, 0 deletions
diff --git a/sci-chemistry/ctffind/Manifest b/sci-chemistry/ctffind/Manifest
new file mode 100644
index 000000000..103ece6da
--- /dev/null
+++ b/sci-chemistry/ctffind/Manifest
@@ -0,0 +1,3 @@
+DIST ctffind-4.1.10.tar.gz 625495 BLAKE2B 29c16308005322f53de8e0e9e9c03bc4219f5499bdd303d08e6ee93debe022151fc6b4ea5a2dec3f5c155e26913ae678de98a9b8b37f10d391c284011399f36a SHA512 abaa94781a16b6a72d5ed461f89c1aa313540e4d982c75e81879df2e863bf3ff8ad9fb30d00df603bdc7b56565508e9caba31ef2af67a4a8b732df33b53ee4c6
+DIST ctffind-4.1.13.tar.gz 637267 BLAKE2B 89440d497c6cfe962fd6af14ebc78049ff7341f246bb794384337d7b69571e9123da2bb200f34bf6fdafd984e7f38a77ed1f11a2a4da30f1463b6cfdded0d247 SHA512 1523856b75431b1cdbc3d29336f7d59bf0e7ecee70573c79273a97661e75387aa78c91c3d337431a432e1b15760ca34ad2692832f2f57bdc37951d1bc03958eb
+DIST ctffind-4.1.14.tar.gz 662195 BLAKE2B cb81a971c74e8f2b38e87945aca9f34d4d9cf90770b149ddc5febaee9af4a7392e1d295b2146a14212ea7c820ebf51c5179811cd42875b8a0ef279f6a07e8642 SHA512 115d04ad1adce3f8a99b14e15844df8d6caa4b873faa24eed9d6999a48e88f5a35ffd0cffa6c50c38566cc0091e0de5baec4d0cc62719540a9cfe67bc7333d42
diff --git a/sci-chemistry/ctffind/ctffind-4.1.10.ebuild b/sci-chemistry/ctffind/ctffind-4.1.10.ebuild
new file mode 100644
index 000000000..a69a36308
--- /dev/null
+++ b/sci-chemistry/ctffind/ctffind-4.1.10.ebuild
@@ -0,0 +1,37 @@
+# Copyright 2019-2021 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=7
+
+WX_GTK_VER="3.0-gtk3"
+inherit wxwidgets
+
+DESCRIPTION="CTF estimation (ctffind, ctftilt)"
+HOMEPAGE="https://grigoriefflab.umassmed.edu/"
+SRC_URI="https://grigoriefflab.umassmed.edu/system/tdf?path=ctffind-${PV}.tar.gz&file=1&type=node&id=26 -> ${P}.tar.gz"
+
+LICENSE="Janelia-1.2"
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+
+DEPEND="
+ sci-libs/fftw:3.0
+ media-libs/libjpeg-turbo
+ media-libs/tiff
+ x11-libs/wxGTK:*
+"
+RDEPEND="${DEPEND}"
+BDEPEND="
+ ${DEPEND}
+ virtual/pkgconfig"
+
+src_prepare() {
+ default
+ sed /pdb/d -i src/core/core_headers.h || die "removing pdb.h failed"
+ sed /water/d -i src/core/core_headers.h || die "removing water.h failed"
+}
+
+src_configure() {
+ setup-wxwidgets
+ default
+}
diff --git a/sci-chemistry/ctffind/ctffind-4.1.13.ebuild b/sci-chemistry/ctffind/ctffind-4.1.13.ebuild
new file mode 100644
index 000000000..a69a36308
--- /dev/null
+++ b/sci-chemistry/ctffind/ctffind-4.1.13.ebuild
@@ -0,0 +1,37 @@
+# Copyright 2019-2021 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=7
+
+WX_GTK_VER="3.0-gtk3"
+inherit wxwidgets
+
+DESCRIPTION="CTF estimation (ctffind, ctftilt)"
+HOMEPAGE="https://grigoriefflab.umassmed.edu/"
+SRC_URI="https://grigoriefflab.umassmed.edu/system/tdf?path=ctffind-${PV}.tar.gz&file=1&type=node&id=26 -> ${P}.tar.gz"
+
+LICENSE="Janelia-1.2"
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+
+DEPEND="
+ sci-libs/fftw:3.0
+ media-libs/libjpeg-turbo
+ media-libs/tiff
+ x11-libs/wxGTK:*
+"
+RDEPEND="${DEPEND}"
+BDEPEND="
+ ${DEPEND}
+ virtual/pkgconfig"
+
+src_prepare() {
+ default
+ sed /pdb/d -i src/core/core_headers.h || die "removing pdb.h failed"
+ sed /water/d -i src/core/core_headers.h || die "removing water.h failed"
+}
+
+src_configure() {
+ setup-wxwidgets
+ default
+}
diff --git a/sci-chemistry/ctffind/ctffind-4.1.14.ebuild b/sci-chemistry/ctffind/ctffind-4.1.14.ebuild
new file mode 100644
index 000000000..a69a36308
--- /dev/null
+++ b/sci-chemistry/ctffind/ctffind-4.1.14.ebuild
@@ -0,0 +1,37 @@
+# Copyright 2019-2021 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=7
+
+WX_GTK_VER="3.0-gtk3"
+inherit wxwidgets
+
+DESCRIPTION="CTF estimation (ctffind, ctftilt)"
+HOMEPAGE="https://grigoriefflab.umassmed.edu/"
+SRC_URI="https://grigoriefflab.umassmed.edu/system/tdf?path=ctffind-${PV}.tar.gz&file=1&type=node&id=26 -> ${P}.tar.gz"
+
+LICENSE="Janelia-1.2"
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+
+DEPEND="
+ sci-libs/fftw:3.0
+ media-libs/libjpeg-turbo
+ media-libs/tiff
+ x11-libs/wxGTK:*
+"
+RDEPEND="${DEPEND}"
+BDEPEND="
+ ${DEPEND}
+ virtual/pkgconfig"
+
+src_prepare() {
+ default
+ sed /pdb/d -i src/core/core_headers.h || die "removing pdb.h failed"
+ sed /water/d -i src/core/core_headers.h || die "removing water.h failed"
+}
+
+src_configure() {
+ setup-wxwidgets
+ default
+}
diff --git a/sci-chemistry/ctffind/metadata.xml b/sci-chemistry/ctffind/metadata.xml
new file mode 100644
index 000000000..7e9e870fd
--- /dev/null
+++ b/sci-chemistry/ctffind/metadata.xml
@@ -0,0 +1,12 @@
+<?xml version="1.0" encoding="UTF-8"?>
+<!DOCTYPE pkgmetadata SYSTEM "http://www.gentoo.org/dtd/metadata.dtd">
+<pkgmetadata>
+ <maintainer type="project">
+ <email>sci-chemistry@gentoo.org</email>
+ <name>Gentoo Chemistry Project</name>
+ </maintainer>
+ <maintainer type="person">
+ <email>alexxy@gentoo.org</email>
+ <name>Alexey Shvetsov</name>
+ </maintainer>
+</pkgmetadata>