aboutsummaryrefslogtreecommitdiff
diff options
context:
space:
mode:
Diffstat (limited to 'sci-chemistry/mgltools-molkit/mgltools-molkit-1.5.6.ebuild')
-rw-r--r--sci-chemistry/mgltools-molkit/mgltools-molkit-1.5.6.ebuild44
1 files changed, 0 insertions, 44 deletions
diff --git a/sci-chemistry/mgltools-molkit/mgltools-molkit-1.5.6.ebuild b/sci-chemistry/mgltools-molkit/mgltools-molkit-1.5.6.ebuild
deleted file mode 100644
index dd79cf6ef..000000000
--- a/sci-chemistry/mgltools-molkit/mgltools-molkit-1.5.6.ebuild
+++ /dev/null
@@ -1,44 +0,0 @@
-# Copyright 1999-2015 Gentoo Foundation
-# Distributed under the terms of the GNU General Public License v2
-
-EAPI=5
-
-PYTHON_COMPAT=( python2_7 )
-
-inherit distutils-r1 eutils
-
-MY_PN="MolKit"
-MY_P="${MY_PN}-${PV/_rc3/}"
-
-DESCRIPTION="MGLTools Plugin -- MolKit"
-HOMEPAGE="http://mgltools.scripps.edu"
-SRC_URI="http://mgltools.scripps.edu/downloads/tars/releases/REL${PV}/mgltools_source_${PV}.tar.gz"
-
-LICENSE="MGLTOOLS MPL-1.1"
-SLOT="0"
-KEYWORDS="~amd64 ~x86"
-IUSE=""
-
-RDEPEND="sci-chemistry/pdb2pqr"
-DEPEND="${RDEPEND}
- dev-lang/swig"
-
-S="${WORKDIR}"/${MY_P}
-
-DOCS=( MolKit/RELNOTES )
-
-src_unpack() {
- tar xzpf "${DISTDIR}"/${A} mgltools_source_${PV/_/}/MGLPACKS/${MY_P}.tar.gz || die
- tar xzpf mgltools_source_${PV/_/}/MGLPACKS/${MY_P}.tar.gz || die
-}
-
-python_prepare_all() {
- ecvs_clean
- find "${S}" -name LICENSE -type f -delete || die
-
- sed \
- -e 's:^.*CVS:#&1:g' \
- -e 's:^.*LICENSE:#&1:g' \
- -i "${S}"/MANIFEST.in || die
- distutils-r1_python_prepare_all
-}