aboutsummaryrefslogtreecommitdiff
diff options
context:
space:
mode:
Diffstat (limited to 'sci-chemistry/mgltools-networkeditor/mgltools-networkeditor-1.5.4.ebuild')
-rw-r--r--sci-chemistry/mgltools-networkeditor/mgltools-networkeditor-1.5.4.ebuild19
1 files changed, 18 insertions, 1 deletions
diff --git a/sci-chemistry/mgltools-networkeditor/mgltools-networkeditor-1.5.4.ebuild b/sci-chemistry/mgltools-networkeditor/mgltools-networkeditor-1.5.4.ebuild
index 3144d4a91..e42957430 100644
--- a/sci-chemistry/mgltools-networkeditor/mgltools-networkeditor-1.5.4.ebuild
+++ b/sci-chemistry/mgltools-networkeditor/mgltools-networkeditor-1.5.4.ebuild
@@ -21,9 +21,26 @@ DEPEND="${RDEPEND}
S="${WORKDIR}"/${MY_P}
+DOCS="NetworkEditor/RELNOTES"
+
src_unpack() {
tar xzpf "${DISTDIR}"/${A} mgltools_source_${PV}/MGLPACKS/${MY_P}.tar.gz
tar xzpf mgltools_source_${PV}/MGLPACKS/${MY_P}.tar.gz
- find . -name CVS -type d -exec rm -rf '{}' \;
+ find "${S}" -name CVS -type d -exec rm -rf '{}' \; >& /dev/null
+ find "${S}" -name LICENSE -type f -exec rm -f '{}' \; >& /dev/null
+
+ sed \
+ -e 's:^.*CVS:#&1:g' \
+ -e 's:^.*LICENSE:#&1:g' \
+ -i "${S}"/MANIFEST.in
+}
+
+src_install() {
+ mglpath="$(python_get_sitedir)/MGLToolsPckgs/"
+
+ distutils_src_install \
+ --install-purelib="${mglpath}" \
+ --install-platlib="${mglpath}" \
+ --install-scripts="${mglpath}"
}