aboutsummaryrefslogtreecommitdiff
diff options
context:
space:
mode:
Diffstat (limited to 'sci-chemistry/modeller/modeller-9.12-r3.ebuild')
-rw-r--r--sci-chemistry/modeller/modeller-9.12-r3.ebuild9
1 files changed, 4 insertions, 5 deletions
diff --git a/sci-chemistry/modeller/modeller-9.12-r3.ebuild b/sci-chemistry/modeller/modeller-9.12-r3.ebuild
index c1a5d810b..79c68add8 100644
--- a/sci-chemistry/modeller/modeller-9.12-r3.ebuild
+++ b/sci-chemistry/modeller/modeller-9.12-r3.ebuild
@@ -1,4 +1,4 @@
-# Copyright 1999-2014 Gentoo Foundation
+# Copyright 1999-2015 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
# $Id$
@@ -27,7 +27,6 @@ INPATH="${EPREFIX}"/opt/modeller${ver}
QA_PREBUILT="/opt/*"
-
pkg_setup() {
case ${ARCH} in
x86)
@@ -45,18 +44,18 @@ python_prepare_all(){
}
python_compile(){
- cd src/swig
+ cd src/swig || die
swig -python -keyword -nodefaultctor -nodefaultdtor -noproxy modeller.i || die
distutils-r1_python_compile
}
python_install() {
- cd src/swig
+ cd src/swig || die
distutils-r1_python_install
}
python_install_all(){
- cd "${S}"
+ cd "${S}" || die
sed \
-e "/^EXECUTABLE_TYPE/s:xxx:${EXECTYPE}:g" \
-e "/MODINSTALL/s:xxx:\"${INPATH}\":g" \