aboutsummaryrefslogtreecommitdiff
diff options
context:
space:
mode:
Diffstat (limited to 'sci-chemistry/openbabel-python')
-rw-r--r--sci-chemistry/openbabel-python/ChangeLog3
-rw-r--r--sci-chemistry/openbabel-python/openbabel-python-9999.ebuild3
2 files changed, 4 insertions, 2 deletions
diff --git a/sci-chemistry/openbabel-python/ChangeLog b/sci-chemistry/openbabel-python/ChangeLog
index 0f52b419e..f02b86cc1 100644
--- a/sci-chemistry/openbabel-python/ChangeLog
+++ b/sci-chemistry/openbabel-python/ChangeLog
@@ -2,6 +2,9 @@
# Copyright 1999-2013 Gentoo Foundation; Distributed under the GPL v2
# $Header: $
+ 14 Nov 2013; Reinis Danne <rei4dan@gmail.com> openbabel-python-9999.ebuild:
+ CMake now is able to find Python module target dir.
+
*openbabel-python-9999 (26 Sep 2013)
26 Sep 2013; Reinis Danne <rei4dan@gmail.com> +openbabel-python-9999.ebuild,
diff --git a/sci-chemistry/openbabel-python/openbabel-python-9999.ebuild b/sci-chemistry/openbabel-python/openbabel-python-9999.ebuild
index f0b113268..de787dde8 100644
--- a/sci-chemistry/openbabel-python/openbabel-python-9999.ebuild
+++ b/sci-chemistry/openbabel-python/openbabel-python-9999.ebuild
@@ -50,7 +50,6 @@ src_configure() {
-DBINDINGS_ONLY=ON
-DBABEL_SYSTEM_LIBRARY=${EPREFIX}/usr/$(get_libdir)/libopenbabel.so
-DOB_MODULE_PATH=${EPREFIX}/usr/$(get_libdir)/openbabel/${PV}
- -DLIB_INSTALL_DIR=${ED}/usr/$(get_libdir)/${EPYTHON}/site-packages
-DPYTHON_BINDINGS=ON
-DPYTHON_EXECUTABLE=${PYTHON}
-DPYTHON_INCLUDE_DIR=${EPREFIX}/usr/include/${EPYTHON}
@@ -75,7 +74,7 @@ src_install() {
my_impl_src_install() {
cd "${BUILD_DIR}" || die
- cmake -DCOMPONENT=bindings_python -P cmake_install.cmake
+ DESTDIR=${ED} cmake -DCOMPONENT=bindings_python -P cmake_install.cmake
python_optimize
}