aboutsummaryrefslogtreecommitdiff
diff options
context:
space:
mode:
Diffstat (limited to 'sci-chemistry/openbabel/openbabel-2.3.0.ebuild')
-rw-r--r--sci-chemistry/openbabel/openbabel-2.3.0.ebuild28
1 files changed, 26 insertions, 2 deletions
diff --git a/sci-chemistry/openbabel/openbabel-2.3.0.ebuild b/sci-chemistry/openbabel/openbabel-2.3.0.ebuild
index 743a4a245..df0324a41 100644
--- a/sci-chemistry/openbabel/openbabel-2.3.0.ebuild
+++ b/sci-chemistry/openbabel/openbabel-2.3.0.ebuild
@@ -10,16 +10,40 @@ DESCRIPTION="Interconverts file formats used in molecular modeling"
HOMEPAGE="http://openbabel.sourceforge.net/"
SRC_URI="mirror://sourceforge/openbabel/${P}.tar.gz"
-KEYWORDS="~amd64 ~hppa ~ppc ~ppc64 ~sparc ~x86 ~amd64-linux ~x86-linux"
+KEYWORDS="~amd64"
SLOT="0"
LICENSE="GPL-2"
-IUSE=""
+IUSE="doc gui"
RDEPEND="
>=dev-libs/libxml2-2.6.5
+ >=sci-chemistry/inchi-1.03
+ gui? ( x11-libs/wxGTK )
!sci-chemistry/babel
dev-cpp/eigen:2
sys-libs/zlib"
DEPEND="${RDEPEND}
>=dev-util/cmake-2.4.8"
+
+src_configure() {
+ local mycmakeargs=""
+ mycmakeargs="${mycmakearg}
+ -DOPENBABEL_USE_SYSTEM_INCHI=ON
+ $(cmake-utils_use gui BUILD_GUI)
+ $(cmake-utils_use_enable test TESTS)"
+
+ cmake-utils_src_configure
+}
+
+src_install() {
+ dodoc AUTHORS ChangeLog NEWS README THANKS || die
+ dodoc doc/{*.inc,README*,*.inc,*.mol2} || die
+ dohtml doc/{*.html,*.png} || die
+ if use doc ; then
+ insinto /usr/share/doc/${PF}/API/html
+ doins doc/API/html/* || die
+ fi
+
+ cmake-utils_src_install
+}