aboutsummaryrefslogtreecommitdiff
diff options
context:
space:
mode:
Diffstat (limited to 'sci-chemistry/pymol/files')
-rw-r--r--sci-chemistry/pymol/files/pymol-1.2_beta6-data-path.patch30
-rw-r--r--sci-chemistry/pymol/files/pymol-1.2_beta6-shaders.patch11
2 files changed, 41 insertions, 0 deletions
diff --git a/sci-chemistry/pymol/files/pymol-1.2_beta6-data-path.patch b/sci-chemistry/pymol/files/pymol-1.2_beta6-data-path.patch
new file mode 100644
index 000000000..86c3fe1f1
--- /dev/null
+++ b/sci-chemistry/pymol/files/pymol-1.2_beta6-data-path.patch
@@ -0,0 +1,30 @@
+diff -arNu -uarN pymol/modules/pymol/commanding.py pymol.new/modules/pymol/commanding.py
+--- pymol/modules/pymol/commanding.py 2009-03-31 12:43:14.585834066 +0200
++++ pymol.new/modules/pymol/commanding.py 2009-03-31 12:44:26.436354330 +0200
+@@ -219,11 +219,11 @@
+ _self.unlock(0,_self)
+ r = DEFAULT_SUCCESS
+ if show_splash==1: # generic / open-source
+- png_path = _self.exp_path("$PYMOL_PATH/data/pymol/splash.png")
++ png_path = _self.exp_path("$PYMOL_DATA/pymol/splash.png")
+ elif show_splash==2: # evaluation builds
+- png_path = _self.exp_path("$PYMOL_PATH/data/pymol/epymol.png")
++ png_path = _self.exp_path("$PYMOL_DATA/pymol/epymol.png")
+ else: # incentive builds
+- png_path = _self.exp_path("$PYMOL_PATH/data/pymol/ipymol.png")
++ png_path = _self.exp_path("$PYMOL_DATA/pymol/ipymol.png")
+ if os.path.exists(png_path):
+ _self.do("_ cmd.load_png('%s',0,quiet=1)"%png_path)
+ else:
+diff -arNu -uarN pymol/modules/pymol/importing.py pymol.new/modules/pymol/importing.py
+--- pymol/modules/pymol/importing.py 2009-03-31 12:43:14.546250540 +0200
++++ pymol.new/modules/pymol/importing.py 2009-03-31 12:44:48.876657949 +0200
+@@ -191,7 +191,7 @@
+ '''
+ r = DEFAULT_ERROR
+
+- tables = { 'cmyk' : "$PYMOL_PATH/data/pymol/cmyk.png",
++ tables = { 'cmyk' : "$PYMOL_DATA/pymol/cmyk.png",
+ 'pymol' : 'pymol',
+ 'rgb' : 'rgb' }
+
diff --git a/sci-chemistry/pymol/files/pymol-1.2_beta6-shaders.patch b/sci-chemistry/pymol/files/pymol-1.2_beta6-shaders.patch
new file mode 100644
index 000000000..7f4a24f48
--- /dev/null
+++ b/sci-chemistry/pymol/files/pymol-1.2_beta6-shaders.patch
@@ -0,0 +1,11 @@
+diff -uarN pymol-9999.orig/setup.py pymol-9999/setup.py
+--- pymol-9999.orig/setup.py 2008-06-18 11:47:58.000000000 +0200
++++ pymol-9999/setup.py 2008-06-18 11:48:52.000000000 +0200
+@@ -143,6 +143,7 @@
+ def_macros=[("_PYMOL_MODULE",None),
+ ("_PYMOL_INLINE",None),
+ ("_PYMOL_FREETYPE",None),
++ ("_PYMOL_OPENGL_SHADERS",None),
+ # Numeric Python support
+ # ("_PYMOL_NUMPY",None),
+ # VMD plugin support