aboutsummaryrefslogtreecommitdiff
diff options
context:
space:
mode:
Diffstat (limited to 'sci-chemistry/refmac/refmac-5.5.0100-r1.ebuild')
-rw-r--r--sci-chemistry/refmac/refmac-5.5.0100-r1.ebuild6
1 files changed, 5 insertions, 1 deletions
diff --git a/sci-chemistry/refmac/refmac-5.5.0100-r1.ebuild b/sci-chemistry/refmac/refmac-5.5.0100-r1.ebuild
index db096c2f2..122a1af43 100644
--- a/sci-chemistry/refmac/refmac-5.5.0100-r1.ebuild
+++ b/sci-chemistry/refmac/refmac-5.5.0100-r1.ebuild
@@ -26,9 +26,13 @@ S="${WORKDIR}"
PATCHES=(
"${FILESDIR}"/$(get_version_component_range 1-2 ${PV})-allow-dynamic-linking.patch
- "${FILESDIR}"/test.log.patch
)
+src_prepare() {
+ base_src_prepare
+ use test && epatch "${FILESDIR}"/test.log.patch
+}
+
src_compile() {
emake \
FC=$(tc-getFC) \