aboutsummaryrefslogtreecommitdiff
diff options
context:
space:
mode:
Diffstat (limited to 'sci-chemistry/simpson/files/3.0.1-gentoo.patch')
-rw-r--r--sci-chemistry/simpson/files/3.0.1-gentoo.patch28
1 files changed, 28 insertions, 0 deletions
diff --git a/sci-chemistry/simpson/files/3.0.1-gentoo.patch b/sci-chemistry/simpson/files/3.0.1-gentoo.patch
new file mode 100644
index 000000000..61d170f89
--- /dev/null
+++ b/sci-chemistry/simpson/files/3.0.1-gentoo.patch
@@ -0,0 +1,28 @@
+diff --git a/Makefile b/Makefile
+index c5f6fcf..25e328f 100644
+--- a/Makefile
++++ b/Makefile
+@@ -7,8 +7,9 @@ C_OBJS = *.o
+ #INCLUDES = -IC:/Tcl/include -I../CBLAS/src
+ #LIBRARIES = -lm *.dll
+ # LINUX:
+-INCLUDES = -I/usr/include/tcl8.5
+-LIBRARIES = -lm -lgslcblas -llapack -ltcl8.5
++INCLUDES = -I@GENTOO_PORTAGE_EPREFIX@/usr/include/
++BLASLIBS = `pkg-config --libs cblas lapack`
++LIBRARIES = -lm ${BLASLIBS} -ltcl
+
+ FLAGS = -c -O3
+ CC = gcc
+@@ -16,9 +17,9 @@ RM = rm
+ TAR = tar
+
+ simpson: $(C_OBJS)
+- $(CC) $(LIBRARIES) $(C_OBJS) -o simpson
++ $(CC) $(LDFLAGS) -o simpson $(C_OBJS) $(LIBRARIES)
+ $(C_OBJS):
+- $(CC) $(FLAGS) $(INCLUDES) *.c
++ $(CC) $(CFLAGS) $(INCLUDES) -c *.c
+ clean:
+ $(RM) -f *.o simpson
+ dist: