aboutsummaryrefslogtreecommitdiff
diff options
context:
space:
mode:
Diffstat (limited to 'sci-geosciences/fullprof-bin/fullprof-bin-2012.11.ebuild')
-rw-r--r--sci-geosciences/fullprof-bin/fullprof-bin-2012.11.ebuild57
1 files changed, 57 insertions, 0 deletions
diff --git a/sci-geosciences/fullprof-bin/fullprof-bin-2012.11.ebuild b/sci-geosciences/fullprof-bin/fullprof-bin-2012.11.ebuild
new file mode 100644
index 000000000..9c8cc7b8c
--- /dev/null
+++ b/sci-geosciences/fullprof-bin/fullprof-bin-2012.11.ebuild
@@ -0,0 +1,57 @@
+# Copyright 1999-2012 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: $
+
+EAPI="4"
+
+DESCRIPTION="a set of crystallographic tools mainly for Rietveld analysis"
+HOMEPAGE="http://www.ill.eu/sites/fullprof/index.html"
+SRC_URI="http://www.ill.eu/sites/fullprof/downloads/FullProf_Suite_Nov2012_Lin.tgz"
+LICENSE="freedist HPND"
+# There is no clear license specified. But according to Docs/Readme_Fp_Suite.txt
+# those two seem to be appropriate.
+SLOT="0"
+KEYWORDS="~x86 ~amd64"
+IUSE="+X +doc +examples"
+
+RDEPEND="X? ( >=x11-libs/motif-2.3 )"
+
+S="${WORKDIR}/"
+
+src_install() {
+ BASEDIR="/opt/fullprof"
+ echo "FULLPROF=\"${BASEDIR}\"" > 99fullprof
+ doenvd 99fullprof
+ rm 99fullprof || die
+
+ if use !examples; then
+ rm -r Examples || die
+ fi
+
+ if use !doc; then
+ rm -r Docs || die
+ rm -r Html || die
+ else
+ # fix (html) documentation to actually work
+ # as upstream is using inconsistent upper and lower case
+ mv Docs docs || die
+ cd docs || die
+ for i in *.HTM; do
+ mv "$i" "${i,,}" || die
+ done
+ mv "FullProf_Manual.pdf" "Fullprof_Manual.pdf" || die
+ mv "Manual_FullProf_Studio.pdf" "Manual_Fullprof_Studio.pdf" || die
+ mv "FullProf_News.htm" "Fullprof_News.htm" || die
+ for i in FullProf_News_200?.htm; do
+ mv "$i" "${i/FullProf/Fullprof}" || die
+ done
+ cd .. || die
+ fi
+
+ mkdir -p "${D}/${BASEDIR}" || die
+ # make symlinks
+ for i in * ; do
+ [[ -x $i && ! -d $i ]] && dosym "../fullprof/${i}" /opt/bin/"${i##*/}"
+ done
+ mv "${S}"/* "${D}/${BASEDIR}" || die
+}