aboutsummaryrefslogtreecommitdiff
diff options
context:
space:
mode:
Diffstat (limited to 'sci-libs/HDF5Plugin-Zstandard')
-rw-r--r--sci-libs/HDF5Plugin-Zstandard/HDF5Plugin-Zstandard-0_pre20201121-r1.ebuild27
-rw-r--r--sci-libs/HDF5Plugin-Zstandard/Manifest1
-rw-r--r--sci-libs/HDF5Plugin-Zstandard/metadata.xml11
3 files changed, 39 insertions, 0 deletions
diff --git a/sci-libs/HDF5Plugin-Zstandard/HDF5Plugin-Zstandard-0_pre20201121-r1.ebuild b/sci-libs/HDF5Plugin-Zstandard/HDF5Plugin-Zstandard-0_pre20201121-r1.ebuild
new file mode 100644
index 000000000..d1257f0ee
--- /dev/null
+++ b/sci-libs/HDF5Plugin-Zstandard/HDF5Plugin-Zstandard-0_pre20201121-r1.ebuild
@@ -0,0 +1,27 @@
+# Copyright 2020-2022 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=7
+
+inherit cmake
+
+DESCRIPTION="ZSTD plugin for hdf5"
+HOMEPAGE="https://github.com/aparamon/HDF5Plugin-Zstandard"
+COMMIT="d5afdb5f04116d5c2d1a869dc9c7c0c72832b143"
+SRC_URI="https://github.com/aparamon/HDF5Plugin-Zstandard/archive/${COMMIT}.tar.gz -> ${P}.tar.gz"
+
+LICENSE="Apache-2.0"
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+
+DEPEND="app-arch/zstd >=sci-libs/hdf5-1.12.2-r5"
+RDEPEND="${DEPEND}"
+
+S=${WORKDIR}/${PN}-${COMMIT}
+
+src_configure() {
+ local mycmakeargs=(
+ -DPLUGIN_INSTALL_PATH="${EPREFIX}/usr/$(get_libdir)/hdf5/plugin"
+ )
+ cmake_src_configure
+}
diff --git a/sci-libs/HDF5Plugin-Zstandard/Manifest b/sci-libs/HDF5Plugin-Zstandard/Manifest
new file mode 100644
index 000000000..80a0da53a
--- /dev/null
+++ b/sci-libs/HDF5Plugin-Zstandard/Manifest
@@ -0,0 +1 @@
+DIST HDF5Plugin-Zstandard-0_pre20201121.tar.gz 6405 BLAKE2B 6d1f169375297872751ee95f0ab6c9b3afaddb222a65c685786bd40ded357c9950d1ae895063c17935ff9fd9f819ba1eb58192daf7bac7d4a1be5e2caa28b322 SHA512 642afc2cc7e9439f5f0c34e1616b1f9d4c883c954ae1027933c98ac99564854513c5d4e4ce589594f3b739ad441d2880a218ee3518318949ed9f18ecff3dc4a7
diff --git a/sci-libs/HDF5Plugin-Zstandard/metadata.xml b/sci-libs/HDF5Plugin-Zstandard/metadata.xml
new file mode 100644
index 000000000..a171606a6
--- /dev/null
+++ b/sci-libs/HDF5Plugin-Zstandard/metadata.xml
@@ -0,0 +1,11 @@
+<?xml version="1.0" encoding="UTF-8"?>
+<!DOCTYPE pkgmetadata SYSTEM "http://www.gentoo.org/dtd/metadata.dtd">
+<pkgmetadata>
+ <maintainer type="person">
+ <email>xgreenlandforwyy@gmail.com</email>
+ <name>Yiyang Wu</name>
+ </maintainer>
+ <upstream>
+ <remote-id type="github">aparamon/HDF5Plugin-Zstandard</remote-id>
+ </upstream>
+</pkgmetadata>