aboutsummaryrefslogtreecommitdiff
diff options
context:
space:
mode:
Diffstat (limited to 'sci-libs/arpack/arpack-96.ebuild')
-rw-r--r--sci-libs/arpack/arpack-96.ebuild28
1 files changed, 12 insertions, 16 deletions
diff --git a/sci-libs/arpack/arpack-96.ebuild b/sci-libs/arpack/arpack-96.ebuild
index cff6df3d6..b3ca1b3b7 100644
--- a/sci-libs/arpack/arpack-96.ebuild
+++ b/sci-libs/arpack/arpack-96.ebuild
@@ -5,7 +5,7 @@
inherit toolchain-funcs fortran
-DESCRIPTION="ARPACK is a collection of Fortran77 subroutines designed to solve large scale eigenvalue problems."
+DESCRIPTION="Library to solve large scale eigenvalue problems."
HOMEPAGE="http://www.caam.rice.edu/software/ARPACK"
# not a very good name: patch.tar.gz :(
SRC_URI="http://www.caam.rice.edu/software/ARPACK/SRC/${PN}${PV}.tar.gz
@@ -13,45 +13,42 @@ SRC_URI="http://www.caam.rice.edu/software/ARPACK/SRC/${PN}${PV}.tar.gz
mpi? http://www.caam.rice.edu/software/ARPACK/SRC/p${PN}${PV}.tar.gz
mpi? http://www.caam.rice.edu/software/ARPACK/SRC/ppatch.tar.gz"
-LICENSE="freedist"
+LICENSE="BSD"
SLOT="0"
IUSE="mpi examples"
KEYWORDS="~amd64 ~x86"
DEPEND="virtual/libc
- mpi? ( virtual/mpi )"
+mpi? ( virtual/mpi )"
# lapack USE/dependence not implemented because README file strongly
# recommands using arpack internal lapack (unless is lapack-2,
# which does not exist on gentoo).
-# anyway, i could not run examples with the installed lapack-3 on my system
-
-# mpi use is very experimental (basically non working)
+# anyway, I could not run examples with the installed lapack-3 on my system
+# mpi use is experimental
S=${WORKDIR}/ARPACK
src_compile() {
- local mpiconf=""
- if use mpi; then
- mpiconf='PFC=$(tc-getF77) PFFLAGS="${FFLAGS}"'
- fi
emake \
home=${S} \
- FC=$(tc-getF77) \
+ FC=${FORTRANC} \
AR=$(tc-getAR) \
RANLIB=$(tc-getRANLIB) \
FFLAGS="${FFLAGS}" \
- MAKE=/usr/bin/make \
+ MAKE=$(which make) \
ARPACKLIB=${S}/libarpack.a \
PRECISIONS="single double complex complex16 sdrv ddrv cdrv zdrv" \
- ${mpiconf} \
all || die "emake failed"
+
+ # todo: make shared libraries
}
src_install() {
dolib.a libarpack.a
- dodoc README
+
+ dodoc -README
docinto DOCUMENTS
dodoc DOCUMENTS/*
@@ -68,7 +65,7 @@ src_install() {
sed -e '/^include/d' \
-e 's:_\$(PLAT)::g' \
-e '1i PLIBS=-lparpack' \
- -e '2i PFC=$(tc-getF77)' \
+ -e '2i PFC=mpif77' \
-e '3i PFFLAGS=${FFLAGS}' \
-i ${mkfile}
done
@@ -84,5 +81,4 @@ src_postinst() {
einfo "ARPACK has been compiled with internal LAPACK routines"
einfo "\"LDFLAGS=-llarpack\" is enough to link your applications"
einfo
-
} \ No newline at end of file