aboutsummaryrefslogtreecommitdiff
diff options
context:
space:
mode:
Diffstat (limited to 'sci-libs/bigdft-abi')
-rw-r--r--sci-libs/bigdft-abi/Manifest2
-rw-r--r--sci-libs/bigdft-abi/bigdft-abi-1.0.4-r3.ebuild181
-rw-r--r--sci-libs/bigdft-abi/files/bigdft-abi-1.0.4-0002.patch37
-rw-r--r--sci-libs/bigdft-abi/files/bigdft-abi-1.0.4-0003.patch49
-rw-r--r--sci-libs/bigdft-abi/files/bigdft-abi-1.0.4-0004.patch20
-rw-r--r--sci-libs/bigdft-abi/files/bigdft-abi-1.0.4-0006.patch43
-rw-r--r--sci-libs/bigdft-abi/files/bigdft-abi-1.0.4-0007.patch344
-rw-r--r--sci-libs/bigdft-abi/files/bigdft-abi-1.0.4-CUDA_gethostname.patch22
-rw-r--r--sci-libs/bigdft-abi/metadata.xml29
9 files changed, 0 insertions, 727 deletions
diff --git a/sci-libs/bigdft-abi/Manifest b/sci-libs/bigdft-abi/Manifest
deleted file mode 100644
index 49efc5411..000000000
--- a/sci-libs/bigdft-abi/Manifest
+++ /dev/null
@@ -1,2 +0,0 @@
-DIST bigdft-abi-1.0.4-0005.patch 190680 BLAKE2B c79821e3f7b94a9d78794ea864dab143ef5532db97bd8abf3b164eab450c4a292fb40c95a6d53156af978dad2aa940bab6342e77e23818dd554b1dff7d41689f SHA512 b0f7b34d621b2b40c8427a98320b28d0a2975742dea8ca1095db86ac712e6d8f4c3f8223f07fa0c2b73b5d6711fc0ee16e4fef312e1254b11ba0a7a047bd8a91
-DIST bigdft-abi-1.0.4.tar.gz 8982260 BLAKE2B 013008aa1aea2fc3954f8618075a6e3fe8c5cc395e6b4789e3ddfa24fae9a7e6e2fa7c8e30182deb1a5e61c0fc50046b4f53471dbbde5dfb63f3f03e6982f20e SHA512 556001d1ffd08be70b97f07a8a150d5d033a4611957180a7a25b41963754e0e3d2bb2a4e9d5b6beb8ff6fb1eb6f4ae9b51633cfe3d7f5a8ed20a85be21031c35
diff --git a/sci-libs/bigdft-abi/bigdft-abi-1.0.4-r3.ebuild b/sci-libs/bigdft-abi/bigdft-abi-1.0.4-r3.ebuild
deleted file mode 100644
index 73471b0dc..000000000
--- a/sci-libs/bigdft-abi/bigdft-abi-1.0.4-r3.ebuild
+++ /dev/null
@@ -1,181 +0,0 @@
-# Copyright 1999-2014 Gentoo Foundation
-# Distributed under the terms of the GNU General Public License v2
-
-EAPI=5
-
-PYTHON_COMPAT=( python2_7 )
-
-inherit autotools-utils eutils flag-o-matic fortran-2 python-any-r1 toolchain-funcs
-
-DESCRIPTION="A DFT electronic structure code using a wavelet basis set"
-HOMEPAGE="http://www.abinit.org/downloads/plug-in-sources"
-SRC_URI="
- http://forge.abinit.org/fallbacks/${P}.tar.gz
- https://raw.githubusercontent.com/gentoo-science/sci/master/patches/bigdft-abi-1.0.4-0005.patch
- "
-
-LICENSE="GPL-3"
-SLOT="0"
-KEYWORDS="~amd64 ~x86 ~amd64-linux"
-IUSE="cuda doc etsf_io glib mpi netcdf openmp opencl scalapack test"
-
-RDEPEND="
- >=sci-libs/libxc-1.2.0-r1[fortran]
- virtual/blas
- virtual/fortran
- virtual/lapack
- dev-libs/libyaml
- mpi? ( virtual/mpi )
- cuda? ( dev-util/nvidia-cuda-sdk )
- opencl? ( virtual/opencl )
- glib? ( >=dev-libs/glib-2.22 )
- etsf_io? ( >=sci-libs/etsf_io-1.0.3-r2 )
- netcdf? (
- || (
- sci-libs/netcdf[fortran]
- sci-libs/netcdf-fortran
- )
- )
- scalapack? ( virtual/scalapack )"
-DEPEND="${RDEPEND}
- virtual/pkgconfig
- >=sys-devel/autoconf-2.59
- doc? ( virtual/latex-base )
- ${PYTHON_DEPS}
- dev-python/pyyaml[libyaml]
- dev-util/gdbus-codegen
- app-arch/tar
- app-arch/gzip"
-
-DOCS=( README INSTALL ChangeLog AUTHORS NEWS )
-
-FORTRAN_STANDARD=90
-
-pkg_setup() {
- # fortran-2.eclass does not handle mpi wrappers
- if use mpi; then
- export FC="mpif90"
- export F77="mpif77"
- export CC="mpicc"
- else
- tc-export FC F77 CC
- fi
-
- # This should be correct.
- # It is gcc-centric because toolchain-funcs.eclass is gcc-centric.
- # Should a bug be filed against toolchain-funcs.eclass?
- # if use openmp; then
- # tc-has-openmp || \
- # die "Please select an openmp capable compiler like gcc[openmp]"
- # fi
- #
- # Luckily Abinit is a fortran package.
- # fortran-2.eclass has its own test for OpenMP support,
- # more general than toolchain-funcs.eclass
- # The test itself proceeds inside fortran-2_pkg_setup
- if use openmp; then FORTRAN_NEED_OPENMP=1; fi
-
- fortran-2_pkg_setup
-
- if use openmp; then
- # based on _fortran-has-openmp() of fortran-2.eclass
- local openmp=""
- local fcode=ebuild-openmp-flags.f
- local _fc=$(tc-getFC)
-
- pushd "${T}"
- cat <<- EOF > "${fcode}"
- 1 call omp_get_num_threads
- 2 end
- EOF
-
- for openmp in -fopenmp -xopenmp -openmp -mp -omp -qsmp=omp; do
- "${_fc}" "${openmp}" "${fcode}" -o "${fcode}.x" && break
- done
-
- rm -f "${fcode}.*"
- popd
-
- append-flags "${openmp}"
- fi
-
- python-any-r1_pkg_setup
-}
-
-src_prepare() {
- epatch \
- "${FILESDIR}"/${P}-0002.patch \
- "${FILESDIR}"/${P}-0003.patch \
- "${FILESDIR}"/${P}-0004.patch \
- "${DISTDIR}"/${P}-0005.patch \
- "${FILESDIR}"/${P}-0006.patch \
- "${FILESDIR}"/${P}-0007.patch \
- "${FILESDIR}"/${P}-CUDA_gethostname.patch
-
- eautoreconf
-}
-
-src_configure() {
- local modules="${EPREFIX}/usr/include"
- local netcdff_libs="-lnetcdff"
- filter-flags '-m*' '-O*' "-pipe"
- local nvcflags="${CFLAGS}"
- _filter-var nvcflags '-m*' '-O*' "-pipe" "-W*"
- use cuda && filter-ldflags '-m*' '-O*' "-pipe" "-W*"
- local mylapack="lapack"
- use scalapack && mylapack="scalapack"
- local myeconfargs=(
- $(use_enable mpi)
- --enable-optimised-convolution
- --enable-pseudo
- --enable-libbigdft
- --enable-binaries
- --disable-minima-hopping
- --disable-internal-libyaml
- --enable-internal-libabinit
- --with-moduledir="${modules}"
- --with-ext-linalg="$($(tc-getPKG_CONFIG) --libs-only-l "${mylapack}")"
- --with-ext-linalg-path="$($(tc-getPKG_CONFIG) --libs-only-L "${mylapack}")"
- --with-libxc="yes"
- --disable-internal-libxc
- $(use_enable cuda cuda-gpu)
- $(use_with cuda cuda-path /opt/cuda)
- $(use_with cuda nvcc-flags "${nvcflags}")
- $(use_enable opencl)
- $(use_with etsf_io etsf-io)
- "$(use etsf_io && echo "--with-netcdf-libs=$($(tc-getPKG_CONFIG) --libs netcdf) ${netcdff_libs}")"
- $(use_with glib gobject)
- $(use_with scalapack)
- $(use_with scalapack scalapack-path "${EPREFIX}/usr/$(get_libdir)")
- $(use_with scalapack blacs)
- $(use_with scalapack blacs-path "${EPREFIX}/usr/$(get_libdir)")
- PKG_CONFIG="$(tc-getPKG_CONFIG)"
- FCFLAGS="${FCFLAGS}"
- LD="$(tc-getLD)"
- CPP="$(tc-getCPP)"
- )
- autotools-utils_src_configure
-}
-
-src_compile() {
- #autotools-utils_src_compile() expanded
- _check_build_dir
- pushd "${AUTOTOOLS_BUILD_DIR}" > /dev/null
- emake -j1
- sed -i -e's%\$(top_builddir)/[^ ]*/lib\([^ /$-]*\)\.a%-l\1%g' bigdft.pc || die
- popd > /dev/null
-
- #autotools-utils_src_compile
- if use doc; then
- VARTEXFONTS="${T}/fonts"
- autotools-utils_src_compile doc
- fi
-}
-
-src_test() {
- ewarn "The tests broken upstream. NOT testing"
-}
-
-src_install() {
- autotools-utils_src_install
-}
diff --git a/sci-libs/bigdft-abi/files/bigdft-abi-1.0.4-0002.patch b/sci-libs/bigdft-abi/files/bigdft-abi-1.0.4-0002.patch
deleted file mode 100644
index e533022c7..000000000
--- a/sci-libs/bigdft-abi/files/bigdft-abi-1.0.4-0002.patch
+++ /dev/null
@@ -1,37 +0,0 @@
-*** bigdft-abi-1.0.4/src/wfn_opt/applyh.f90 Tue May 28 15:42:28 2013
---- bigdft-patch/src/wfn_opt/applyh.f90 Thu Jun 6 11:29:13 2013
-***************
-*** 1104,1110 ****
- istart_c=1
- if(at%npspcode(iatype)==7) then
- call atom_projector_paw(ikpt,iat,idir,istart_c,iproj,nlpspd%nprojel,&
-! lr,hx,hy,hz,rxyz(1,iat),at,orbs,nlpspd%plr(iat),proj,nwarnings,proj_G(iatype))
- else
- call atom_projector(ikpt,iat,idir,istart_c,iproj,nlpspd%nprojel,&
- lr,hx,hy,hz,rxyz(1,iat),at,orbs,nlpspd%plr(iat),proj,nwarnings)
---- 1104,1110 ----
- istart_c=1
- if(at%npspcode(iatype)==7) then
- call atom_projector_paw(ikpt,iat,idir,istart_c,iproj,nlpspd%nprojel,&
-! lr,hx,hy,hz,paw%rpaw(iatype),rxyz(1,iat),at,orbs,nlpspd%plr(iat),proj,nwarnings,proj_G(iatype))
- else
- call atom_projector(ikpt,iat,idir,istart_c,iproj,nlpspd%nprojel,&
- lr,hx,hy,hz,rxyz(1,iat),at,orbs,nlpspd%plr(iat),proj,nwarnings)
-***************
-*** 1116,1122 ****
- istart_c=1
- if(at%npspcode(iatype)==7) then
- ! PAW case:
-! call apply_atproj_iorb_paw(iat,iorb,nlpspd%nprojel,&
- at,orbs,wfd,nlpspd%plr(iat),proj,&
- psi(ispsi),hpsi(ispsi),eproj_sum,proj_G(iatype),paw)
- else
---- 1116,1123 ----
- istart_c=1
- if(at%npspcode(iatype)==7) then
- ! PAW case:
-! call apply_atproj_iorb_paw(iat,iorb,ispsi,istart_c,&
-! nlpspd%nprojel,&
- at,orbs,wfd,nlpspd%plr(iat),proj,&
- psi(ispsi),hpsi(ispsi),eproj_sum,proj_G(iatype),paw)
- else
diff --git a/sci-libs/bigdft-abi/files/bigdft-abi-1.0.4-0003.patch b/sci-libs/bigdft-abi/files/bigdft-abi-1.0.4-0003.patch
deleted file mode 100644
index 5b406a9a7..000000000
--- a/sci-libs/bigdft-abi/files/bigdft-abi-1.0.4-0003.patch
+++ /dev/null
@@ -1,49 +0,0 @@
-*** bigdft-abi-1.0.4/src/init/gautowav.f90 Mon Jul 9 16:43:33 2012
---- bigdft-patch/src/init/gautowav.f90 Mon Jun 10 11:16:37 2013
-***************
-*** 675,680 ****
---- 675,681 ----
- integer :: i_stat,i_all,ishell,iexpo,icoeff,iat,isat,ng,l,m,i,nterm,ig
- integer :: nterms_max,nterms,iterm,n_gau,ml1,mu1,ml2,mu2,ml3,mu3 !n(c) iscoeff
- real(gp) :: rx,ry,rz,gau_a
-+ real(gp) :: gau_cut !only for PAW
- integer, dimension(nterm_max) :: lx,ly,lz
- real(gp), dimension(nterm_max) :: fac_arr
- real(wp), allocatable, dimension(:,:,:) :: work
-***************
-*** 746,762 ****
- gau_a=G%xp(1,iexpo+ig-1)
- n_gau=lx(i)
- !print *,'x',gau_a,nterm,ncplx,kx,ky,kz,ml1,mu1,lr%d%n1
-! call gauss_to_daub_k(hx,kx*hx,ncplx,1,ncplx,fac_arr(i),rx,gau_a,n_gau,&
- lr%ns1,lr%d%n1,ml1,mu1,&
- wx(1,0,1,iterm),work,nw,perx)
- n_gau=ly(i)
- !print *,'y',ml2,mu2,lr%d%n2
-! call gauss_to_daub_k(hy,ky*hy,ncplx,1,ncplx,wfn_gau(icoeff),ry,gau_a,n_gau,&
- lr%ns2,lr%d%n2,ml2,mu2,&
- wy(1,0,1,iterm),work,nw,pery)
- n_gau=lz(i)
- !print *,'z',ml3,mu3,lr%d%n3
-! call gauss_to_daub_k(hz,kz*hz,ncplx,1,ncplx,G%psiat(:,iexpo+ig-1),rz,gau_a,n_gau,&
- lr%ns3,lr%d%n3,ml3,mu3,&
- wz(1,0,1,iterm),work,nw,perz)
- iterm=iterm+1
---- 747,763 ----
- gau_a=G%xp(1,iexpo+ig-1)
- n_gau=lx(i)
- !print *,'x',gau_a,nterm,ncplx,kx,ky,kz,ml1,mu1,lr%d%n1
-! call gauss_to_daub_k(hx,kx*hx,ncplx,1,ncplx,fac_arr(i),rx,gau_a,gau_cut,n_gau,&
- lr%ns1,lr%d%n1,ml1,mu1,&
- wx(1,0,1,iterm),work,nw,perx)
- n_gau=ly(i)
- !print *,'y',ml2,mu2,lr%d%n2
-! call gauss_to_daub_k(hy,ky*hy,ncplx,1,ncplx,wfn_gau(icoeff),ry,gau_a,gau_cut,n_gau,&
- lr%ns2,lr%d%n2,ml2,mu2,&
- wy(1,0,1,iterm),work,nw,pery)
- n_gau=lz(i)
- !print *,'z',ml3,mu3,lr%d%n3
-! call gauss_to_daub_k(hz,kz*hz,ncplx,1,ncplx,G%psiat(:,iexpo+ig-1),rz,gau_a,gau_cut,n_gau,&
- lr%ns3,lr%d%n3,ml3,mu3,&
- wz(1,0,1,iterm),work,nw,perz)
- iterm=iterm+1
diff --git a/sci-libs/bigdft-abi/files/bigdft-abi-1.0.4-0004.patch b/sci-libs/bigdft-abi/files/bigdft-abi-1.0.4-0004.patch
deleted file mode 100644
index e9af11a58..000000000
--- a/sci-libs/bigdft-abi/files/bigdft-abi-1.0.4-0004.patch
+++ /dev/null
@@ -1,20 +0,0 @@
-*** bigdft-abi-1.0.4/src/hpsiortho.f90 Wed Jan 30 10:10:56 2013
---- bigdft-patch/src/hpsiortho.f90 Tue Jun 11 09:49:22 2013
-***************
-*** 720,726 ****
- if(at%npspcode(1)==7) then
- call atom_projector_paw(ikpt,iat,0,istart_c,iproj,&
- nlpspd%nprojel,&
-! Lzd%Glr,Lzd%hgrids(1),Lzd%hgrids(2),Lzd%hgrids(3),rxyz(1,iat),at,orbs,&
- nlpspd%plr(iat),proj,nwarnings,proj_G(iatype))
- else
- call atom_projector(ikpt,iat,0,istart_c,iproj,&
---- 720,727 ----
- if(at%npspcode(1)==7) then
- call atom_projector_paw(ikpt,iat,0,istart_c,iproj,&
- nlpspd%nprojel,&
-! Lzd%Glr,Lzd%hgrids(1),Lzd%hgrids(2),Lzd%hgrids(3),&
-! paw%rpaw(iatype),rxyz(1,iat),at,orbs,&
- nlpspd%plr(iat),proj,nwarnings,proj_G(iatype))
- else
- call atom_projector(ikpt,iat,0,istart_c,iproj,&
diff --git a/sci-libs/bigdft-abi/files/bigdft-abi-1.0.4-0006.patch b/sci-libs/bigdft-abi/files/bigdft-abi-1.0.4-0006.patch
deleted file mode 100644
index 56a67fc66..000000000
--- a/sci-libs/bigdft-abi/files/bigdft-abi-1.0.4-0006.patch
+++ /dev/null
@@ -1,43 +0,0 @@
-diff -urN bigdft-abi-1.0.4.old/configure bigdft-abi-1.0.4.new/configure
---- bigdft-abi-1.0.4.old/configure 2012-10-05 15:10:27.000000000 +0200
-+++ bigdft-abi-1.0.4.new/configure 2013-06-11 16:51:00.000000000 +0200
-@@ -9185,15 +9185,15 @@
- withlibabinit=no
- fi
-
-- as_ac_File=`$as_echo "ac_cv_file_$ac_libabinit_dir/include/ab6_moldyn.$ax_fc_mod_ext" | $as_tr_sh`
--{ $as_echo "$as_me:${as_lineno-$LINENO}: checking for $ac_libabinit_dir/include/ab6_moldyn.$ax_fc_mod_ext" >&5
--$as_echo_n "checking for $ac_libabinit_dir/include/ab6_moldyn.$ax_fc_mod_ext... " >&6; }
-+ as_ac_File=`$as_echo "ac_cv_file_$ac_libabinit_dir/include/ab7_moldyn.$ax_fc_mod_ext" | $as_tr_sh`
-+{ $as_echo "$as_me:${as_lineno-$LINENO}: checking for $ac_libabinit_dir/include/ab7_moldyn.$ax_fc_mod_ext" >&5
-+$as_echo_n "checking for $ac_libabinit_dir/include/ab7_moldyn.$ax_fc_mod_ext... " >&6; }
- if eval \${$as_ac_File+:} false; then :
- $as_echo_n "(cached) " >&6
- else
- test "$cross_compiling" = yes &&
- as_fn_error $? "cannot check for file existence when cross compiling" "$LINENO" 5
--if test -r "$ac_libabinit_dir/include/ab6_moldyn.$ax_fc_mod_ext"; then
-+if test -r "$ac_libabinit_dir/include/ab7_moldyn.$ax_fc_mod_ext"; then
- eval "$as_ac_File=yes"
- else
- eval "$as_ac_File=no"
-@@ -9208,15 +9208,15 @@
- moldyn="no"
- fi
-
-- as_ac_File=`$as_echo "ac_cv_file_$ac_libabinit_dir/include/ab6_symmetry.$ax_fc_mod_ext" | $as_tr_sh`
--{ $as_echo "$as_me:${as_lineno-$LINENO}: checking for $ac_libabinit_dir/include/ab6_symmetry.$ax_fc_mod_ext" >&5
--$as_echo_n "checking for $ac_libabinit_dir/include/ab6_symmetry.$ax_fc_mod_ext... " >&6; }
-+ as_ac_File=`$as_echo "ac_cv_file_$ac_libabinit_dir/include/ab7_symmetry.$ax_fc_mod_ext" | $as_tr_sh`
-+{ $as_echo "$as_me:${as_lineno-$LINENO}: checking for $ac_libabinit_dir/include/ab7_symmetry.$ax_fc_mod_ext" >&5
-+$as_echo_n "checking for $ac_libabinit_dir/include/ab7_symmetry.$ax_fc_mod_ext... " >&6; }
- if eval \${$as_ac_File+:} false; then :
- $as_echo_n "(cached) " >&6
- else
- test "$cross_compiling" = yes &&
- as_fn_error $? "cannot check for file existence when cross compiling" "$LINENO" 5
--if test -r "$ac_libabinit_dir/include/ab6_symmetry.$ax_fc_mod_ext"; then
-+if test -r "$ac_libabinit_dir/include/ab7_symmetry.$ax_fc_mod_ext"; then
- eval "$as_ac_File=yes"
- else
- eval "$as_ac_File=no"
diff --git a/sci-libs/bigdft-abi/files/bigdft-abi-1.0.4-0007.patch b/sci-libs/bigdft-abi/files/bigdft-abi-1.0.4-0007.patch
deleted file mode 100644
index 8f871d8fd..000000000
--- a/sci-libs/bigdft-abi/files/bigdft-abi-1.0.4-0007.patch
+++ /dev/null
@@ -1,344 +0,0 @@
-diff -crB bigdft-abi-1.0.4/src/init/projectors.f90 bigdft-patch/src/init/projectors.f90
-*** bigdft-abi-1.0.4/src/init/projectors.f90 Thu Nov 29 11:09:02 2012
---- bigdft-patch/src/init/projectors.f90 Thu Jun 6 11:31:46 2013
-***************
-*** 383,394 ****
- END SUBROUTINE fill_projectors
-
- subroutine atom_projector_paw(ikpt,iat,idir,istart_c,iproj,nprojel,&
-! lr,hx,hy,hz,rxyz,at,orbs,plr,proj,nwarnings,proj_G)
- use module_base
- use module_types
- implicit none
- integer, intent(in) :: iat,idir,ikpt,nprojel
-! real(gp), intent(in) :: hx,hy,hz
- type(atoms_data), intent(in) :: at
- type(orbitals_data), intent(in) :: orbs
- type(locreg_descriptors), intent(in) :: plr
---- 383,394 ----
- END SUBROUTINE fill_projectors
-
- subroutine atom_projector_paw(ikpt,iat,idir,istart_c,iproj,nprojel,&
-! lr,hx,hy,hz,rpaw,rxyz,at,orbs,plr,proj,nwarnings,proj_G)
- use module_base
- use module_types
- implicit none
- integer, intent(in) :: iat,idir,ikpt,nprojel
-! real(gp), intent(in) :: hx,hy,hz,rpaw
- type(atoms_data), intent(in) :: at
- type(orbitals_data), intent(in) :: orbs
- type(locreg_descriptors), intent(in) :: plr
-***************
-*** 460,466 ****
- ! plr%wfd%keyvglob,plr%wfd%keyglob,proj_tmp(1),nwarnings)
- !END DEBUG
- call projector_paw(at%geocode,at%atomnames(ityp),iat,idir,l,i,&
-! proj_G%psiat(:,jj),proj_G%xp(:,jj),rxyz(1),lr,&
- hx,hy,hz,kx,ky,kz,proj_G%ncplx,ncplx_k,&
- mbvctr_c,mbvctr_f,mbseg_c,mbseg_f,&
- plr%wfd%keyvglob,plr%wfd%keyglob,proj_tmp(1),nwarnings)
---- 460,466 ----
- ! plr%wfd%keyvglob,plr%wfd%keyglob,proj_tmp(1),nwarnings)
- !END DEBUG
- call projector_paw(at%geocode,at%atomnames(ityp),iat,idir,l,i,&
-! proj_G%psiat(:,jj),proj_G%xp(:,jj),rpaw,rxyz(1),lr,&
- hx,hy,hz,kx,ky,kz,proj_G%ncplx,ncplx_k,&
- mbvctr_c,mbvctr_f,mbseg_c,mbseg_f,&
- plr%wfd%keyvglob,plr%wfd%keyglob,proj_tmp(1),nwarnings)
-***************
-*** 646,651 ****
---- 646,652 ----
- integer :: istart_c,nterm,idir2
- real(gp) :: fpi,factor,rx,ry,rz
- real(dp) :: scpr
-+ real(gp) :: gau_cut !dummy here just for PAW
- integer, dimension(3) :: nterm_arr
- integer, dimension(nterm_max) :: lx,ly,lz
- integer, dimension(3,nterm_max,3) :: lxyz_arr
-***************
-*** 709,715 ****
-
- call crtproj(geocode,nterm,lr,hx,hy,hz,kx,ky,kz,&
- ncplx_g,ncplx,&
-! gau_a,factors,rx,ry,rz,lx,ly,lz,&
- mbvctr_c,mbvctr_f,mseg_c,mseg_f,keyv_p,keyg_p,proj(istart_c))
-
- ! testing
---- 710,716 ----
-
- call crtproj(geocode,nterm,lr,hx,hy,hz,kx,ky,kz,&
- ncplx_g,ncplx,&
-! gau_a,gau_cut,factors,rx,ry,rz,lx,ly,lz,&
- mbvctr_c,mbvctr_f,mseg_c,mseg_f,keyv_p,keyg_p,proj(istart_c))
-
- ! testing
-***************
-*** 1055,1061 ****
- end subroutine projector_paw_isf
-
- subroutine projector_paw(geocode,atomname,iat,idir,l,i,&
-! factor,gau_a,rxyz,lr,&
- hx,hy,hz,kx,ky,kz,ncplx_g,ncplx_k,&
- mbvctr_c,mbvctr_f,mseg_c,mseg_f,keyv_p,keyg_p,proj,nwarnings)
- use module_base
---- 1056,1062 ----
- end subroutine projector_paw_isf
-
- subroutine projector_paw(geocode,atomname,iat,idir,l,i,&
-! factor,gau_a,gau_cut,rxyz,lr,&
- hx,hy,hz,kx,ky,kz,ncplx_g,ncplx_k,&
- mbvctr_c,mbvctr_f,mseg_c,mseg_f,keyv_p,keyg_p,proj,nwarnings)
- use module_base
-***************
-*** 1066,1072 ****
- integer, intent(in) :: iat,idir,l,i,mbvctr_c,mbvctr_f,mseg_c,mseg_f
- integer, intent(in) :: ncplx_k,ncplx_g
- type(locreg_descriptors),intent(in) :: lr
-! real(gp), intent(in) :: hx,hy,hz,kx,ky,kz
- !integer, dimension(2,3), intent(in) :: nboxp_c,nboxp_f
- integer, dimension(mseg_c+mseg_f), intent(in) :: keyv_p
- integer, dimension(2,mseg_c+mseg_f), intent(in) :: keyg_p
---- 1067,1073 ----
- integer, intent(in) :: iat,idir,l,i,mbvctr_c,mbvctr_f,mseg_c,mseg_f
- integer, intent(in) :: ncplx_k,ncplx_g
- type(locreg_descriptors),intent(in) :: lr
-! real(gp), intent(in) :: hx,hy,hz,kx,ky,kz,gau_cut
- !integer, dimension(2,3), intent(in) :: nboxp_c,nboxp_f
- integer, dimension(mseg_c+mseg_f), intent(in) :: keyv_p
- integer, dimension(2,mseg_c+mseg_f), intent(in) :: keyg_p
-***************
-*** 1131,1137 ****
-
- call crtproj(geocode,nterm,lr,hx,hy,hz,kx,ky,kz,&
- ncplx_g,ncplx_k,&
-! gau_a,factors(1:ncplx_g,1:nterm),&
- rx,ry,rz,lx(1:nterm),ly(1:nterm),lz(1:nterm),&
- mbvctr_c,mbvctr_f,mseg_c,mseg_f,keyv_p,keyg_p,&
- proj(istart_c))
---- 1132,1138 ----
-
- call crtproj(geocode,nterm,lr,hx,hy,hz,kx,ky,kz,&
- ncplx_g,ncplx_k,&
-! gau_a,gau_cut,factors(1:ncplx_g,1:nterm),&
- rx,ry,rz,lx(1:nterm),ly(1:nterm),lz(1:nterm),&
- mbvctr_c,mbvctr_f,mseg_c,mseg_f,keyv_p,keyg_p,&
- proj(istart_c))
-***************
-*** 1248,1254 ****
- !! in the arrays proj_c, proj_f
- subroutine crtproj(geocode,nterm,lr, &
- hx,hy,hz,kx,ky,kz,ncplx_g,ncplx_k,&
-! gau_a,fac_arr,rx,ry,rz,lx,ly,lz, &
- mvctr_c,mvctr_f,mseg_c,mseg_f,keyv_p,keyg_p,proj)
- use module_base
- use module_types
---- 1249,1255 ----
- !! in the arrays proj_c, proj_f
- subroutine crtproj(geocode,nterm,lr, &
- hx,hy,hz,kx,ky,kz,ncplx_g,ncplx_k,&
-! gau_a,gau_cut,fac_arr,rx,ry,rz,lx,ly,lz, &
- mvctr_c,mvctr_f,mseg_c,mseg_f,keyv_p,keyg_p,proj)
- use module_base
- use module_types
-***************
-*** 1256,1262 ****
- character(len=1), intent(in) :: geocode
- integer, intent(in) :: nterm,mvctr_c,mvctr_f,mseg_c,mseg_f
- integer, intent(in) :: ncplx_g,ncplx_k
-! real(gp), intent(in) :: hx,hy,hz,rx,ry,rz,kx,ky,kz
- integer, dimension(nterm), intent(in) :: lx,ly,lz
- real(gp), dimension(ncplx_g,nterm), intent(in) :: fac_arr
- real(gp), dimension(ncplx_g),intent(in):: gau_a
---- 1257,1263 ----
- character(len=1), intent(in) :: geocode
- integer, intent(in) :: nterm,mvctr_c,mvctr_f,mseg_c,mseg_f
- integer, intent(in) :: ncplx_g,ncplx_k
-! real(gp), intent(in) :: hx,hy,hz,rx,ry,rz,kx,ky,kz,gau_cut
- integer, dimension(nterm), intent(in) :: lx,ly,lz
- real(gp), dimension(ncplx_g,nterm), intent(in) :: fac_arr
- real(gp), dimension(ncplx_g),intent(in):: gau_a
-***************
-*** 1313,1327 ****
-
- factor(:)=fac_arr(:,iterm)
- n_gau=lx(iterm)
-! call gauss_to_daub_k(hx,kx*hx,ncplx_w,ncplx_g,ncplx_k,factor,rx,gau_a,n_gau,ns1,n1,ml1,mu1,&
- wprojx(1,0,1,iterm),work,nw,perx)
-
- n_gau=ly(iterm)
-! call gauss_to_daub_k(hy,ky*hy,ncplx_w,ncplx_g,ncplx_k,1.d0,ry,gau_a,n_gau,ns2,n2,ml2,mu2,&
- wprojy(1,0,1,iterm),work,nw,pery)
-
- n_gau=lz(iterm)
-! call gauss_to_daub_k(hz,kz*hz,ncplx_w,ncplx_g,ncplx_k,1.d0,rz,gau_a,n_gau,ns3,n3,ml3,mu3,&
- wprojz(1,0,1,iterm),work,nw,perz)
- end do
- !the filling of the projector should be different if ncplx_k==1 or 2
---- 1314,1328 ----
-
- factor(:)=fac_arr(:,iterm)
- n_gau=lx(iterm)
-! call gauss_to_daub_k(hx,kx*hx,ncplx_w,ncplx_g,ncplx_k,factor,rx,gau_a,gau_cut,n_gau,ns1,n1,ml1,mu1,&
- wprojx(1,0,1,iterm),work,nw,perx)
-
- n_gau=ly(iterm)
-! call gauss_to_daub_k(hy,ky*hy,ncplx_w,ncplx_g,ncplx_k,1.d0,ry,gau_a,gau_cut,n_gau,ns2,n2,ml2,mu2,&
- wprojy(1,0,1,iterm),work,nw,pery)
-
- n_gau=lz(iterm)
-! call gauss_to_daub_k(hz,kz*hz,ncplx_w,ncplx_g,ncplx_k,1.d0,rz,gau_a,gau_cut,n_gau,ns3,n3,ml3,mu3,&
- wprojz(1,0,1,iterm),work,nw,perz)
- end do
- !the filling of the projector should be different if ncplx_k==1 or 2
-diff -crB bigdft-abi-1.0.4/src/modules/types.f90 bigdft-patch/src/modules/types.f90
-*** bigdft-abi-1.0.4/src/modules/types.f90 Thu Jan 3 10:18:08 2013
---- bigdft-patch/src/modules/types.f90 Thu Jun 6 11:27:48 2013
-***************
-*** 1119,1124 ****
---- 1119,1125 ----
- type(cprj_objects),dimension(:,:),allocatable :: cprj
- real(wp),dimension(:),pointer :: spsi
- real(wp),dimension(:,:),pointer :: sij
-+ real(dp),dimension(:),pointer :: rpaw
- end type paw_objects
-
- contains
-***************
-*** 2090,2095 ****
---- 2091,2097 ----
- nullify(paw%indlmn)
- nullify(paw%spsi)
- nullify(paw%sij)
-+ nullify(paw%rpaw)
-
- if(present(rholoc)) then
- nullify(rholoc%msz)
-diff -crB bigdft-abi-1.0.4/src/wavelib/gauss_to_daub.f90 bigdft-patch/src/wavelib/gauss_to_daub.f90
-*** bigdft-abi-1.0.4/src/wavelib/gauss_to_daub.f90 Mon Jul 9 16:43:33 2012
---- bigdft-patch/src/wavelib/gauss_to_daub.f90 Thu Jun 6 13:01:01 2013
-***************
-*** 448,454 ****
- !! In this version, we dephase the projector to wrt the center of the gaussian
- !! this should not have an impact on the results since the operator is unchanged
- subroutine gauss_to_daub_k(hgrid,kval,ncplx_w,ncplx_g,ncplx_k,&
-! factor,gau_cen,gau_a,n_gau,&!no err, errsuc
- nstart,nmax,n_left,n_right,c,&
- ww,nwork,periodic) !added work arrays ww with dimension nwork
- use module_base
---- 448,454 ----
- !! In this version, we dephase the projector to wrt the center of the gaussian
- !! this should not have an impact on the results since the operator is unchanged
- subroutine gauss_to_daub_k(hgrid,kval,ncplx_w,ncplx_g,ncplx_k,&
-! factor,gau_cen,gau_a,gau_cut,n_gau,&!no err, errsuc
- nstart,nmax,n_left,n_right,c,&
- ww,nwork,periodic) !added work arrays ww with dimension nwork
- use module_base
-***************
-*** 458,464 ****
- integer, intent(in) :: ncplx_w !size of the ww matrix
- integer, intent(in) :: ncplx_g !1 or 2 for simple or complex gaussians, respectively.
- integer, intent(in) :: ncplx_k !use 2 for k-points.
-! real(gp), intent(in) :: hgrid,gau_cen,kval
- real(gp),dimension(ncplx_g),intent(in)::factor,gau_a
- real(wp), dimension(0:nwork,2,ncplx_w), intent(inout) :: ww
- integer, intent(out) :: n_left,n_right
---- 458,464 ----
- integer, intent(in) :: ncplx_w !size of the ww matrix
- integer, intent(in) :: ncplx_g !1 or 2 for simple or complex gaussians, respectively.
- integer, intent(in) :: ncplx_k !use 2 for k-points.
-! real(gp), intent(in) :: hgrid,gau_cen,kval,gau_cut
- real(gp),dimension(ncplx_g),intent(in)::factor,gau_a
- real(wp), dimension(0:nwork,2,ncplx_w), intent(inout) :: ww
- integer, intent(out) :: n_left,n_right
-***************
-*** 467,473 ****
- character(len=*), parameter :: subname='gauss_to_daub_k'
- integer :: i_all,i_stat
- integer :: rightx,leftx,right_t,i0,i,k,length,j,icplx
-! real(gp) :: a1,a2,z0,h,x,r,coeff,r2,rk
- real(gp) :: fac(ncplx_g)
- real(wp) :: func,cval,sval,cval2,sval2
- real(wp), dimension(:,:,:), allocatable :: cc
---- 467,473 ----
- character(len=*), parameter :: subname='gauss_to_daub_k'
- integer :: i_all,i_stat
- integer :: rightx,leftx,right_t,i0,i,k,length,j,icplx
-! real(gp) :: a1,a2,z0,h,x,r,coeff,r2,rk,gcut
- real(gp) :: fac(ncplx_g)
- real(wp) :: func,cval,sval,cval2,sval2
- real(wp), dimension(:,:,:), allocatable :: cc
-***************
-*** 487,492 ****
---- 487,493 ----
- end if
- i0=nint(gau_cen/hgrid) ! the array is centered at i0
- z0=gau_cen/hgrid-real(i0,gp)
-+ gcut=gau_cut/hgrid
- h=.125_gp*.5_gp
-
- !calculate the array sizes;
-***************
-*** 655,681 ****
- do i=leftx,rightx
- x=real(i-i0*16,gp)*h
- r=x-z0
-! r2=r*r
-! cval=real(cos(a2*r2),wp)
-! sval=real(sin(a2*r2),wp)
-! r2=0.5_gp*r2/(a1**2)
-! func=real(dexp(-real(r2,kind=8)),wp)
-! ww(i-leftx,1,1)=func*cval
-! ww(i-leftx,1,2)=func*sval
- enddo
- else
- do i=leftx,rightx
- x=real(i-i0*16,gp)*h
- r=x-z0
-! r2=r*r
-! cval=real(cos(a2*r2),wp)
-! sval=real(sin(a2*r2),wp)
-! coeff=r**n_gau
-! r2=0.5_gp*r2/(a1**2)
-! func=real(dexp(-real(r2,kind=8)),wp)
-! func=real(coeff,wp)*func
-! ww(i-leftx,1,1)=func*cval
-! ww(i-leftx,1,2)=func*sval
- enddo
- end if
-
---- 656,690 ----
- do i=leftx,rightx
- x=real(i-i0*16,gp)*h
- r=x-z0
-! if(abs(r)-gcut < 1e-8) then
-! r2=r*r
-! cval=real(cos(a2*r2),wp)
-! sval=real(sin(a2*r2),wp)
-! r2=0.5_gp*r2/(a1**2)
-! func=real(dexp(-real(r2,kind=8)),wp)
-! ww(i-leftx,1,1)=func*cval
-! ww(i-leftx,1,2)=func*sval
-! else
-! ww(i-leftx,1,:)=0.0_wp
-! end if
- enddo
- else
- do i=leftx,rightx
- x=real(i-i0*16,gp)*h
- r=x-z0
-! if( abs(r)-gcut < 1e-8 ) then
-! r2=r*r
-! cval=real(cos(a2*r2),wp)
-! sval=real(sin(a2*r2),wp)
-! coeff=r**n_gau
-! r2=0.5_gp*r2/(a1**2)
-! func=real(dexp(-real(r2,kind=8)),wp)
-! func=real(coeff,wp)*func
-! ww(i-leftx,1,1)=func*cval
-! ww(i-leftx,1,2)=func*sval
-! else
-! ww(i-leftx,1,:)=0.0_wp
-! end if
- enddo
- end if
-
diff --git a/sci-libs/bigdft-abi/files/bigdft-abi-1.0.4-CUDA_gethostname.patch b/sci-libs/bigdft-abi/files/bigdft-abi-1.0.4-CUDA_gethostname.patch
deleted file mode 100644
index 04c45b4d7..000000000
--- a/sci-libs/bigdft-abi/files/bigdft-abi-1.0.4-CUDA_gethostname.patch
+++ /dev/null
@@ -1,22 +0,0 @@
-diff -Naurp bigdft-abi-1.0.4-orig/S_GPU/src/class_utils.h bigdft-abi-1.0.4/S_GPU/src/class_utils.h
---- bigdft-abi-1.0.4-orig/S_GPU/src/class_utils.h 2012-07-09 14:43:33.000000000 +0000
-+++ bigdft-abi-1.0.4/S_GPU/src/class_utils.h 2013-06-27 09:52:17.000000000 +0000
-@@ -32,6 +32,7 @@
- #include <config.h>
- #endif
-
-+#include <unistd.h>
- #include <sstream>
-
- class deleter
-diff -Naurp bigdft-abi-1.0.4-orig/src/CUDA/check_cuda.h bigdft-abi-1.0.4/src/CUDA/check_cuda.h
---- bigdft-abi-1.0.4-orig/src/CUDA/check_cuda.h 2012-07-09 14:43:33.000000000 +0000
-+++ bigdft-abi-1.0.4/src/CUDA/check_cuda.h 2013-06-27 09:51:50.000000000 +0000
-@@ -1,6 +1,7 @@
- #ifndef __checkcuda__
- #define __checkcuda__
-
-+#include <unistd.h>
- #include <string>
- #include <sstream>
-
diff --git a/sci-libs/bigdft-abi/metadata.xml b/sci-libs/bigdft-abi/metadata.xml
deleted file mode 100644
index b5efea318..000000000
--- a/sci-libs/bigdft-abi/metadata.xml
+++ /dev/null
@@ -1,29 +0,0 @@
-<?xml version="1.0" encoding="UTF-8"?>
-<!DOCTYPE pkgmetadata SYSTEM "http://www.gentoo.org/dtd/metadata.dtd">
-<pkgmetadata>
- <maintainer type="project">
- <email>sci-physics@gentoo.org</email>
- <name>Gentoo Physics Project</name>
- </maintainer>
- <longdescription lang="en">
-BigDFT is a package whose main program allows one to find the total energy,
-charge density and electronic structure of systems made of electrons and nuclei
-(molecules and periodic solids) within Density Functional Theory (DFT), using
-pseudopotentials and a wavelets basis. BigDFT-ABI is its fork by ABINIT developers
-to serve as a library for sci-physics/abinit.
-</longdescription>
- <use>
- <flag name="cuda">Enable support for nVidia CUDA</flag>
- <flag name="etsf_io">
-Enable support for reading and writing the European Theoretical
-Spectroscopy facility (ETSF) file format
-</flag>
- <flag name="glib">
-Compile with GLib Object System support
-</flag>
- <flag name="opencl">Enable support for OpenCL GPU acceleration</flag>
- <flag name="scalapack">
-Use ScaLAPACK, a subset of LAPACK routines redesigned for heterogenous computing
-</flag>
- </use>
-</pkgmetadata>