aboutsummaryrefslogtreecommitdiff
diff options
context:
space:
mode:
Diffstat (limited to 'sci-libs/bigdft/files/bigdft-1.6-tuto.1-bigdft.pc.patch')
-rw-r--r--sci-libs/bigdft/files/bigdft-1.6-tuto.1-bigdft.pc.patch203
1 files changed, 203 insertions, 0 deletions
diff --git a/sci-libs/bigdft/files/bigdft-1.6-tuto.1-bigdft.pc.patch b/sci-libs/bigdft/files/bigdft-1.6-tuto.1-bigdft.pc.patch
new file mode 100644
index 000000000..3ddde7014
--- /dev/null
+++ b/sci-libs/bigdft/files/bigdft-1.6-tuto.1-bigdft.pc.patch
@@ -0,0 +1,203 @@
+diff -Naur bigdft-1.6-tuto_orig/Makefile.am bigdft-1.6-tuto/Makefile.am
+--- Makefile.am 2011-10-18 07:39:52.000000000 +0000
++++ Makefile.am 2012-03-21 10:08:44.000000000 +0000
+@@ -4,7 +4,10 @@
+
+ ACLOCAL_AMFLAGS = -I config/m4
+
+-DISTCLEANFILES = config.inc
++DISTCLEANFILES = config.inc bigdft.pc
++
++pkgconfigdir = $(libdir)/pkgconfig
++pkgconfig_DATA = bigdft.pc
+
+ if BUILD_LIBABINIT
+ libABINIT_dir = libABINIT/src
+diff -Naur bigdft-1.6-tuto_orig/Makefile.in bigdft-1.6-tuto/Makefile.in
+--- Makefile.in 2012-03-21 10:03:28.000000000 +0000
++++ Makefile.in 2012-03-21 10:20:48.000000000 +0000
+@@ -33,7 +33,7 @@
+ POST_UNINSTALL = :
+ subdir = .
+ DIST_COMMON = README $(am__configure_deps) $(srcdir)/Makefile.am \
+- $(srcdir)/Makefile.in $(srcdir)/config.h.in \
++ $(srcdir)/Makefile.in $(srcdir)/bigdft.pc.in $(srcdir)/config.h.in \
+ $(top_srcdir)/config/Doxyfile.in $(top_srcdir)/configure \
+ AUTHORS COPYING ChangeLog INSTALL NEWS config/depcomp \
+ config/install-sh config/missing
+@@ -48,7 +48,7 @@
+ configure.lineno config.status.lineno
+ mkinstalldirs = $(install_sh) -d
+ CONFIG_HEADER = config.h
+-CONFIG_CLEAN_FILES = config/Doxyfile
++CONFIG_CLEAN_FILES = bigdft.pc config/Doxyfile
+ CONFIG_CLEAN_VPATH_FILES =
+ SOURCES =
+ DIST_SOURCES =
+@@ -59,6 +59,35 @@
+ install-pdf-recursive install-ps-recursive install-recursive \
+ installcheck-recursive installdirs-recursive pdf-recursive \
+ ps-recursive uninstall-recursive
++am__vpath_adj_setup = srcdirstrip=`echo "$(srcdir)" | sed 's|.|.|g'`;
++am__vpath_adj = case $$p in \
++ $(srcdir)/*) f=`echo "$$p" | sed "s|^$$srcdirstrip/||"`;; \
++ *) f=$$p;; \
++ esac;
++am__strip_dir = f=`echo $$p | sed -e 's|^.*/||'`;
++am__install_max = 40
++am__nobase_strip_setup = \
++ srcdirstrip=`echo "$(srcdir)" | sed 's/[].[^$$\\*|]/\\\\&/g'`
++am__nobase_strip = \
++ for p in $$list; do echo "$$p"; done | sed -e "s|$$srcdirstrip/||"
++am__nobase_list = $(am__nobase_strip_setup); \
++ for p in $$list; do echo "$$p $$p"; done | \
++ sed "s| $$srcdirstrip/| |;"' / .*\//!s/ .*/ ./; s,\( .*\)/[^/]*$$,\1,' | \
++ $(AWK) 'BEGIN { files["."] = "" } { files[$$2] = files[$$2] " " $$1; \
++ if (++n[$$2] == $(am__install_max)) \
++ { print $$2, files[$$2]; n[$$2] = 0; files[$$2] = "" } } \
++ END { for (dir in files) print dir, files[dir] }'
++am__base_list = \
++ sed '$$!N;$$!N;$$!N;$$!N;$$!N;$$!N;$$!N;s/\n/ /g' | \
++ sed '$$!N;$$!N;$$!N;$$!N;s/\n/ /g'
++am__uninstall_files_from_dir = { \
++ test -z "$$files" \
++ || { test ! -d "$$dir" && test ! -f "$$dir" && test ! -r "$$dir"; } \
++ || { echo " ( cd '$$dir' && rm -f" $$files ")"; \
++ $(am__cd) "$$dir" && rm -f $$files; }; \
++ }
++am__installdirs = "$(DESTDIR)$(pkgconfigdir)"
++DATA = $(pkgconfig_DATA)
+ RECURSIVE_CLEAN_TARGETS = mostlyclean-recursive clean-recursive \
+ distclean-recursive maintainer-clean-recursive
+ AM_RECURSIVE_TARGETS = $(RECURSIVE_TARGETS:-recursive=) \
+@@ -232,7 +261,9 @@
+ config/m4
+
+ ACLOCAL_AMFLAGS = -I config/m4
+-DISTCLEANFILES = config.inc
++DISTCLEANFILES = config.inc bigdft.pc
++pkgconfigdir = $(libdir)/pkgconfig
++pkgconfig_DATA = bigdft.pc
+ @BUILD_LIBABINIT_FALSE@libABINIT_dir =
+ @BUILD_LIBABINIT_TRUE@libABINIT_dir = libABINIT/src
+ @BUILD_LIBXC_FALSE@libXC_dir =
+@@ -307,8 +338,28 @@
+
+ distclean-hdr:
+ -rm -f config.h stamp-h1
++bigdft.pc: $(top_builddir)/config.status $(srcdir)/bigdft.pc.in
++ cd $(top_builddir) && $(SHELL) ./config.status $@
+ config/Doxyfile: $(top_builddir)/config.status $(top_srcdir)/config/Doxyfile.in
+ cd $(top_builddir) && $(SHELL) ./config.status $@
++install-pkgconfigDATA: $(pkgconfig_DATA)
++ @$(NORMAL_INSTALL)
++ test -z "$(pkgconfigdir)" || $(MKDIR_P) "$(DESTDIR)$(pkgconfigdir)"
++ @list='$(pkgconfig_DATA)'; test -n "$(pkgconfigdir)" || list=; \
++ for p in $$list; do \
++ if test -f "$$p"; then d=; else d="$(srcdir)/"; fi; \
++ echo "$$d$$p"; \
++ done | $(am__base_list) | \
++ while read files; do \
++ echo " $(INSTALL_DATA) $$files '$(DESTDIR)$(pkgconfigdir)'"; \
++ $(INSTALL_DATA) $$files "$(DESTDIR)$(pkgconfigdir)" || exit $$?; \
++ done
++
++uninstall-pkgconfigDATA:
++ @$(NORMAL_UNINSTALL)
++ @list='$(pkgconfig_DATA)'; test -n "$(pkgconfigdir)" || list=; \
++ files=`for p in $$list; do echo $$p; done | sed -e 's|^.*/||'`; \
++ dir='$(DESTDIR)$(pkgconfigdir)'; $(am__uninstall_files_from_dir)
+
+ # This directory's subdirectories are mostly independent; you can cd
+ # into them and run `make' without going through this Makefile.
+@@ -622,9 +673,12 @@
+ exit 1; } >&2
+ check-am: all-am
+ check: check-recursive
+-all-am: Makefile config.h
++all-am: Makefile $(DATA) config.h
+ installdirs: installdirs-recursive
+ installdirs-am:
++ for dir in "$(DESTDIR)$(pkgconfigdir)"; do \
++ test -z "$$dir" || $(MKDIR_P) "$$dir"; \
++ done
+ install: install-recursive
+ install-exec: install-exec-recursive
+ install-data: install-data-recursive
+@@ -672,7 +726,7 @@
+
+ info-am:
+
+-install-data-am:
++install-data-am: install-pkgconfigDATA
+
+ install-dvi: install-dvi-recursive
+
+@@ -718,7 +772,7 @@
+
+ ps-am:
+
+-uninstall-am:
++uninstall-am: uninstall-pkgconfigDATA
+
+ .MAKE: $(RECURSIVE_CLEAN_TARGETS) $(RECURSIVE_TARGETS) all \
+ ctags-recursive install-am install-strip tags-recursive
+@@ -733,10 +787,10 @@
+ install-data-am install-dvi install-dvi-am install-exec \
+ install-exec-am install-html install-html-am install-info \
+ install-info-am install-man install-pdf install-pdf-am \
+- install-ps install-ps-am install-strip installcheck \
++ install-pkgconfigDATA install-ps install-ps-am install-strip installcheck \
+ installcheck-am installdirs installdirs-am maintainer-clean \
+ maintainer-clean-generic mostlyclean mostlyclean-generic pdf \
+- pdf-am ps ps-am tags tags-recursive uninstall uninstall-am
++ pdf-am ps ps-am tags tags-recursive uninstall uninstall-am uninstall-pkgconfigDATA
+
+ configure
+
+diff -Naur bigdft-1.6-tuto_orig/bigdft.pc.in bigdft-1.6-tuto/bigdft.pc.in
+--- bigdft.pc.in 1970-01-01 00:00:00.000000000 +0000
++++ bigdft.pc.in 2012-02-01 09:43:59.000000000 +0000
+@@ -0,0 +1,11 @@
++prefix=@prefix@
++exec_prefix=@exec_prefix@
++libdir=@libdir@
++includedir=@includedir@
++
++Name: libbigdft
++Description: Library for DFT calculation over wavelets.
++Requires:
++Version: @VERSION@
++Libs: -L${libdir} -lbigdft -lpoissonsolver @LIBS@ @FCLIBS@
++Cflags: -I${includedir}
+diff -Naur bigdft-1.6-tuto_orig/configure bigdft-1.6-tuto/configure
+--- configure 2012-03-21 10:03:26.000000000 +0000
++++ configure 2012-03-21 11:04:52.000000000 +0000
+@@ -8512,7 +8512,7 @@
+ docdir="${docdir}"
+
+
+-ac_config_files="$ac_config_files Makefile libABINIT/src/Makefile config/Doxyfile src/Makefile src/modules/Makefile src/modules/configure.inc src/profiling/Makefile src/PSolver/Makefile src/convolutions/Makefile src/CUDA/Makefile src/OpenCL/Makefile src/dgemmsy/Makefile src/convolutions-c/Makefile src/art/Makefile src/tools/Makefile src/tools/bader/Makefile utils/Makefile utils/PSPfiles/Makefile pseudo/Makefile pseudo/src/Makefile pseudo/tests/Makefile doc/Makefile tests/Makefile tests/fft/Makefile tests/PSolver/Makefile tests/H2-freq/Makefile tests/MINHOP/Makefile tests/NEB/Makefile tests/NEB/input tests/NEB/NEB_include.sh tests/XabsCheb/Makefile tests/SPLSAD/Makefile tests/TDDFT/Makefile tests/OP2P/Makefile tests/DFT/Makefile tests/OpenCL/Makefile tests/CUDA/Makefile tests/ETSF_IO/Makefile tests/tutorials/Makefile tests/xc/Makefile"
++ac_config_files="$ac_config_files Makefile bigdft.pc libABINIT/src/Makefile config/Doxyfile src/Makefile src/modules/Makefile src/modules/configure.inc src/profiling/Makefile src/PSolver/Makefile src/convolutions/Makefile src/CUDA/Makefile src/OpenCL/Makefile src/dgemmsy/Makefile src/convolutions-c/Makefile src/art/Makefile src/tools/Makefile src/tools/bader/Makefile utils/Makefile utils/PSPfiles/Makefile pseudo/Makefile pseudo/src/Makefile pseudo/tests/Makefile doc/Makefile tests/Makefile tests/fft/Makefile tests/PSolver/Makefile tests/H2-freq/Makefile tests/MINHOP/Makefile tests/NEB/Makefile tests/NEB/input tests/NEB/NEB_include.sh tests/XabsCheb/Makefile tests/SPLSAD/Makefile tests/TDDFT/Makefile tests/OP2P/Makefile tests/DFT/Makefile tests/OpenCL/Makefile tests/CUDA/Makefile tests/ETSF_IO/Makefile tests/tutorials/Makefile tests/xc/Makefile"
+
+
+ # Call libXC ./configure script recursively.
+@@ -9349,6 +9349,7 @@
+ "config.h") CONFIG_HEADERS="$CONFIG_HEADERS config.h" ;;
+ "depfiles") CONFIG_COMMANDS="$CONFIG_COMMANDS depfiles" ;;
+ "Makefile") CONFIG_FILES="$CONFIG_FILES Makefile" ;;
++ "bigdft.pc") CONFIG_FILES="$CONFIG_FILES bigdft.pc" ;;
+ "libABINIT/src/Makefile") CONFIG_FILES="$CONFIG_FILES libABINIT/src/Makefile" ;;
+ "config/Doxyfile") CONFIG_FILES="$CONFIG_FILES config/Doxyfile" ;;
+ "src/Makefile") CONFIG_FILES="$CONFIG_FILES src/Makefile" ;;
+diff -Naur bigdft-1.6-tuto_orig/configure.ac bigdft-1.6-tuto/configure.ac
+--- configure.ac 2012-03-21 10:03:02.000000000 +0000
++++ configure.ac 2012-03-21 10:48:53.000000000 +0000
+@@ -715,6 +715,7 @@
+ dnl Give the name of file.in to transform to file
+ AC_CONFIG_FILES([
+ Makefile
++bigdft.pc
+ libABINIT/src/Makefile
+ config/Doxyfile
+ src/Makefile