aboutsummaryrefslogtreecommitdiff
diff options
context:
space:
mode:
Diffstat (limited to 'sci-libs/bigdft')
-rw-r--r--sci-libs/bigdft/ChangeLog6
-rw-r--r--sci-libs/bigdft/bigdft-1.6.0-r2.ebuild8
-rw-r--r--sci-libs/bigdft/bigdft-1.6_pre1-r3.ebuild8
3 files changed, 14 insertions, 8 deletions
diff --git a/sci-libs/bigdft/ChangeLog b/sci-libs/bigdft/ChangeLog
index b0e101e47..7a43f6b50 100644
--- a/sci-libs/bigdft/ChangeLog
+++ b/sci-libs/bigdft/ChangeLog
@@ -2,6 +2,7 @@
# Copyright 1999-2012 Gentoo Foundation; Distributed under the GPL v2
# $Header: $
+<<<<<<< HEAD
*bigdft-1.6_pre1-r3 (04 Jul 2012)
04 Jul 2012; Honza Macháček <Hloupy.Honza@centrum.cz>
@@ -10,6 +11,11 @@
+files/bigdft-1.6-tuto.1-gcc-4.6.patch:
bigdft-1.6_pre1 from -r2 to -r3: patched to install necessary libraries for
GPU support and to compile with gcc-4.6
+=======
+ 22 Jun 2012; Alexey Shvetsov <alexxy@gentoo.org> bigdft-1.6.0-r2.ebuild,
+ bigdft-1.6_pre1-r2.ebuild:
+ [sci-libs/bigdft] add ~amd64-linux
+>>>>>>> cd00b2db98a3e0ec9013e1d3646e292213071270
*bigdft-1.6.0-r2 (19 Jun 2012)
*bigdft-1.6_pre1-r2 (19 Jun 2012)
diff --git a/sci-libs/bigdft/bigdft-1.6.0-r2.ebuild b/sci-libs/bigdft/bigdft-1.6.0-r2.ebuild
index b4e40f540..09350541e 100644
--- a/sci-libs/bigdft/bigdft-1.6.0-r2.ebuild
+++ b/sci-libs/bigdft/bigdft-1.6.0-r2.ebuild
@@ -14,7 +14,7 @@ SRC_URI="http://inac.cea.fr/L_Sim/BigDFT/${REAL_P}.tar.gz"
LICENSE="GPL-3"
SLOT="0"
-KEYWORDS="~amd64 ~x86"
+KEYWORDS="~amd64 ~x86 ~amd64-linux"
IUSE="cuda doc etsf_io mpi netcdf opencl test"
RDEPEND="
@@ -66,7 +66,7 @@ src_prepare() {
}
src_configure() {
- local modules="/usr/$(get_libdir)/finclude"
+ local modules="${EPREFIX}/usr/$(get_libdir)/finclude"
local netcdff_libs="-lnetcdff"
filter-flags '-m*' '-O*' "-pipe"
local nvcflags="${CFLAGS}"
@@ -90,9 +90,9 @@ src_configure() {
$(use_with cuda cuda-path /opt/cuda)
$(use_with cuda nvcc-flags "${nvcflags}")
$(use_enable opencl)
- $(use_with opencl ocl-path /usr)
+ $(use_with opencl ocl-path "${EPREFIX}/usr")
$(use_with etsf_io etsf-io)
- $(use_with etsf_io etsf-io-path "/usr")
+ $(use_with etsf_io etsf-io-path "${EPREFIX}/usr")
$(use_with etsf_io netcdf-path "$(pkg-config --libs-only-L netcdf)")
"$(use etsf_io && echo "--with-netcdf-libs=$(pkg-config --libs netcdf) ${netcdff_libs}")"
FCFLAGS="${FCFLAGS:- ${FFLAGS:- -O2}} -I${modules}"
diff --git a/sci-libs/bigdft/bigdft-1.6_pre1-r3.ebuild b/sci-libs/bigdft/bigdft-1.6_pre1-r3.ebuild
index 7187becbc..a2cef02de 100644
--- a/sci-libs/bigdft/bigdft-1.6_pre1-r3.ebuild
+++ b/sci-libs/bigdft/bigdft-1.6_pre1-r3.ebuild
@@ -15,7 +15,7 @@ SRC_URI="http://inac.cea.fr/L_Sim/BigDFT/${REAL_P}.tar.gz"
LICENSE="GPL-3"
SLOT="0"
-KEYWORDS="~amd64 ~x86"
+KEYWORDS="~amd64 ~x86 ~amd64-linux"
IUSE="cuda doc etsf_io mpi netcdf opencl test"
RDEPEND="
@@ -73,7 +73,7 @@ src_prepare() {
}
src_configure() {
- local modules="/usr/$(get_libdir)/finclude"
+ local modules="${EPREFIX}/usr/$(get_libdir)/finclude"
local netcdff_libs="-lnetcdff"
filter-flags '-m*' '-O*' "-pipe"
local nvcflags="${CFLAGS}"
@@ -98,9 +98,9 @@ src_configure() {
$(use_with cuda cuda-path /opt/cuda)
$(use_with cuda nvcc-flags "${nvcflags}")
$(use_enable opencl)
- $(use_with opencl ocl-path /usr)
+ $(use_with opencl ocl-path "${EPREFIX}/usr")
$(use_with etsf_io etsf-io)
- $(use_with etsf_io etsf-io-path "/usr")
+ $(use_with etsf_io etsf-io-path "${EPREFIX}/usr")
$(use_with etsf_io netcdf-path "$(pkg-config --libs-only-L netcdf)")
"$(use etsf_io && echo "--with-netcdf-libs=$(pkg-config --libs netcdf) ${netcdff_libs}")"
FCFLAGS="${FCFLAGS:- ${FFLAGS:- -O2}} -I${modules}"