aboutsummaryrefslogtreecommitdiff
diff options
context:
space:
mode:
Diffstat (limited to 'sci-libs/blas-reference')
-rw-r--r--sci-libs/blas-reference/blas-reference-20131116-r1.ebuild118
-rw-r--r--sci-libs/blas-reference/blas-reference-20131116-r2.ebuild107
-rw-r--r--sci-libs/blas-reference/blas-reference-20131116.ebuild78
-rw-r--r--sci-libs/blas-reference/blas-reference-99999999.ebuild76
-rw-r--r--sci-libs/blas-reference/metadata.xml4
5 files changed, 142 insertions, 241 deletions
diff --git a/sci-libs/blas-reference/blas-reference-20131116-r1.ebuild b/sci-libs/blas-reference/blas-reference-20131116-r1.ebuild
deleted file mode 100644
index 4b9d2eaf7..000000000
--- a/sci-libs/blas-reference/blas-reference-20131116-r1.ebuild
+++ /dev/null
@@ -1,118 +0,0 @@
-# Copyright 1999-2014 Gentoo Foundation
-# Distributed under the terms of the GNU General Public License v2
-# $Id$
-
-EAPI=5
-
-EBASE_PROFNAME="refblas"
-ESTATIC_MULTIBUILD="true"
-inherit fortran-2 cmake-utils alternatives-2 multibuild multilib-build toolchain-funcs fortran-int64
-
-LPN=lapack
-LPV=3.5.0
-
-if [[ ${PV} == "99999999" ]] ; then
- ESVN_REPO_URI="https://icl.cs.utk.edu/svn/lapack-dev/${LPN}/trunk"
- inherit subversion
- KEYWORDS=""
-else
- SRC_URI="http://www.netlib.org/${LPN}/${LPN}-${LPV}.tgz"
- KEYWORDS="~amd64 ~x86 ~amd64-linux ~x86-linux"
-fi
-
-DESCRIPTION="Reference implementation of BLAS"
-HOMEPAGE="http://www.netlib.org/lapack/"
-
-LICENSE="BSD"
-SLOT="0"
-IUSE="int64 static-libs test"
-
-RDEPEND=""
-DEPEND="${RDEPEND}
- virtual/pkgconfig"
-PDEPEND=">=virtual/blas-2.1-r3[int64?]"
-
-S="${WORKDIR}/${LPN}-${LPV}"
-
-src_prepare() {
- # rename library to avoid collision with other blas implementations
- # ${LIBNAME} and ${PROFNAME} are not defined here, they are in single
- # quotes in the following seds. They are later set by defining cmake
- # variables with -DPROFNAME etc in src_configure
- sed -i \
- -e 's:\([^xc]\)blas:\1${LIBNAME}:g' \
- CMakeLists.txt \
- BLAS/SRC/CMakeLists.txt || die
- sed -i \
- -e '/Name: /s:blas:${PROFNAME}:' \
- -e 's:-lblas:-l${LIBNAME}:g' \
- BLAS/blas.pc.in || die
- sed -i \
- -e 's:blas):${LIBNAME}):' \
- BLAS/TESTING/CMakeLists.txt || die
- sed -i \
- -e 's:BINARY_DIR}/blas:BINARY_DIR}/${PROFNAME}:' \
- BLAS/CMakeLists.txt || die
-}
-
-src_configure() {
- local MULTIBUILD_VARIANTS=( $(fortran-int64_multilib_get_enabled_abis) )
- blas_configure() {
- local profname=$(fortran-int64_get_profname)
- local libname="${profname//-/_}"
- local mycmakeargs=(
- -Wno-dev
- -DPROFNAME="${profname}"
- -DLIBNAME="${libname}"
- -DUSE_OPTIMIZED_BLAS=OFF
- $(cmake-utils_use_build test TESTING)
- -DCMAKE_Fortran_FLAGS="$($(tc-getPKG_CONFIG) --cflags ${blas_profname}) $(get_abi_CFLAGS) $(fortran-int64_get_fortran_int64_abi_fflags) ${FCFLAGS}"
- -DLAPACK_PKGCONFIG_FFLAGS="$(fortran-int64_get_fortran_int64_abi_fflags)"
- )
- if $(fortran-int64_is_static_build); then
- mycmakeargs+=(
- -DBUILD_SHARED_LIBS=OFF
- -DBUILD_STATIC_LIBS=ON
- )
- else
- mycmakeargs+=(
- -DBUILD_SHARED_LIBS=ON
- -DBUILD_STATIC_LIBS=OFF
- )
- fi
- cmake-utils_src_configure
- }
- multibuild_foreach_variant fortran-int64_multilib_multibuild_wrapper blas_configure
-}
-
-src_compile() {
- local MULTIBUILD_VARIANTS=( $(fortran-int64_multilib_get_enabled_abis) )
- multibuild_foreach_variant fortran-int64_multilib_multibuild_wrapper cmake-utils_src_compile -C BLAS
-}
-
-src_test() {
- local MULTIBUILD_VARIANTS=( $(fortran-int64_multilib_get_enabled_abis) )
- blas_test() {
- _check_build_dir
- pushd "${BUILD_DIR}/BLAS" > /dev/null
- local ctestargs
- [[ -n ${TEST_VERBOSE} ]] && ctestargs="--extra-verbose --output-on-failure"
- ctest ${ctestargs} || die
- popd > /dev/null
- }
- multibuild_foreach_variant fortran-int64_multilib_multibuild_wrapper blas_test
-}
-
-src_install() {
- local MULTIBUILD_VARIANTS=( $(fortran-int64_multilib_get_enabled_abis) )
- my_src_install() {
- cmake-utils_src_install -C BLAS
- if ! $(fortran-int64_is_static_build); then
- local profname=$(fortran-int64_get_profname)
- local provider=$(fortran-int64_get_blas_provider)
- alternatives_for ${provider} $(fortran-int64_get_profname "reference") 0 \
- /usr/$(get_libdir)/pkgconfig/${provider}.pc ${profname}.pc
- fi
- }
- multibuild_foreach_variant fortran-int64_multilib_multibuild_wrapper my_src_install
-}
diff --git a/sci-libs/blas-reference/blas-reference-20131116-r2.ebuild b/sci-libs/blas-reference/blas-reference-20131116-r2.ebuild
new file mode 100644
index 000000000..3b4d976d3
--- /dev/null
+++ b/sci-libs/blas-reference/blas-reference-20131116-r2.ebuild
@@ -0,0 +1,107 @@
+# Copyright 1999-2015 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+EAPI=5
+
+PYTHON_COMPAT=( python2_7 )
+
+NUMERIC_MODULE_NAME="refblas"
+
+inherit alternatives-2 cmake-utils fortran-2 numeric-int64-multibuild python-any-r1 toolchain-funcs
+
+LPN=lapack
+LPV=3.5.0
+
+DESCRIPTION="Reference implementation of BLAS"
+HOMEPAGE="http://www.netlib.org/lapack/"
+SRC_URI="http://www.netlib.org/${LPN}/${LPN}-${LPV}.tgz"
+
+LICENSE="BSD"
+SLOT="0"
+KEYWORDS="~amd64 ~x86 ~amd64-linux ~x86-linux"
+IUSE="static-libs test"
+
+REQUIRED_USE="test? ( ${PYTHON_REQUIRED_USE} )"
+
+RDEPEND=""
+DEPEND="${RDEPEND}
+ test? ( ${PYTHON_DEPS} )
+ virtual/pkgconfig"
+
+S="${WORKDIR}/${LPN}-${LPV}"
+
+src_prepare() {
+ # rename library to avoid collision with other blas implementations
+ # ${LIBNAME} and ${PROFNAME} are not defined here, they are in single
+ # quotes in the following seds. They are later set by defining cmake
+ # variables with -DPROFNAME etc in src_configure
+ sed -i \
+ -e 's:\([^xc]\)blas:\1${LIBNAME}:g' \
+ CMakeLists.txt \
+ BLAS/SRC/CMakeLists.txt || die
+ sed -i \
+ -e '/Name: /s:blas:${PROFNAME}:' \
+ -e 's:-lblas:-l${LIBNAME}:g' \
+ BLAS/blas.pc.in || die
+ sed -i \
+ -e 's:blas):${LIBNAME}):' \
+ BLAS/TESTING/CMakeLists.txt || die
+ sed -i \
+ -e 's:BINARY_DIR}/blas:BINARY_DIR}/${PROFNAME}:' \
+ BLAS/CMakeLists.txt || die
+}
+
+src_configure() {
+ blas_configure() {
+ local FCFLAGS="${FCFLAGS}"
+ append-fflags $($(tc-getPKG_CONFIG) --cflags ${blas_profname})
+ append-fflags $(get_abi_CFLAGS)
+ append-fflags $(numeric-int64_get_fortran_int64_abi_fflags)
+
+ local profname=$(numeric-int64_get_module_name)
+ local libname="${profname//-/_}"
+
+ local mycmakeargs=(
+ -Wno-dev
+ -DPROFNAME="${profname}"
+ -DLIBNAME="${libname}"
+ -DUSE_OPTIMIZED_BLAS=OFF
+ -DCMAKE_Fortran_FLAGS="${FCFLAGS}"
+ -DLAPACK_PKGCONFIG_FFLAGS="$(numeric-int64_get_fortran_int64_abi_fflags)"
+ $(cmake-utils_use_build test TESTING)
+ )
+ if $(numeric-int64_is_static_build); then
+ mycmakeargs+=(
+ -DBUILD_SHARED_LIBS=OFF
+ -DBUILD_STATIC_LIBS=ON
+ )
+ else
+ mycmakeargs+=(
+ -DBUILD_SHARED_LIBS=ON
+ -DBUILD_STATIC_LIBS=OFF
+ )
+ fi
+ cmake-utils_src_configure
+ }
+ numeric-int64-multibuild_foreach_all_abi_variants blas_configure
+}
+
+src_compile() {
+ local each target_dirs=( BLAS )
+ use test && target_dirs+=( TESTING )
+ for each in ${target_dirs[@]}; do
+ numeric-int64-multibuild_foreach_all_abi_variants \
+ cmake-utils_src_compile -C ${each}
+ done
+
+}
+
+src_test() {
+ numeric-int64-multibuild_foreach_all_abi_variants cmake-utils_src_test
+}
+
+src_install() {
+ numeric-int64-multibuild_foreach_all_abi_variants cmake-utils_src_install -C BLAS
+ numeric-int64-multibuild_install_alternative blas reference
+}
diff --git a/sci-libs/blas-reference/blas-reference-20131116.ebuild b/sci-libs/blas-reference/blas-reference-20131116.ebuild
deleted file mode 100644
index 94337c973..000000000
--- a/sci-libs/blas-reference/blas-reference-20131116.ebuild
+++ /dev/null
@@ -1,78 +0,0 @@
-# Copyright 1999-2014 Gentoo Foundation
-# Distributed under the terms of the GNU General Public License v2
-# $Id$
-
-EAPI=5
-
-inherit fortran-2 cmake-utils alternatives-2
-
-LPN=lapack
-LPV=3.5.0
-
-if [[ ${PV} == "99999999" ]] ; then
- ESVN_REPO_URI="https://icl.cs.utk.edu/svn/lapack-dev/${LPN}/trunk"
- inherit subversion
- KEYWORDS=""
-else
- SRC_URI="http://www.netlib.org/${LPN}/${LPN}-${LPV}.tgz"
- KEYWORDS="~amd64 ~x86 ~amd64-linux ~x86-linux"
-fi
-
-DESCRIPTION="Reference implementation of BLAS"
-HOMEPAGE="http://www.netlib.org/lapack/"
-
-LICENSE="BSD"
-SLOT="0"
-IUSE="static-libs test"
-
-S="${WORKDIR}/${LPN}-${LPV}"
-
-src_prepare() {
- # rename library to avoid collision with other blas implementations
- sed -i \
- -e 's:blas:refblas:g' \
- CMakeLists.txt BLAS/blas.pc.in \
- BLAS/{SRC,TESTING}/CMakeLists.txt || die
- sed -i \
- -e 's:BINARY_DIR}/blas:BINARY_DIR}/refblas:' \
- BLAS/CMakeLists.txt || die
- use static-libs && mkdir "${WORKDIR}/${PN}_static"
-}
-
-src_configure() {
- blas_configure() {
- local mycmakeargs=(
- -DUSE_OPTIMIZED_BLAS=OFF
- $(cmake-utils_use_build test TESTING)
- $@
- )
- cmake-utils_src_configure
- }
-
- blas_configure -DBUILD_SHARED_LIBS=ON -DBUILD_STATIC_LIBS=OFF
- use static-libs && \
- CMAKE_BUILD_DIR="${WORKDIR}/${PN}_static" blas_configure \
- -DBUILD_SHARED_LIBS=OFF -DBUILD_STATIC_LIBS=ON
-}
-
-src_compile() {
- cmake-utils_src_compile -C BLAS
- use static-libs && CMAKE_BUILD_DIR="${WORKDIR}/${PN}_static" \
- cmake-utils_src_compile -C BLAS
-}
-
-src_test() {
- pushd "${CMAKE_BUILD_DIR}/BLAS" > /dev/null
- local ctestargs
- [[ -n ${TEST_VERBOSE} ]] && ctestargs="--extra-verbose --output-on-failure"
- ctest ${ctestargs} || die
- popd > /dev/null
-}
-
-src_install() {
- cmake-utils_src_install -C BLAS
- use static-libs && CMAKE_BUILD_DIR="${WORKDIR}/${PN}_static" \
- cmake-utils_src_install -C BLAS
- alternatives_for blas reference 0 \
- /usr/$(get_libdir)/pkgconfig/blas.pc refblas.pc
-}
diff --git a/sci-libs/blas-reference/blas-reference-99999999.ebuild b/sci-libs/blas-reference/blas-reference-99999999.ebuild
index 4b9d2eaf7..b079855d0 100644
--- a/sci-libs/blas-reference/blas-reference-99999999.ebuild
+++ b/sci-libs/blas-reference/blas-reference-99999999.ebuild
@@ -1,34 +1,32 @@
-# Copyright 1999-2014 Gentoo Foundation
+# Copyright 1999-2015 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
# $Id$
EAPI=5
-EBASE_PROFNAME="refblas"
-ESTATIC_MULTIBUILD="true"
-inherit fortran-2 cmake-utils alternatives-2 multibuild multilib-build toolchain-funcs fortran-int64
+PYTHON_COMPAT=( python2_7 )
+
+NUMERIC_MODULE_NAME="refblas"
+
+inherit alternatives-2 cmake-utils fortran-2 numeric-int64-multibuild python-any-r1 toolchain-funcs subversion
LPN=lapack
LPV=3.5.0
-if [[ ${PV} == "99999999" ]] ; then
- ESVN_REPO_URI="https://icl.cs.utk.edu/svn/lapack-dev/${LPN}/trunk"
- inherit subversion
- KEYWORDS=""
-else
- SRC_URI="http://www.netlib.org/${LPN}/${LPN}-${LPV}.tgz"
- KEYWORDS="~amd64 ~x86 ~amd64-linux ~x86-linux"
-fi
-
DESCRIPTION="Reference implementation of BLAS"
HOMEPAGE="http://www.netlib.org/lapack/"
+ESVN_REPO_URI="https://icl.cs.utk.edu/svn/lapack-dev/${LPN}/trunk"
LICENSE="BSD"
SLOT="0"
-IUSE="int64 static-libs test"
+KEYWORDS=""
+IUSE="static-libs test"
+
+REQUIRED_USE="test? ( ${PYTHON_REQUIRED_USE} )"
RDEPEND=""
DEPEND="${RDEPEND}
+ test? ( ${PYTHON_DEPS} )
virtual/pkgconfig"
PDEPEND=">=virtual/blas-2.1-r3[int64?]"
@@ -56,20 +54,25 @@ src_prepare() {
}
src_configure() {
- local MULTIBUILD_VARIANTS=( $(fortran-int64_multilib_get_enabled_abis) )
blas_configure() {
- local profname=$(fortran-int64_get_profname)
+ local FCFLAGS="${FCFLAGS}"
+ append-fflags $($(tc-getPKG_CONFIG) --cflags ${blas_profname})
+ append-fflags $(get_abi_CFLAGS)
+ append-fflags $(numeric-int64_get_fortran_int64_abi_fflags)
+
+ local profname=$(numeric-int64_get_module_name)
local libname="${profname//-/_}"
+
local mycmakeargs=(
-Wno-dev
-DPROFNAME="${profname}"
-DLIBNAME="${libname}"
-DUSE_OPTIMIZED_BLAS=OFF
+ -DCMAKE_Fortran_FLAGS="${FCFLAGS}"
+ -DLAPACK_PKGCONFIG_FFLAGS="$(numeric-int64_get_fortran_int64_abi_fflags)"
$(cmake-utils_use_build test TESTING)
- -DCMAKE_Fortran_FLAGS="$($(tc-getPKG_CONFIG) --cflags ${blas_profname}) $(get_abi_CFLAGS) $(fortran-int64_get_fortran_int64_abi_fflags) ${FCFLAGS}"
- -DLAPACK_PKGCONFIG_FFLAGS="$(fortran-int64_get_fortran_int64_abi_fflags)"
)
- if $(fortran-int64_is_static_build); then
+ if $(numeric-int64_is_static_build); then
mycmakeargs+=(
-DBUILD_SHARED_LIBS=OFF
-DBUILD_STATIC_LIBS=ON
@@ -82,37 +85,24 @@ src_configure() {
fi
cmake-utils_src_configure
}
- multibuild_foreach_variant fortran-int64_multilib_multibuild_wrapper blas_configure
+ numeric-int64-multibuild_foreach_all_abi_variants blas_configure
}
src_compile() {
- local MULTIBUILD_VARIANTS=( $(fortran-int64_multilib_get_enabled_abis) )
- multibuild_foreach_variant fortran-int64_multilib_multibuild_wrapper cmake-utils_src_compile -C BLAS
+ local each target_dirs=( BLAS )
+ use test && target_dirs+=( TESTING )
+ for each in ${target_dirs[@]}; do
+ numeric-int64-multibuild_foreach_all_abi_variants \
+ cmake-utils_src_compile -C ${each}
+ done
+
}
src_test() {
- local MULTIBUILD_VARIANTS=( $(fortran-int64_multilib_get_enabled_abis) )
- blas_test() {
- _check_build_dir
- pushd "${BUILD_DIR}/BLAS" > /dev/null
- local ctestargs
- [[ -n ${TEST_VERBOSE} ]] && ctestargs="--extra-verbose --output-on-failure"
- ctest ${ctestargs} || die
- popd > /dev/null
- }
- multibuild_foreach_variant fortran-int64_multilib_multibuild_wrapper blas_test
+ numeric-int64-multibuild_foreach_all_abi_variants cmake-utils_src_test
}
src_install() {
- local MULTIBUILD_VARIANTS=( $(fortran-int64_multilib_get_enabled_abis) )
- my_src_install() {
- cmake-utils_src_install -C BLAS
- if ! $(fortran-int64_is_static_build); then
- local profname=$(fortran-int64_get_profname)
- local provider=$(fortran-int64_get_blas_provider)
- alternatives_for ${provider} $(fortran-int64_get_profname "reference") 0 \
- /usr/$(get_libdir)/pkgconfig/${provider}.pc ${profname}.pc
- fi
- }
- multibuild_foreach_variant fortran-int64_multilib_multibuild_wrapper my_src_install
+ numeric-int64-multibuild_foreach_all_abi_variants cmake-utils_src_install -C BLAS
+ numeric-int64-multibuild_install_alternative blas reference
}
diff --git a/sci-libs/blas-reference/metadata.xml b/sci-libs/blas-reference/metadata.xml
index 346d64cd5..f5000ebba 100644
--- a/sci-libs/blas-reference/metadata.xml
+++ b/sci-libs/blas-reference/metadata.xml
@@ -1,8 +1,8 @@
<?xml version="1.0" encoding="UTF-8"?>
<!DOCTYPE pkgmetadata SYSTEM "http://www.gentoo.org/dtd/metadata.dtd">
<pkgmetadata>
-<herd>sci</herd>
-<longdescription lang="en">
+ <herd>sci</herd>
+ <longdescription lang="en">
The BLAS (Basic Linear Algebra Subprograms) are high quality "building
block" routines for performing basic vector and matrix operations. Level 1
BLAS do vector-vector operations, Level 2 BLAS do matrix-vector operations,