aboutsummaryrefslogtreecommitdiff
diff options
context:
space:
mode:
Diffstat (limited to 'sci-libs/cctbx/cctbx-2009.02.15.2320-r1.ebuild')
-rw-r--r--sci-libs/cctbx/cctbx-2009.02.15.2320-r1.ebuild16
1 files changed, 8 insertions, 8 deletions
diff --git a/sci-libs/cctbx/cctbx-2009.02.15.2320-r1.ebuild b/sci-libs/cctbx/cctbx-2009.02.15.2320-r1.ebuild
index b0383d189..0ec1e93ce 100644
--- a/sci-libs/cctbx/cctbx-2009.02.15.2320-r1.ebuild
+++ b/sci-libs/cctbx/cctbx-2009.02.15.2320-r1.ebuild
@@ -136,17 +136,17 @@ src_install(){
-i '{}' \; || die "Fail to correct path"
- insinto /usr/$(get_libdir)/${PN}
- doins -r cctbx_sources cctbx_build || die
-
ebegin "removing unnessary files"
- rm -r "${D}"/usr/$(get_libdir)/${PN}/cctbx_sources/scons || die "failed to remove uneeded scons"
- find "${D}" -type f -name "*.o" -exec rm -f '{}' \; || die "failed to remove uneeded *.o"
- find "${D}" -type f -name "*.c" -exec rm -f '{}' \; || die "failed to remove uneeded *.c"
- find "${D}" -type f -name "*.cpp" -exec rm -f '{}' \; || die "failed to remove uneeded *.cpp"
- find "${D}" -type f -name "*.pyc" -exec rm -f '{}' \; || die "failed to remove uneeded *.pyc"
+ rm -r "${S}"/cctbx_sources/scons || die "failed to remove uneeded scons"
+ find "${S}" -type f -name "*.o" -exec rm -f '{}' \; || die "failed to remove uneeded *.o"
+ find "${S}" -type f -name "*.c" -exec rm -f '{}' \; || die "failed to remove uneeded *.c"
+ find "${S}" -type f -name "*.cpp" -exec rm -f '{}' \; || die "failed to remove uneeded *.cpp"
+ find "${S}" -type f -name "*.pyc" -exec rm -f '{}' \; || die "failed to remove uneeded *.pyc"
eend
+ insinto /usr/$(get_libdir)/${PN}
+ doins -r cctbx_sources cctbx_build || die
+
# fperms cannot handle wildcards
chmod 775 "${D}"/usr/$(get_libdir)/${PN}/cctbx_build/*sh && \
chmod 775 "${D}"/usr/$(get_libdir)/${PN}/cctbx_build/scitbx/array_family/* && \