aboutsummaryrefslogtreecommitdiff
diff options
context:
space:
mode:
Diffstat (limited to 'sci-libs/ciftilib/files/ciftilib-1.6.0-version.patch')
-rw-r--r--sci-libs/ciftilib/files/ciftilib-1.6.0-version.patch27
1 files changed, 27 insertions, 0 deletions
diff --git a/sci-libs/ciftilib/files/ciftilib-1.6.0-version.patch b/sci-libs/ciftilib/files/ciftilib-1.6.0-version.patch
new file mode 100644
index 000000000..e64a55f2f
--- /dev/null
+++ b/sci-libs/ciftilib/files/ciftilib-1.6.0-version.patch
@@ -0,0 +1,27 @@
+--- a/CMakeLists.txt
++++ b/CMakeLists.txt
+@@ -83,18 +83,18 @@ ENDIF (NOT QT_FOUND)
+ INCLUDE_DIRECTORIES(${Boost_INCLUDE_DIRS})
+ SET(LIBS ${LIBS} ${Boost_LIBRARIES})
+ #boost quirks
+-IF (Boost_VERSION LESS 104400)
++IF (Boost_VERSION VERSION_LESS 1.44.00)
+ #absolute() was added in 1.44.0, with filesystem v3
+ ADD_DEFINITIONS(-DCIFTILIB_BOOST_NO_FSV3)
+-ENDIF (Boost_VERSION LESS 104400)
+-IF (Boost_VERSION LESS 104800)
++ENDIF (Boost_VERSION VERSION_LESS 1.44.00)
++IF (Boost_VERSION VERSION_LESS 1.48.00)
+ #canonical() was added in 1.48.0
+ ADD_DEFINITIONS(-DCIFTILIB_BOOST_NO_CANONICAL)
+-ENDIF (Boost_VERSION LESS 104800)
+-IF (Boost_VERSION LESS 105600)
++ENDIF (Boost_VERSION VERSION_LESS 1.48.00)
++IF (Boost_VERSION VERSION_LESS 1.56.00)
+ #try_lexical_cast was added in 1.56.0
+ ADD_DEFINITIONS(-DCIFTILIB_BOOST_NO_TRY_LEXICAL)
+-ENDIF (Boost_VERSION LESS 105600)
++ENDIF (Boost_VERSION VERSION_LESS 1.56.00)
+
+ #zlib, useful for volume reading
+ FIND_PACKAGE(ZLIB)