aboutsummaryrefslogtreecommitdiff
diff options
context:
space:
mode:
Diffstat (limited to 'sci-libs/clipper/clipper-20090210-r2.ebuild')
-rw-r--r--sci-libs/clipper/clipper-20090210-r2.ebuild56
1 files changed, 56 insertions, 0 deletions
diff --git a/sci-libs/clipper/clipper-20090210-r2.ebuild b/sci-libs/clipper/clipper-20090210-r2.ebuild
new file mode 100644
index 000000000..a91002bd3
--- /dev/null
+++ b/sci-libs/clipper/clipper-20090210-r2.ebuild
@@ -0,0 +1,56 @@
+# Copyright 1999-2009 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/sci-libs/clipper/clipper-20070907.ebuild,v 1.1 2007/12/19 18:43:12 dberkholz Exp $
+
+inherit autotools flag-o-matic
+
+DESCRIPTION="Object-oriented libraries for the organisation of crystallographic data and the performance of crystallographic computation"
+HOMEPAGE="http://www.ysbl.york.ac.uk/~cowtan/clipper/clipper.html"
+# Transform 4-digit year to 2 digits
+SRC_URI="http://www.ysbl.york.ac.uk/~cowtan/clipper/clipper-2.1-${PV:2:${#PV}}-ac.tar.gz"
+LICENSE="LGPL-2.1"
+SLOT="0"
+KEYWORDS="~x86 ~ppc ~amd64"
+IUSE=""
+RDEPEND="sci-libs/ccp4-libs"
+DEPEND="${RDEPEND}"
+S=${WORKDIR}/clipper-2.1
+
+src_unpack() {
+ unpack ${A}
+ cd "${S}"
+
+ # ccp4 provides these, and more.
+ sed -i -e "s:examples::g" "${S}"/Makefile.am
+
+ epatch "${FILESDIR}"/20081201-as-needed.patch \
+ "${FILESDIR}"/20081201-typo.patch
+
+ AT_M4DIR="config" eautoreconf
+}
+
+src_compile() {
+ # Recommended on ccp4bb/coot ML to fix crashes when calculating maps
+ # on 64-bit systems
+ append-flags -fno-strict-aliasing
+
+ # Slot programs with a '-2' suffix
+ econf \
+ --enable-contrib \
+ --enable-phs \
+ --enable-mmdb \
+ --with-mmdb=/usr \
+ --enable-minimol \
+ --enable-cif \
+ --enable-ccp4 \
+ --enable-cns \
+ || die
+ # We don't have a cctbx ebuild yet
+ # --enable-cctbx \
+
+ emake || die
+}
+
+src_install() {
+ emake DESTDIR="${D}" install || die
+}