aboutsummaryrefslogtreecommitdiff
diff options
context:
space:
mode:
Diffstat (limited to 'sci-libs/colamd/colamd-2.7.0.ebuild')
-rw-r--r--sci-libs/colamd/colamd-2.7.0.ebuild35
1 files changed, 35 insertions, 0 deletions
diff --git a/sci-libs/colamd/colamd-2.7.0.ebuild b/sci-libs/colamd/colamd-2.7.0.ebuild
new file mode 100644
index 000000000..af5b7a3d7
--- /dev/null
+++ b/sci-libs/colamd/colamd-2.7.0.ebuild
@@ -0,0 +1,35 @@
+# Copyright 1999-2007 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: $
+
+inherit autotools eutils
+
+MY_PN=COLAMD
+DESCRIPTION="Column approximate minimum degree ordering algorithm"
+HOMEPAGE="http://www.cise.ufl.edu/research/sparse/colamd"
+SRC_URI="http://www.cise.ufl.edu/research/sparse/${PN}/${MY_PN}-${PV}.tar.gz"
+
+LICENSE="LGPL-2"
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+IUSE=""
+DEPEND="sci-libs/ufconfig"
+
+S="${WORKDIR}/${MY_PN}"
+
+src_unpack() {
+ unpack ${A}
+ cd "${S}"
+ epatch "${FILESDIR}"/${P}-autotools.patch
+ eautoreconf
+}
+
+src_test() {
+ cd "${S}"/Demo
+ emake test || die "emake test failed"
+}
+
+src_install() {
+ emake DESTDIR="${D}" install || die "emake install failed"
+ dodoc README.txt Doc/ChangeLog || die "dodoc failed"
+}